gedit crashed with SIGSEGV in g_object_ref()

Bug #244896 reported by syscon-hh
204
This bug affects 4 people
Affects Status Importance Assigned to Milestone
gedit
Fix Released
Critical
gedit (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gedit

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.10
DISTRIB_CODENAME=intrepid
DISTRIB_DESCRIPTION="Ubuntu intrepid (development branch)"

After starting in a root-terminal by typing

> sudo gedit /etc/fstab

the gedit-window appears and freezes short time later (less than 1 sec)

The gnome-terminal-window has been not affected and I could start another session with the same command without any problems.

ProblemType: Crash
Architecture: i386
Date: Wed Jul 2 16:38:08 2008
DistroRelease: Ubuntu 8.10
ExecutablePath: /usr/bin/gedit
Package: gedit 2.23.1-0ubuntu1
PackageArchitecture: i386
ProcCmdline: gedit /etc/fstab
ProcEnviron:
 SHELL=/bin/bash
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/X11R6/bin
 LANG=de_DE.UTF-8
Signal: 11
SourcePackage: gedit
StacktraceTop:
 g_object_ref () from /usr/lib/libgobject-2.0.so.0
 g_io_scheduler_push_job () from /usr/lib/libgio-2.0.so.0
 g_simple_async_result_run_in_thread ()
 ?? () from /usr/lib/libgio-2.0.so.0
 g_file_enumerator_next_files_async ()
Title: gedit crashed with SIGSEGV in g_object_ref()
Uname: Linux 2.6.26-2-generic i686
UserGroups:

Related branches

Revision history for this message
syscon-hh (syscon-kono) wrote :
Revision history for this message
Apport retracing service (apport) wrote : Symbolic stack trace

StacktraceTop:IA__g_object_interface_install_property (g_iface=0xb75eeab0, pspec=0x849d3a0)
g_io_job_compare (a=0xbf9c02e8, b=0xb7584ac2, user_data=0x84f1124)
?? ()

Revision history for this message
Apport retracing service (apport) wrote : Symbolic threaded stack trace
Revision history for this message
Sebastien Bacher (seb128) wrote :

Thanks for your bug report. Please try to obtain a backtrace http://wiki.ubuntu.com/DebuggingProgramCrash and attach the file to the bug report. This will greatly help us in tracking down your problem.

Changed in gedit:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: New → Incomplete
Revision history for this message
Sebastien Bacher (seb128) wrote :

the issue is likely http://bugzilla.gnome.org/show_bug.cgi?id=539581 which has been fixed upstream now

Changed in gedit:
status: Incomplete → Fix Committed
Changed in gedit:
status: Unknown → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gedit - 2.23.1-0ubuntu2

---------------
gedit (2.23.1-0ubuntu2) intrepid; urgency=low

  * debian/patches/90_from_svn_fix_async_cancellation.patch:
    - svn change to fix cancellation issues leading to random crashes
      (lp: #244896)

 -- Sebastien Bacher <email address hidden> Fri, 01 Aug 2008 09:35:38 +0200

Changed in gedit:
status: Fix Committed → Fix Released
Changed in gedit:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.