/usr/bin/gedit:11:gedit_metadata_manager_set:gedit_document_set_metadata:save_metadata:gedit_document_dispose:g_object_unref

Bug #1822753 reported by errors.ubuntu.com bug bridge on 2019-04-02
74
This bug affects 9 people
Affects Status Importance Assigned to Milestone
gedit
Fix Released
Unknown
gedit (Ubuntu)
Undecided
Andrea Azzarone
Disco
Undecided
Andrea Azzarone

Bug Description

[Impact]
Gedit crashes when it is closed while a file is being loaded or just after the file has been loaded.

The bug is a regression in Disco: in Cosmic Gedit is built using autotools while in Disco we use meson. During the port to meson upstream forgot to port a build option (in particular 'enable-gvfs-metadata', enabled by default). Without this option a broken - and untested - code path is activated.

To fix this bug we should reintroduce the 'enable-gvfs-metadata' option.

[Test case]
1. Create a big text file
2. Open gedit
3. Close the window while the file is still being loaded

Also check there are no more reports in e.u.c.

[Regression Potential]
The change affects the way gedit stores the file metadata. Try for example
1. open a file
2. focus a random line
3. close the file
4. re-open the file
5. make sure the random line that you focused in point 2. is focused

[Original report]
The Ubuntu Error Tracker has been receiving reports about a problem regarding gedit. This problem was most recently seen with package version 3.32.0-1, the problem page at https://errors.ubuntu.com/problem/011263859266370f9e85de3368ab51716dadbf28 contains more details, including versions of packages affected, stacktrace or traceback, and individual crash reports.
If you do not have access to the Ubuntu Error Tracker and are a software developer, you can request it at http://forms.canonical.com/reports/.

Andrea Azzarone (azzar1) wrote :

The first issues it that gedit should use gvfs to store file metadata. Since the port of gedit to meson this feature has been lost. I've proposed a fix upstream here: https://gitlab.gnome.org/GNOME/gedit/merge_requests/32

Changed in gedit (Ubuntu):
assignee: nobody → Andrea Azzarone (azzar1)
status: New → In Progress
Andrea Azzarone (azzar1) wrote :
Changed in gedit:
status: Unknown → New
Andrea Azzarone (azzar1) on 2019-04-16
description: updated
description: updated
Changed in gedit:
status: New → Fix Released

Hello errors.ubuntu.com, or anyone else affected,

Accepted gedit into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gedit/3.32.0-3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-disco to verification-done-disco. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-disco. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in gedit (Ubuntu Disco):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-disco
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gedit - 3.32.0-3

---------------
gedit (3.32.0-3) experimental; urgency=medium

  [ Andrea Azzarone ]
  * d/p/build-Reintroduce-enable-gvfs-metadata-option.patch:
    - Reintroduce enable-gvfs-metadata option. (LP: #1822753)
  * d/p/gitlab_idle_handling.patch:
    - Patch refreshed automatically by gbp pq import/export.
  * d/p/series:
    - Added d/p/build-Reintroduce-enable-gvfs-metadata-option.patch

 -- Iain Lane <email address hidden> Tue, 16 Apr 2019 16:19:15 +0100

Changed in gedit (Ubuntu Disco):
status: Fix Committed → Fix Released
Changed in gedit (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.