GEdit deletes files rather than saves (on samba share)

Bug #177710 reported by High_Yield
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
gedit
Expired
Medium
gedit (Ubuntu)
High
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gedit

Local PC: Using Ubuntu Gutsy with full updates run ~12/16/2007.
NAS: QNap TS-101 running Linux and Samba
Problem App: gedit 2.20.3

Steps to reproduce:
- Open mounted share folder
- Double Click to open a text file (opens using the default GEdit program)
- File opens properly, proceed to make edits
- Click save, all APPEARS normal...
- Make a few more edits
- Click save and I'm warned that I can't save since the file DOES NOT EXIST ??
- The warning is correct - the FILE WAS DELETED from the server by GEdit!

Notes:
Editing/Saving the files on the NAS works properly using:
- Windows XP from multiple machines
- GVim from Ubuntu 7.1
- OpenOffice Document using Ubuntu 7.1

- So far I only see issues using GEdit on text files from the NAS (Local TXT ok)
- I can reproduce this every time with any text file

This bug is perhaps one of the most devious I've ever seen. Clicking SAVE causes the file to be deleted - OMG! PLEASE attend to this immediately.

Revision history for this message
High_Yield (wolf-bill) wrote :

See attachment

Revision history for this message
Daniel Hahler (blueyed) wrote :

Thank you for reporting this (nasty) bug.

It has been reported already (bug 34813) and I'm marking it as duplicate.

Changed in gedit:
assignee: nobody → blueyed
importance: Undecided → High
status: New → Invalid
Revision history for this message
High_Yield (wolf-bill) wrote :

Daniel - your duplicate assessment is incorrect.

In my case gedit is "deleting the source file" whereas in 34813 it is simply "disallowing a save" for the first try or two. There is a BIG DIFFERENCE between the two issues.

I want my wife to use ubuntu and if the first time she edits a file it gets deleted - well guess what - it will NEVER be used again.

This is a high priority, critical bug affecting a commonly used piece of software.

And - I also see many, many other issues related to gedit. Perhaps the ubuntu decision makers should make a change to a better default text editor. I'm go to start looking for one now.

Regards - B

Daniel Hahler (blueyed)
Changed in gedit:
assignee: blueyed → nobody
status: Invalid → New
Changed in gedit:
status: Unknown → Confirmed
Revision history for this message
Jorge Castro (jorge) wrote :

Can you confirm that this bug exists in the latest Hardy Alpha? I have tried to reproduce this but gedit shows the proper behavior every time.

Changed in gedit:
status: New → Incomplete
Revision history for this message
High_Yield (wolf-bill) wrote :

Jorge,

I will try using a live CD but I will need appropriate security to access my NAS and I don't recall if I can do that from a live CD.
Will keep you posted.

BTW - Jorge, were any development changes made to gedit or am I simply "trying" something ?

Thanks - B

Revision history for this message
Jorge Castro (jorge) wrote :

GEdit in hardy is using the new GIO/GVFS thing, so I am (hoping) that this new layer fixes the bug. I can't reproduce it on two of my machines so I am thinking this was fixed, but some confirmation from you would be nice!

Revision history for this message
High_Yield (wolf-bill) wrote :

I cannot properly test as:
A) I do not have a second 64 bit machine
B) Booting from the LiveCD does not appear to give me proper user permission to access my network.

Also, I'm using Gutsy - have you simply bypassed Gutsy and are working only on Hardy ?

- B

Revision history for this message
Daniel Hahler (blueyed) wrote :

Gutsy would require a StableReleaseUpdate, see https://wiki.ubuntu.com/SRU

Revision history for this message
Sebastien Bacher (seb128) wrote :

there is too many changes in hardy to backport those to gutsy

Revision history for this message
High_Yield (wolf-bill) wrote :

I just installed (full clean install) Hardy 4/27/2008 and STILL have exactly the same problems.
No fixes were made.

Changed in gedit:
assignee: nobody → desktop-bugs
status: Incomplete → Triaged
Revision history for this message
Marty McLaren (mmcl-pugetridge) wrote :

This seems to be related to my problem with gedit. It started last week with several files disappearing from my desktop, and when I tried to retrieve them from trash, they could not be opened and I got a message saying that gedit could not open the docs. Check to see if the file was binary.

When I returned to the problem, eventually all the docs on my desktop and in my documents folder became infected, and I can no longer access any saved files.

I've just changed jobs and have little time to deal with this, but it's a HUGE problem, especially for someone like me who has mediocre tech skills.

I've tried posting about it several times; the first two times the answers didn't solve the problem; as the problem grew and I posted, I've received no answers at all.

Marty

Changed in gedit:
importance: Unknown → Medium
Revision history for this message
ebvigmo (erik-vigmostad) wrote :

This has happened to me TOO many times. I've lost several files when closing gedit that were on a mounted disk. There is no version with ~ at the end. Is there some other directory where these backups are saved? I DO have autosave enabled.

Changed in gedit:
status: Confirmed → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.