Gedit crashes when unicode test page is pasted into new document

Bug #1326346 reported by Andrew Rowson
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gedit (Ubuntu)
High
Unassigned

Bug Description

gedit crashes on pasting of certain unicode characters.

Reproduce:

1. Open gedit
2. Copy entire page content from the Unicode 3.2 test page (http://www.ltg.ed.ac.uk/~richard/unicode-sample-3-2.html)
3. Paste into gedit

Expected behaviour: I see the text content in the gedit window.

Actual behaviour: gedit crashes

Message on the terminal is:

$ gedit
*** Error in `gedit': malloc(): memory corruption: 0x00000000023b0ee0 ***
Aborted

Using gdb, I see the following:

(gdb) run
Starting program: /usr/bin/gedit
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[New Thread 0x7fffee2e9700 (LWP 21753)]
[New Thread 0x7fffed8db700 (LWP 21754)]
[New Thread 0x7fffe5de1700 (LWP 21755)]
[New Thread 0x7fffe55e0700 (LWP 21756)]
[New Thread 0x7fffe4ddf700 (LWP 21757)]
[New Thread 0x7fffdbfff700 (LWP 21758)]
[New Thread 0x7fffdb7fe700 (LWP 21759)]
[New Thread 0x7fffd43bc700 (LWP 21760)]
[New Thread 0x7fffd1d26700 (LWP 21762)]
[Thread 0x7fffe5de1700 (LWP 21755) exited]
*** Error in `/usr/bin/gedit': malloc(): memory corruption: 0x0000000001208610 ***

Program received signal SIGABRT, Aborted.
0x00007ffff4a53f79 in __GI_raise (sig=sig@entry=6)
    at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
56 ../nptl/sysdeps/unix/sysv/linux/raise.c: No such file or directory.
(gdb)

Ubuntu version:

Description: Ubuntu 14.04 LTS
Release: 14.04

Gedit version:

gedit:
  Installed: 3.10.4-0ubuntu4
  Candidate: 3.10.4-0ubuntu4
  Version table:
 *** 3.10.4-0ubuntu4 0
        500 http://gb.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
        100 /var/lib/dpkg/status

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: gedit 3.10.4-0ubuntu4
ProcVersionSignature: Ubuntu 3.13.0-27.50-generic 3.13.11
Uname: Linux 3.13.0-27-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.14.1-0ubuntu3.2
Architecture: amd64
CurrentDesktop: Unity
Date: Wed Jun 4 11:48:57 2014
EcryptfsInUse: Yes
InstallationDate: Installed on 2014-04-14 (50 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Daily amd64 (20140413)
SourcePackage: gedit
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Andrew Rowson (growse) wrote :
Revision history for this message
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Changed in gedit (Ubuntu):
importance: Undecided → High
Revision history for this message
Carlos Hsiao (weii666) wrote :

The problem is at pasting Greek (maybe) in Private Use Area in the unicode page:

2. Copy entire page content from the Unicode 3.2 test page (http://www.ltg.ed.ac.uk/~richard/unicode-sample-3-2.html)

Just copy and paste the line below Private Use Area to gedit for recreation.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gedit (Ubuntu):
status: New → Confirmed
Revision history for this message
madbiologist (me-again) wrote :

I'm unable to reproduce this on Ubuntu 18.04.1 LTS with gedit 3.28.1-1ubuntu1.1

Changed in gedit (Ubuntu):
status: Confirmed → Invalid
status: Invalid → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers