Gedit context menu font is monospace

Bug #1242984 reported by PJSingh5000 on 2013-10-22
82
This bug affects 17 people
Affects Status Importance Assigned to Milestone
gedit
Fix Released
Medium
gedit (Ubuntu)
Low
Lars Karlitski
ubuntu-themes (Ubuntu)
Low
Lars Karlitski

Bug Description

Start Gedit in Ubuntu 13.10

Right click in the text area

Notice that the context menu font is Monospaced

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gedit (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, could you add a screenshot showing the issue?

Changed in gedit (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
Donarsson (benjamin-schwarz) wrote :

I can reproduce this on Ubuntu 13.10 with gEdit 3.8.3

The bug was also reported here by another user:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=726647

PJSingh5000 (pjsingh5000) wrote :

Sebastien,

Please see the attached screenshot.

1. Gedit with Courier 12 as the monospaced text font.
Notice the context menu uses the same monospaced font.

2. For comparison, Kate with Courier 12 as the monospaced text font.
Notice the context menu uses the system's proportional font.

Ashish (ashg) wrote :

I'm seeing the same bug as well, I've also noticed if I change the font type and font size from preferences, font type and size of the context menu also changes. I've attached a screenshot showing the bug.

Changed in gedit (Ubuntu):
status: Incomplete → Triaged
Changed in gedit:
importance: Unknown → Medium
status: Unknown → Fix Released
Lars Karlitski (larsu) on 2014-01-10
Changed in gedit (Ubuntu):
assignee: nobody → Lars Uebernickel (larsu)
status: Triaged → In Progress
Changed in gedit (Ubuntu):
status: In Progress → Fix Committed
Changed in ubuntu-themes (Ubuntu):
assignee: nobody → Lars Uebernickel (larsu)
importance: Undecided → Low
status: New → In Progress
Adolfo Jayme (fitojb) wrote :

IMHO this is a bug in new GTK -- in unity-greeter's password field, if you right-click it it also inherits font styling from the field.

Sebastien Bacher (seb128) wrote :

Seems a feature rather than a bug, in any case feel free to open a GTK report (upstream would be better)

Changed in ubuntu-themes (Ubuntu):
status: In Progress → Fix Committed
Changed in gedit (Ubuntu):
status: Fix Committed → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-themes - 13.04+14.04.20140117.1-0ubuntu1

---------------
ubuntu-themes (13.04+14.04.20140117.1-0ubuntu1) trusty; urgency=low

  [ Andrés G. Aragoneses ]
  * Ambiance: support zebra striping for treeviews This is a rework of
    Andrea's patch (committed in r220:
    http://bazaar.launchpad.net/~ubuntu-art-pkg/ubuntu-
    themes/trunk/revision/220) that doesn't introduce a visual glitch on
    progress bars inside treeviews (because of this visual glitch, the
    r220 patch was reverted in r234:
    http://bazaar.launchpad.net/~ubuntu-art-pkg/ubuntu-
    themes/trunk/revision/234 and bug LP#945430 had to be reopened), and
    therefore allows us to have a theme that implements zebra striping
    treeviews when applications choose to use them via
    `self.treeview.set_rules_hint(True)` API. . (LP: #945430)

  [ Lars Uebernickel ]
  * Fix some theming issues in gedit (file browser toolbar and context
    menu font). (LP: #1242984)
  * gedit: make search occurences label readable.

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 335
 -- Ubuntu daily release <email address hidden> Fri, 17 Jan 2014 19:27:58 +0000

Changed in ubuntu-themes (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.