Ubuntu

font not visible in terminal plugin

Reported by William Doyle on 2012-03-04
246
This bug affects 54 people
Affects Status Importance Assigned to Milestone
Ubuntu theme
Undecided
Unassigned
gedit
Won't Fix
Critical
gedit-plugins
Fix Released
High
gedit-plugins (Ubuntu)
Undecided
Unassigned

Bug Description

In font of the terminal plugin is not visible as the background and the font have the same colour(white)

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: gedit 3.3.4-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-17.27-generic-pae 3.2.6
Uname: Linux 3.2.0-17-generic-pae i686
ApportVersion: 1.93-0ubuntu2
Architecture: i386
Date: Sun Mar 4 11:02:22 2012
ExecutablePath: /usr/bin/gedit
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20120201.1)
ProcEnviron:
 LANGUAGE=en_IN:en
 PATH=(custom, no user)
 LANG=en_IN
 SHELL=/bin/bash
SourcePackage: gedit
UpgradeStatus: Upgraded to precise on 2012-02-25 (7 days ago)

William Doyle (williamdoyleaf) wrote :
Vadim Rutkovsky (roignac) wrote :

Marked as Won't Fix upstream:
The terminal plugins uses the color specified for the gnome-terminal since it
wants to look as similar as possible as a normal terminal, just embedded in
gedit.

If you adjust your gnome-terminal colors, gedit's terminal will pick em up.

Changed in gedit (Ubuntu):
status: New → Invalid
Changed in gedit:
importance: Unknown → Critical
status: Unknown → Won't Fix
aloctavodia (aloctavodia) wrote :

The problem is that the terminal plugin is JUST using the font color specified for the gnome-terminal, BUT is not using the background gnome-terminal color. The gedit-terminal SHOULD match the gnome-terminal color schema. The rationale for what I am saying is as follow:

1) It should be simple to fix
2) It will make the Ubuntu apps more integrated "out-of-the-box"
3) There is not a simple way to change the gedit-terminal color schema (dconf-editor should be used), or as Vadim suggest the gnome-terminal color should be changed.

aloctavodia (aloctavodia) wrote :

BTW, even when the gnome-terminal colors are changed, gedit's terminal will not pick em up.

Changed in gedit (Ubuntu):
status: Invalid → Confirmed
aloctavodia (aloctavodia) wrote :

the problem is still there in 12.04 beta 2

Ernesto Jardim (ernesto-jardim) wrote :

Is there any idea when this bug will be fixed ?

Jan Groenewald (jan-aims) wrote :

Should this bug not be in gedit-plugins?

Jan Groenewald (jan-aims) wrote :

I've marked https://bugs.launchpad.net/ubuntu/+source/gedit/+bug/144859 as a duplicate of this bug.

MSzynisz (mszynisz) wrote :

My solution: install dconf-tools, open dconf-editor, go to org.gnome.gedit.plugins.terminal, uncheck use-theme-colors. I also changed background-color to #f2f1f0.
Hope this works. If not, try changing the colors of the actual terminal and try again the dconf solution.

Hi

On 26 May 2012 12:29, MSzynisz <email address hidden> wrote:

> My solution: install dconf-tools, open dconf-editor, go to
> org.gnome.gedit.plugins.terminal, uncheck use-theme-colors. I also changed
> background-color to #f2f1f0.
> Hope this works. If not, try changing the colors of the actual terminal
> and try again the dconf solution.
>

I still don't get readable directory listings. Either the folders or the
commands are too similar to the background to be readable.

Jan Niklas Hasse (jhasse) wrote :

On 26 May 2012 12:29, MSzynisz <email address hidden> wrote:
> My solution: install dconf-tools, open dconf-editor, go to
> org.gnome.gedit.plugins.terminal, uncheck use-theme-colors. I also changed
> background-color to #f2f1f0.
> Hope this works. If not, try changing the colors of the actual terminal
> and try again the dconf solution.

Worked, thanks! :)

Voidcode (terkelsorensen) wrote :

Wee just need to edited the /usr/lib/gedit/plugins/terminal.py.

Search for:

fg = context.get_color(Gtk.StateFlags.NORMAL)
bg = context.get_background_color(Gtk.StateFlags.NORMAL)

I replace with

fg = Gdk.RGBA(0, 0, 0, 1)
bg = Gdk.RGBA(1, 1, 1, 1)

Info: fg = black text, bg = white background

Find this on askubuntu: http://askubuntu.com/questions/35109/how-to-change-background-color-of-gedit-embedded-terminal

The attachment "terminal.py" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch

Hi

If you edit a file belonging to a package, it will be overwritten when
you receive an update for that package.

However creating a custom file here,

0 jan@tunis:~$grep -A1 gnome.gedit.plugins.terminal
/usr/share/glib-2.0/schemas/00_aims_settings.gschema.override
[org.gnome.gedit.plugins.terminal]
use-theme-colors=false

And running

sudo glib-compile-schemas /usr/share/glib-2.0/schemas

will set this for your system (system-wide, for all users, as a default,
they can change it again).

Regards,
Jan

On 19 July 2012 23:06, Voidcode <email address hidden> wrote:

> Wee just need to edited the /usr/lib/gedit/plugins/terminal.py.
>
> Search for:
>
> fg = context.get_color(Gtk.StateFlags.NORMAL)
> bg = context.get_background_color(Gtk.StateFlags.NORMAL)
>
> I replace with
>
> fg = Gdk.RGBA(0, 0, 0, 1)
> bg = Gdk.RGBA(1, 1, 1, 1)
>
> Info: fg = black text, bg = white background
>
> Find this on askubuntu: http://askubuntu.com/questions/35109/how-to-
> change-background-color-of-gedit-embedded-terminal<http://askubuntu.com/questions/35109/how-to-%0Achange-background-color-of-gedit-embedded-terminal>
>
> ** Attachment added: "replace: fg =
> context.get_color(Gtk.StateFlags.NORMAL) bg =
> context.get_background_color(Gtk.StateFlags.NORMAL) with fg = Gdk.RGBA(0,
> 0, 0, 1) bg = Gdk.RGBA(1, 1, 1, 1)"
>
> https://bugs.launchpad.net/ubuntu/+source/gedit/+bug/946095/+attachment/3228834/+files/terminal.py
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/946095
>
> Title:
> font not visible in terminal plugin
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gedit/+bug/946095/+subscriptions
>

--
  .~.
  /V\ Jan Groenewald
 /( )\ www.aims.ac.za
 ^^-^^

tarkaran (tarkaran) wrote :

I'm quite amazed that being that this bug make useless the plugin under last Ubuntu 12.04, the importance is still set as "undecided"

Whitehat (i-whitehat) wrote :

my gnome terminal is green on black background. Why Embedded Terminal is white on white?????

Adam Dingle (adam-yorba) on 2013-05-19
affects: gedit (Ubuntu) → gedit-plugins (Ubuntu)
Adam Dingle (adam-yorba) wrote :

I investigated since I wanted to understand what was going on here. I thought this was probably an Ambiance-related theme issue, but I was wrong. (I've also posted the following explanation at the upstream ticket at https://bugzilla.gnome.org/show_bug.cgi?id=694598 .)

Back in GNOME 2.32, both gedit and gnome-terminal stored settings in GConf. At that time the gedit terminal plugin looked at gnome-terminal's GConf settings to read the default profile information to find out what colors to use. You
can see that code here:

https://git.gnome.org/browse/gedit-plugins/tree/plugins/terminal/terminal.py?h=gnome-2-32

Then in GNOME 3.0 gedit ported over to GSettings, but gnome-terminal was still using GConf. The terminal plugin could no longer easily look at the gnome-terminal profile info, so the terminal plugin just started using the
default colors from the VTE terminal widget (which look poor, hence this bug). At that time the terminal plugin code added this FIXME line:

   def get_profile_settings(self):
        #FIXME return either the gnome-terminal settings or the gedit one
        return Gio.Settings.new("org.gnome.gedit.plugins.terminal")

Now, finally, in GNOME 3.8 gnome-terminal has been ported to use GSettings:

  https://git.gnome.org/browse/gnome-terminal/tree/NEWS?h=gnome-3-8

So it should now be possible to fix this bug by having the terminal plugin read profile information from GSettings.

Changed in gedit-plugins:
importance: Unknown → High
status: Unknown → New
Adam Dingle (adam-yorba) wrote :

This has now been fixed in gedit-plugins git master upstream, but it doesn't yet work with Ambiance when "Use colors from system theme" is checked in your gnome-terminal profile (which is the default setting). Ambiance will need a patch to make this work in Ubuntu - see

https://bugzilla.gnome.org/show_bug.cgi?id=694598#c14

Changed in gedit-plugins:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.