intrepid - gedit-plugins - character map plugin greyed out when enabled

Bug #271715 reported by Savvas Radevic on 2008-09-18
4
Affects Status Importance Assigned to Milestone
gedit-plugins (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gedit-plugins

Intrepid alpha 5 updated
$ apt-cache policy gedit gedit-plugins
gedit:
  Installed: 2.23.93-0ubuntu1
  Candidate: 2.23.93-0ubuntu1
  Version table:
 *** 2.23.93-0ubuntu1 0
        500 http://archive.ubuntu.com intrepid/main Packages
        100 /var/lib/dpkg/status
gedit-plugins:
  Installed: 2.22.3-0ubuntu1
  Candidate: 2.22.3-0ubuntu1
  Version table:
 *** 2.22.3-0ubuntu1 0
        500 http://archive.ubuntu.com intrepid/universe Packages
        100 /var/lib/dpkg/status

Problem: Character map plugin cannot be enabled and is greyed out.
Reproduce:
Install gedit-plugins, run gedit, go to menu Edit > Preferences > Plugins > check "Character map"
The plugin in the list will be greyed out.

Running from terminal I get this message:
$ gedit

** (gedit:7850): WARNING **: charmap: /usr/lib/gedit-2/plugins/libcharmap.so: undefined symbol: gucharmap_chartable_set_font

** (gedit:7850): WARNING **: Cannot load plugin 'charmap' since file '/usr/lib/gedit-2/plugins' cannot be read.

** (gedit:7850): WARNING **: Error activating plugin 'Character Map'
Traceback (most recent call last):
  File "/usr/lib/gedit-2/plugins/bracketcompletion.py", line 243, in deactivate
    window.disconnect(handler)
NameError: global name 'handler' is not defined

The file is there however:
$ ls -l /usr/lib/gedit-2/plugins/charmap.gedit-plugin
-rw-r--r-- 1 root root 3052 2008-09-10 11:24 /usr/lib/gedit-2/plugins/charmap.gedit-plugin

gedit-plugins (2.22.4-0ubuntu2) intrepid; urgency=low

  * Add of debian/patches/01_charmap.patch to remove the call to the
    deprecated gucharmap_chartable_set_font (LP: #271715).

 -- Christophe Sauthier <email address hidden> Thu, 23 Oct 2008 13:52:31 +0200

James Westby (james-w) wrote :

I will upload shortly.

Thanks,

James

Changed in gedit-plugins:
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gedit-plugins - 2.22.4-0ubuntu2

---------------
gedit-plugins (2.22.4-0ubuntu2) intrepid; urgency=low

  * Add of debian/patches/01_charmap.patch to remove the call to the
    deprecated gucharmap_chartable_set_font (LP: #271715).

 -- Christophe Sauthier <email address hidden> Thu, 23 Oct 2008 13:52:31 +0200

Changed in gedit-plugins:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers