Synctex plugin was not built in raring

Bug #1165742 reported by Antoine-terracol on 2013-04-07
40
This bug affects 9 people
Affects Status Importance Assigned to Milestone
dbus-python (Ubuntu)
Undecided
Unassigned
Raring
Undecided
Unassigned
gedit-plugins (Ubuntu)
Low
Unassigned
Raring
Undecided
Unassigned

Bug Description

The Synctex plugin is apparently not installed by gedit-plugins. There is no "synctex" folder been created in usr/lib/gedit/plugins/ Obviously the plugin does not appear among the available plugins in gedit preferences/plugins.

The Synctex plugin appears to be in the package file on launchpad in https://launchpad.net/ubuntu/+archive/primary/+files/gedit-plugins_3.6.1.orig.tar.xz ; but it seems it fails to install correctly.

Installing through CLI does not give any error message

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: gedit-plugins 3.6.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.8.0-16.26-generic 3.8.5
Uname: Linux 3.8.0-16-generic i686
ApportVersion: 2.9.2-0ubuntu5
Architecture: i386
Date: Sun Apr 7 14:48:14 2013
InstallationDate: Installed on 2011-05-01 (706 days ago)
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
MarkForUpload: True
SourcePackage: gedit-plugins
UpgradeStatus: Upgraded to raring on 2013-03-29 (8 days ago)

Doug McMahon (mc3man) wrote :

The plugins package(s) were built on 13 Nov 2012 & while python-dbus-dev (1.1.1-1ubuntu2) was installed for build maybe not 'good enough' or something else, as seen in build log -
"Disabled plugins: synctex (dbus-python not found)"

When doing a package build here locally with current 1.1.1-1ubuntu3 there is no issue with the plugin being built, installed & enabled. (Whether it works right not in a position to tell, that's for someone else..

Changed in gedit-plugins (Ubuntu):
status: New → Confirmed
Doug McMahon (mc3man) on 2013-04-07
summary: - Synctex plugin is not installed (raring i386)
+ Synctex plugin was not built in raring i386)
summary: - Synctex plugin was not built in raring i386)
+ Synctex plugin was not built in raring
Doug McMahon (mc3man) wrote :

Been confirmed that the plugin does work ok, source just needs a simple rebuild.

The attachment "gedit-plugins_3.6.1-0ubuntu2.debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Sebastien Bacher (seb128) wrote :

Thanks, do you have an explanation of why a no change rebuild would fix it? The diff you attached is also not a "no change" one, the debian/control description changed

Sebastien Bacher (seb128) wrote :

the issue from https://launchpadlibrarian.net/122902634/buildlog_ubuntu-raring-i386.gedit-plugins_3.6.1-0ubuntu1_BUILDING.txt.gz is "configure: WARNING: dbus-python could not be found, synctex plugin will be disabled", e.g missing build-depends, I will fix that

Changed in gedit-plugins (Ubuntu):
status: Confirmed → Fix Committed
importance: Undecided → Low
Sebastien Bacher (seb128) wrote :

(the control update was a side effect of control.in->control auto refresh, not a change)

Doug McMahon (mc3man) wrote :

Sorry about that (the debdiff), seemed like the source just needed to be rebuilt with no changes (didn't get why the control.in > control deal happened.
As far as build deps thought that because python-dbus depends on python-dbus-dev that it was ok for the build dep to remain on python-dbus (can't install one without the other & build log did show python-dbus-dev being installed for LP build..

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gedit-plugins - 3.6.1-0ubuntu2

---------------
gedit-plugins (3.6.1-0ubuntu2) raring; urgency=low

  * debian/control.in: build-depends on dbus-python-dev rather than
    dbus-python, since the .pc has been moved to that binary (lp: #1165742)
 -- Sebastien Bacher <email address hidden> Wed, 10 Apr 2013 16:00:35 +0200

Changed in gedit-plugins (Ubuntu):
status: Fix Committed → Fix Released
GrandVizier (grandvizier) wrote :

I have gedit-plugins - 3.6.1-0ubuntu2 installed (and re-installed) but still no synctex plugin under Ubuntu 13.04.

The build logs https://launchpadlibrarian.net/136861019/buildlog_ubuntu-raring-i386.gedit-plugins_3.6.1-0ubuntu2_UPLOADING.txt.gz and https://launchpadlibrarian.net/136860798/buildlog_ubuntu-raring-amd64.gedit-plugins_3.6.1-0ubuntu2_UPLOADING.txt.gz
still show that Synctex was disabled on build :
checking whether Python support is requested... checking for DBUSPYTHON... no
configure: WARNING: dbus-python could not be found, synctex plugin will be disabled

hove99 (hove99) wrote :

You guys may have already done this, but I managed to do a temporary fix by downloading the quantal gedit-plugins deb and extracting synctex plugin. I copied the plugin file and the plugin folder manually:

sudo cp -r synctex.plugin synctex /usr/lib/gedit/plugins

I have attached the necessary file and folder.

Rafael Kitover (rafaelkitover) wrote :

There is another problem:

python-dbus-dev requires libdbus-1-dev but does NOT depend on it, or at least pkg-config thinks so, so configure thinks it's not there.

pkg-config --cflags dbus-python
# Package dbus-1 was not found...

sudo apt-get install libdbus-1-dev

pkg-config --cflags dbus-python
# -I/usr/include/......

Once I do this, the synctex plugin builds.

Adam Conrad (adconrad) on 2013-10-08
Changed in gedit-plugins (Ubuntu):
status: Fix Released → Confirmed
Adam Conrad (adconrad) wrote :

So, while this *should* be fixed in dbus-python, there exists the hilarious situation right now that python-dbus depends on python-dbus-dev for backward compat, so making python-dbus-dev depend on libdbus-1-dev would pull libdbus-1-dev onto every desktop, which is less than ideal.

When that backward compat dependency is removed, someone should fix python-dbus-dev's dependencies.

gedit-plugins in saucy already has the extra libdbus-1-dev build-dep, so this should be working correctly there. Thus, the only thing that could use a fix is a raring SRU of gedit-plugins, if someone feels the urge.

Changed in gedit-plugins (Ubuntu):
status: Confirmed → Fix Released
Changed in dbus-python (Ubuntu Raring):
status: New → Won't Fix
Rolf Leggewie (r0lf) wrote :

raring has seen the end of its life and is no longer receiving any updates. Marking the raring task for this ticket as "Won't Fix".

Changed in gedit-plugins (Ubuntu Raring):
status: New → Won't Fix
Simon McVittie (smcv) on 2018-05-09
Changed in dbus-python (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers