gedit-latex-plugin should recommend libgnome2-0

Bug #897346 reported by Alex Valavanis on 2011-11-28
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Oneiric Backports
Undecided
Unassigned
gedit-latex-plugin (Debian)
Fix Released
Unknown
gedit-latex-plugin (Ubuntu)
Undecided
Unassigned

Bug Description

In oneiric, libgnome2-0 is not installed by default... this means that the "gnome-open" command used by gedit-latex-plugin is unavailable. This is seen in the oneiric backport of version 3.3.1 of the plugin.

To reproduce...
1. Make a simple LaTeX file
2. Use the "LaTeX -> PDF" command
>> a warning message appears in the bottom-pane because gnome-open is unavailable

To workaround...
Install libgnome2-0.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: gedit-latex-plugin 3.3.1-1~oneiric1
ProcVersionSignature: Ubuntu 3.0.0-14.23-generic 3.0.9
Uname: Linux 3.0.0-14-generic x86_64
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
Date: Mon Nov 28 18:48:56 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110901)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: gedit-latex-plugin
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Alex Valavanis (valavanisalex) wrote :
Alex Valavanis (valavanisalex) wrote :

Updated backport branch linked. Please consider merging. (Updated deb attached)

Evan Broder (broder) wrote :

Hi Alex - Thanks for reporting this. Instead of continuing to use gnome-open, which has been deprecated, I'm going to switch the package to using gvfs-open, which is the new GNOME-sanctioned replacement for gnome-open. (http://git.gnome.org/browse/gedit-latex/commit/?id=4166f494ca26e1ef0540652fc1658e9dc31e6a0d)

Once the package has been uploaded to Precise, then we can look into backporting the fix to oneiric-backports. In the mean time, I'm going to mark the oneiric-backports task as Incomplete.

Evan Broder (broder) wrote :

I've opened a bug against Debian asking them to update to the most recent release of gedit-latex-plugin

Changed in gedit-latex-plugin (Debian):
status: Unknown → New
Andrea Gasparini (gaspa) wrote :

Seen, thanks Evan and Alex.

I'll take care of this asap. :)

Changed in gedit-latex-plugin (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.