Plugins cannot be activated from preferences -> plugins

Bug #1374297 reported by Ammon
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
gedit-developer-plugins (Ubuntu)
Undecided
Unassigned

Bug Description

When I run gedit from a terminal I can get these error messages:

(gedit:13423): libpeas-WARNING **: Could not find loader 'python' for plugin 'gdpbzr'

(gedit:13423): libpeas-WARNING **: Could not find loader 'python' for plugin 'gdpcomplete'

(gedit:13423): libpeas-WARNING **: Could not find loader 'python' for plugin 'gdpfind'

(gedit:13423): libpeas-WARNING **: Could not find loader 'python' for plugin 'gdpformat'

--------------------------------------------------------------------------------------------

I found a suggestion to modify /usr/lib/gedit/plugins/gdpXXXXXX.plugin

from
"Loader=python"
to
"Loader=python3"

then trying to activate the plugin from preferences -> plugins results in this error:

Traceback (most recent call last):
  File "/usr/lib/gedit/plugins/gdpcomplete.py", line 19, in <module>
    from gdpbase import (
  File "/usr/lib/gedit/plugins/gdpbase.py", line 24, in <module>
    from gdp import (
  File "/usr/lib/gedit/plugins/gdp/__init__.py", line 14, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'

(gedit:14199): libpeas-WARNING **: Error loading plugin 'gdpcomplete'

------------versions-------------------------------------------

gedit 3.10.4
gedit-developer-plugins 0.5.15-0ubuntu1
ubuntu 14.04 LTS

$ python -V
Python 2.7.6

$ python3 -V
Python 3.4.0

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gedit-developer-plugins (Ubuntu):
status: New → Confirmed
Revision history for this message
Curtis Hovey (sinzui) wrote :

Ubuntu has old packages
    https://launchpad.net/~sinzui/+archive/ubuntu/ppa?field.series_filter=trusty
    1.1.0+661-0~gdp~ubuntu13.10.1 was rebuilt for trusty and it works well.

Curtis Hovey (sinzui)
no longer affects: gdp
Revision history for this message
adm (alexm-) wrote :

no, it's still affected:

Preparing to unpack …/gedit-developer-plugins_1.1.0+661-0~gdp~ubuntu13.10.1_all.deb ...
Unpacking gedit-developer-plugins (1.1.0+661-0~gdp~ubuntu13.10.1) over (0.5.15-0ubuntu1) ...
Настраивается пакет gedit-developer-plugins (1.1.0+661-0~gdp~ubuntu13.10.1) …
# gedit
Traceback (most recent call last):
  File "/usr/lib/gedit/plugins/gdpformat.py", line 25, in <module>
    from gdp.format import Formatter
  File "/usr/lib/gedit/plugins/gdp/format.py", line 30, in <module>
    from pocketlint.formatdoctest import DoctestReviewer
ImportError: No module named 'pocketlint'

(gedit:11520): libpeas-WARNING **: Error loading plugin 'gdpformat'

(gedit:11520): Gtk-WARNING **: Calling Inhibit failed: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers