Please sync geda-utils 1:1.4.3-2 (universe) from Debian unstable (main).

Bug #337231 reported by Bhavani Shankar on 2009-03-03
4
Affects Status Importance Assigned to Milestone
geda-utils (Ubuntu)
Wishlist
Unassigned

Bug Description

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

 affects ubuntu/geda-utils
 status new
 importance wishlist
 subscribe ubuntu-universe-sponsors

Please sync geda-utils 1:1.4.3-2 (universe) from Debian unstable (main).

Please sync the latest version from debian as they have updated their
package to the latest upstream version which is a bug fix release.

Changelog since current jaunty version 1:1.4.0-3:

geda-utils (1:1.4.3-2) unstable; urgency=low

  * Added build-dep on intltool (closes: #514902)

 -- Hamish Moffatt <email address hidden> Mon, 16 Feb 2009 10:58:13 +1100

geda-utils (1:1.4.3-1) unstable; urgency=low

  * New upstream bug fix release

 -- Hamish Moffatt <email address hidden> Sun, 01 Feb 2009 00:56:29 +1100

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFJrTkOL+KnYRaooWIRAnZvAJ4/1++BuNGT3860JMDycKYB37EupwCfVZ0v
o/lVt5X4enZ+O2sAvQ4sPmk=
=ZDeE
-----END PGP SIGNATURE-----

Bhavani Shankar (bhavi) wrote :
Download full text (3.4 KiB)

Upstream changelog:

# Do not edit this file - generated from version control history

commit 32907f4c9585abd866f0f4aaec2d4884ed519c93
Author: Ales Hvezda <email address hidden>
Date: Wed Dec 31 18:42:17 2008 -0500

    Updated manual page versions in prep for a release

commit 732a12f84d3dbc3b6cfc78f51e71211f2dce3368
Author: Ales Hvezda <email address hidden>
Date: Wed Dec 31 18:20:33 2008 -0500

    Updated program versions and shared library in prep for 1.4.3.20081231

    Versions updated by running:
     ./update-versions.sh 1.4.3 20081231 33:2:0

commit 6f001abc5c1fc69bb5bfbece189efbd231a8ed4c
Author: Peter Clifton <email address hidden>
Date: Wed Dec 24 04:13:26 2008 +0000

    gschlas: Fix segfault opening file

    Segfault introduced in commit b635ebb641383360e5e7864830d42d13cf7f4d12.

    (cherry picked from commit 46fdb00b19d300dfcc5f9009f9c7dbbf0940834f)

commit f3c81e69811a60559b9a25dd9890c2e2df85e27a
Author: Ales Hvezda <email address hidden>
Date: Sat Dec 20 21:01:52 2008 -0500

    Updated all the ChangeLogs again

commit 58052ffbcf9fb83ed620473cac7eb33dca39615c
Author: Ales Hvezda <email address hidden>
Date: Sat Dec 20 20:59:41 2008 -0500

    Oops, created the 1.4.2 release with the wrong date. Today is 20081220 ...

    ... not 20081218.

commit 389ee59aa4e37b29862395b56ae62a42cc7fa9cd
Author: Ales Hvezda <email address hidden>
Date: Sat Dec 20 20:13:16 2008 -0500

    Updated ChangeLogs for the 1.4.2.20081218 release

    Updated by running:
     ./update-changelogs.sh 1.0-20070526..stable-1.4

commit 8d7e4c55be31e0f1afc0ce2c85c9a10c584364bd
Author: Ales Hvezda <email address hidden>
Date: Sat Dec 20 19:10:10 2008 -0500

    Updated all version in the man pages to 1.4.2.20081218

commit 59f9593cf903345f96f78fbd365c008061cf600e
Author: Ales Hvezda <email address hidden>
Date: Sat Dec 20 19:07:12 2008 -0500

    Bumped the reveision number libgeda's shared library and updated versions.

    Updated all version to 1.4.2.20081218. Update was done by running:
    ./update-versions.sh 1.4.2 20081218 33:1:0

commit 6cb66fef58470e627bbf33eac4a50d928a15b4c7
Author: Ales Hvezda <email address hidden>
Date: Sun Sep 28 17:41:58 2008 -0400

    Another round of updating ChangeLogs in prep for the release

commit 58a3d3cfd1ae6e98c41b733821461d3753c68bfe
Author: Ales Hvezda <email address hidden>
Date: Sun Sep 28 17:05:45 2008 -0400

    Updated all ChangeLogs to pick up all new commits

    This was done by by running: ./update-changelogs.sh 1.0-20070526..stable-1.4

commit 491e639b9147780fa58dce15c06591cf28470987
Author: Ales Hvezda <email address hidden>
Date: Sun Sep 28 17:01:21 2008 -0400

    Updated all date versions to 20080929 (today!)

    The other (dotted) version was updated previously in:
    7737ec1544d967202bdd425792795d00918897f2

commit 7737ec1544d967202bdd425792795d00918897f2
Author: Ales Hvezda <email address hidden>
Date: Wed Mar 5 05:22:55 2008 -0500

    Updated versions to 1.4.1 in prep for the start of a new bug fix release

Looking at the changelog since its a bugfix update I think that FFe is not required

Additionally debian has fixed FTBFS

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=514898

...

Read more...

Changed in geda-utils:
assignee: nobody → bhavi
status: New → In Progress
Bhavani Shankar (bhavi) wrote :
Bhavani Shankar (bhavi) wrote :

Awaiting sponsorship

Changed in geda-utils:
assignee: bhavi → nobody
status: In Progress → New
Daniel Holbach (dholbach) wrote :

ACKed.

Changed in geda-utils:
status: New → Confirmed
Steve Langasek (vorlon) wrote :

[Updating] geda-utils (1:1.4.0-3 [Ubuntu] < 1:1.4.3-2 [Debian])
 * Trying to add geda-utils...
  - <geda-utils_1.4.3-2.diff.gz: downloading from http://ftp.debian.org/debian/>
  - <geda-utils_1.4.3-2.dsc: downloading from http://ftp.debian.org/debian/>
  - <geda-utils_1.4.3.orig.tar.gz: downloading from http://ftp.debian.org/debian/>
I: geda-utils [universe] -> geda-utils_1:1.4.0-3 [universe].

Changed in geda-utils:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.