Please sync geda-gattrib 1:1.4.3-2 (universe) from Debian unstable (main).

Bug #334373 reported by Bhavani Shankar on 2009-02-25
10
Affects Status Importance Assigned to Milestone
geda-gattrib (Ubuntu)
Wishlist
Unassigned

Bug Description

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

 affects ubuntu/geda-gattrib
 status new
 importance wishlist
 subscribe ubuntu-universe-sponsors

Please sync geda-gattrib 1:1.4.3-2 (universe) from Debian unstable
(main).

Changelog since current jaunty version 1:1.4.0-5:

Please sync the latest version from debian as they have updated their
package to the latest upstream version which is a bug fix release.

geda-gattrib (1:1.4.3-2) unstable; urgency=low

  * Added missing build-dep on intltool (closes: #514898)

 -- Hamish Moffatt <email address hidden> Mon, 16 Feb 2009 10:43:52 +1100

geda-gattrib (1:1.4.3-1) unstable; urgency=low

  * New upstream bug fix release

 -- Hamish Moffatt <email address hidden> Sun, 01 Feb 2009 00:44:25 +1100

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFJpVtpL+KnYRaooWIRArSAAJwO20m4BiCQEHFJU+ssIMr0qMpaewCcCxqK
gBmLpvdE3ZDU0mUIU49Q9d8=
=iB0r
-----END PGP SIGNATURE-----

Bhavani Shankar (bhavi) wrote :

Please unsubscribe u-u-s

Regards

Changed in geda-gattrib:
assignee: nobody → bhavi
status: New → In Progress
Bhavani Shankar (bhavi) wrote :
Download full text (5.3 KiB)

Upstream changelog:

commit 24527dcb9d25d2a81b7059ca750c1a557173804f
Author: Ales Hvezda <email address hidden>
Date: Wed Dec 31 18:40:14 2008 -0500

    Manually ran make update-po in all po directories in prep for a release

commit 732a12f84d3dbc3b6cfc78f51e71211f2dce3368
Author: Ales Hvezda <email address hidden>
Date: Wed Dec 31 18:20:33 2008 -0500

    Updated program versions and shared library in prep for 1.4.3.20081231

    Versions updated by running:
     ./update-versions.sh 1.4.3 20081231 33:2:0

commit f3c81e69811a60559b9a25dd9890c2e2df85e27a
Author: Ales Hvezda <email address hidden>
Date: Sat Dec 20 21:01:52 2008 -0500

    Updated all the ChangeLogs again

commit 58052ffbcf9fb83ed620473cac7eb33dca39615c
Author: Ales Hvezda <email address hidden>
Date: Sat Dec 20 20:59:41 2008 -0500

    Oops, created the 1.4.2 release with the wrong date. Today is 20081220 ...

    ... not 20081218.

commit 389ee59aa4e37b29862395b56ae62a42cc7fa9cd
Author: Ales Hvezda <email address hidden>
Date: Sat Dec 20 20:13:16 2008 -0500

    Updated ChangeLogs for the 1.4.2.20081218 release

    Updated by running:
     ./update-changelogs.sh 1.0-20070526..stable-1.4

commit aa9e7b426142bc08e454f944ba1246c27c63e773
Author: Ales Hvezda <email address hidden>
Date: Sat Dec 20 19:12:22 2008 -0500

    Manually ran make update-po in all po directories

commit 59f9593cf903345f96f78fbd365c008061cf600e
Author: Ales Hvezda <email address hidden>
Date: Sat Dec 20 19:07:12 2008 -0500

    Bumped the reveision number libgeda's shared library and updated versions.

    Updated all version to 1.4.2.20081218. Update was done by running:
    ./update-versions.sh 1.4.2 20081218 33:1:0

commit 4eee4ebea399b332179091a0679429015223f305
Author: Peter Clifton <email address hidden>
Date: Tue Dec 9 09:14:20 2008 +0000

    gattrib: Don't crash if we can't find data in the sheet. Bug #2214739

    Check for a -1 return from s_table_get_index() before
    using to index an array. Print ugly warnings to stderr
    and skip whatever we were doing if this is encountered.

commit ad0e3027a721132c12727e1806979dadfc4af731
Author: Peter Clifton <email address hidden>
Date: Tue Dec 9 09:14:05 2008 +0000

    gattrib: Don't special-case ignore components with "graphical" attribute.

    It was noted that special-casing the "graphical" attribute could cause
    gattrib to crash on save (Bug #2214739).

    There is no real reason why the user might not want to edit a graphical
    symol's attributes with gattrib, so we should treat it like any other.

commit 2b302915fdd5c385c7515b82d5a1dd5f02bcf2aa
Author: Ales Hvezda <ahvezda@-e false.(none)>
Date: Tue Dec 9 09:12:05 2008 +0000

    Fixed up all icon-theme-installer files to work with non-bash

    Grabbed the latest icon-theme-installer files from the pcb repository
    since they have been fully patched to work with non-bash shells. On
    my ubuntu system, /bin/sh is linked to dash which prevented me from
    running the previous version of icon-theme-installer. This commit
    is related to a7e7a28613abe4705ec01011d0f4308ff024251b

commit 73b045e75d95d6633e51c5cfac63f25ea31e7c31
Author: Carlos Nieves Onega <cnieves...

Read more...

description: updated
Bhavani Shankar (bhavi) on 2009-02-26
Changed in geda-gattrib:
assignee: bhavi → nobody
status: In Progress → New
Daniel Holbach (dholbach) wrote :

Can you get in touch with motu-release about this one?

I understand that it's required to bring the the *geda* world in sync again, but it might be worth checking with the team beforehand.

https://wiki.ubuntu.com/FreezeExceptionProcess

Bhavani Shankar (bhavi) wrote :

Okay daniel.....

Bhavani Shankar (bhavi) wrote :

Awaiting sponsorship.......

Regards

Daniel Holbach (dholbach) wrote :

ACKed.

Changed in geda-gattrib:
status: New → Confirmed
Steve Langasek (vorlon) wrote :

[Updating] geda-gattrib (1:1.4.0-5 [Ubuntu] < 1:1.4.3-2 [Debian])
 * Trying to add geda-gattrib...
  - <geda-gattrib_1.4.3-2.diff.gz: downloading from http://ftp.debian.org/debian/>
  - <geda-gattrib_1.4.3.orig.tar.gz: downloading from http://ftp.debian.org/debian/>
  - <geda-gattrib_1.4.3-2.dsc: downloading from http://ftp.debian.org/debian/>
I: geda-gattrib [universe] -> geda-gattrib_1:1.4.0-5 [universe].

Changed in geda-gattrib:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.