can't open gvfs sftp files

Bug #738147 reported by levu on 2011-03-19
46
This bug affects 8 people
Affects Status Importance Assigned to Milestone
geany (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: geany

Since the last update, geany can't open sftp files from gvfs mounted directories (in nautilus mounted). There is no error message (and no output even in verbose mode).

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: geany 0.20-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-7.35-generic 2.6.38
Uname: Linux 2.6.38-7-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Sat Mar 19 11:58:29 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110302)
ProcEnviron:
 LANGUAGE=de_DE:en
 PATH=(custom, user)
 LANG=de_DE.UTF-8
 SHELL=/usr/bin/zsh
SourcePackage: geany
UpgradeStatus: No upgrade log present (probably fresh install)

levu (levu) wrote :

Thanks for your report. What update do you mean? The latest geany update
or general system updates? Also, I can't reproduce, I can open files on
sftp mounted directories with geany.

Can you look if there is something in your .xsession-errors?

What happens if you try opening the files with gedit? (Right mouse
click, open with)

 status Incomplete
 importance Low
 subscribe

Changed in geany (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
levu (levu) wrote :

With gedit it works, that's the strange thing.Also, there is nothing in the .xsession-errors related to geany or gvfs or fuse. I don't know exactly, how this comes, but it's like this since ~4 days. I append my apt history file.

levu (levu) wrote :

And also purging geany, removing per-user-config, reinstalling geany doesn't work

That's strange. Can you do 'strace -o strace-geany.txt geany', open a
sftp-mounted file and attach the strace to this report?

levu (levu) wrote :

I've done some debugging work, and this is where i found something strange:

filelist = gtk_file_chooser_get_filenames(GTK_FILE_CHOOSER(ui_widgets.open_filesel));
if (filelist != NULL)

filelist seems to be NULL, because it goes never in this if. At the time the problem started, some gtk stuff was updated, maybe there was a change in the API or something similar?

levu (levu) wrote :

the strace

Andreas Moog (ampelbein) wrote :

Can you try and test this with a new user profile? I can't reproduce the
issue at all, tried opening files with different paths, names, german
umlauts äöü - all worked. So I can't imagine it's a API issue.

 tag test-clean-profile

levu (levu) wrote :

With a new profile it worked so i'll try to find the problematic setting in my home dir (will be a long night :) ). I'll tell you what caused the problem. Thanks for your time and sorry that it was wasted...

tags: removed: test-clean-profile
Changed in geany (Ubuntu):
status: Incomplete → Invalid

The bug also hit me. I thus think it's not "invalid", it's rather low-priority.

Levu, could you please post here as soon as you have found the problematic setting? Thanks.

Amatriain (geralt) wrote :

This affects me too, since updating my 10.10 installation to natty yesterday.

Any pointers? Thanks.

Septimus (septimus) wrote :

I create a new user profile with and without encryption (encfs).

User profile without encryption Nautilus and Geany 0.20 doesn't have problems with open remote files from sftp.
With encryption geany can't open remote files from sftp and nautlilus context menu doesn't show up geany as default application to open. That's a bit weird...

So geany just open remote files with user profiles without encfs.

Tested on Ubuntu 10.10.

Septimus (septimus) wrote :

The user profile personal encryption folder option is encrypted with the default ecrypts and not encfs. Sorry for the wrong info.

Aditya Gilra (aditya-gilra) wrote :

I did an install of natty 11.04 over my 10.04 without formatting so that the installer kept /home intact. Now I am unable to use geany to edit remote files in .gvfs . Am able to use gedit. Do bump the priority up. Thanks.

Changed in geany (Ubuntu):
status: Invalid → Confirmed
status: Confirmed → Incomplete
status: Incomplete → Confirmed
NoahY (noahy) wrote :

I can open gvfs files, but it takes about a minute for them to load... not sure if this is related or if I should open a new bug? I'm using Natty 64-bit.

Marcus Weber (ich-marcusweber) wrote :

same here

Marcus Weber (ich-marcusweber) wrote :

simple Fix for me:
cd ~

ln -s .gvfs Network

and it works again

Same for me on Debian Wheezy 64 bit. The files displayed on a sftp dir in nautilus do not open with geany (geany is opened with nothing in the ui), with gedit no problem.

Rolf (rolwil) wrote :

$ apt-get install gvfs-fuse

For each remote connection there will be a folder created in ~/.gvfs/ and geany just works. Restart may be required.

phiamo (phiamo) wrote :

i am having this issue right now too. .. any idea why this might be caused?

Vikrant Shah (vik748) wrote :

I have observed the exact same issue on the Ubuntu 16.04 . Its a bit deeper than just Geany. None of the default Ubuntu programs is able to open files over the SFTP mount.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers