Geany doesn't recognize .dpatch nor .debdiff files as diff's

Bug #160036 reported by Siegfried Gevatter on 2007-11-04
6
Affects Status Importance Assigned to Milestone
geany (Debian)
Fix Released
Unknown
geany (Ubuntu)
Wishlist
Emmet Hikory

Bug Description

Binary package hint: geany

Geany doesn't recognize .dpatch nor .debdiff files as diff's, and so doesn't color them.

Upstream refused to add them, saying that people can add them manually to the configuration file.

Since those formats are very common in Debian and Ubuntu related development I think it would be good to have them recognized by default.

Related branches

Changed in geany:
importance: Undecided → Wishlist
Changed in geany:
assignee: nobody → rainct
status: New → In Progress
Changed in geany:
status: Unknown → New
Siegfried Gevatter (rainct) wrote :

geany (0.12-1ubuntu1) hardy; urgency=low

  * patches/40_add_filetypes.dpatch:
     - Recognize .debdiff and .dpatch files as diff's (LP: #160036)
  * patches/60_fix_desktop_file.dpatch:
     - Patch .desktop file to match the current FD.o standards
  * debian/geany.xpm:
     - Replace icon with a .xpm of the new one
  * debian/rules:
     - Do not ignore "make distclean" errors
  * Bump standards version to 3.7.3:
     - Move Homepage field to source stanza
  * Modify Maintainer value to match the DebianMaintainerField
    specification.

 -- Siegfried-Angel Gevatter Pujals (RainCT) <email address hidden> Tue, 11 Dec 2007 19:56:45 +0100

Changed in geany:
assignee: rainct → nobody
status: In Progress → Confirmed
Daniel Holbach (dholbach) wrote :

Thanks for forwarding this upstream. Maybe you can make use of http://wiki.ubuntu.com/Bugs/Debian/Usertagging next time?

Daniel Holbach (dholbach) wrote :

Sorry, bug spam necessary because of bug 176085.

This bug has a patch attached, which needs review and sponsoring.

Emmet Hikory (persia) on 2007-12-16
Changed in geany:
assignee: nobody → persia
status: Confirmed → In Progress
Emmet Hikory (persia) wrote :

Uploaded. Thanks.

Changed in geany:
status: In Progress → Fix Committed
Siegfried Gevatter (rainct) wrote :

geany (0.12-1ubuntu1) hardy; urgency=low

  * patches/40_add_filetypes.dpatch:
     - Recognize .debdiff and .dpatch files as diff's (LP: #160036)
  * patches/60_fix_desktop_file.dpatch:
     - Patch .desktop file to match the current FD.o standards
  * debian/geany.xpm:
     - Replace icon with a .xpm of the new one
  * debian/rules:
     - Do not ignore "make distclean" errors
  * Bump standards version to 3.7.3:
     - Move Homepage field to source stanza
  * Modify Maintainer value to match the DebianMaintainerField
    specification.

 -- Siegfried-Angel Gevatter Pujals (RainCT) <email address hidden> Tue, 11 Dec 2007 19:56:45 +0100

Changed in geany:
status: Fix Committed → Fix Released
Changed in geany:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.