Geany exits with fatal error when starting it

Bug #1586317 reported by Jarno Suni on 2016-05-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
geany (Ubuntu)
Undecided
Unassigned

Bug Description

$ geany

(geany:5049): Geany-WARNING **: Geany tried to access the Unix Domain socket of another instance running as another user.
This is a fatal error and Geany will now quit.

$ echo $?
1

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: geany 1.27-1
ProcVersionSignature: Ubuntu 4.4.0-22.40-generic 4.4.8
Uname: Linux 4.4.0-22-generic x86_64
ApportVersion: 2.20.1-0ubuntu2
Architecture: amd64
CurrentDesktop: XFCE
Date: Fri May 27 12:11:36 2016
EcryptfsInUse: Yes
InstallationDate: Installed on 2016-04-28 (28 days ago)
InstallationMedia: Xubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
SourcePackage: geany
UpgradeStatus: No upgrade log present (probably fresh install)

Jarno Suni (jarnos) wrote :
Colomban Wendling (banw) wrote :

Duplicate of https://bugs.launchpad.net/ubuntu/+source/geany/+bug/1536760 IMO. See the answer to it for further details, but the baseline is that the socket file is in the user's directory and so shouldn't ever be accessed by different users in a correct setup. Your problem probably is that you ran Geany through a misconfigured `sudo`, which accessed your user's home (rather than root's).

Jarno Suni (jarnos) wrote :

There was a broken symbolic link owned by root at "~/.config/geany/". Once I ran "sudo geany" and exited, the link was gone, and thereafter I could start geany as regular user.

Jarno Suni (jarnos) wrote :

So should one make a bug report against sudo?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers