geany crashes during character conversion to "no coding"

Bug #147151 reported by Jürgen Mertens on 2007-09-30
6
Affects Status Importance Assigned to Milestone
geany (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: geany

Crash occured during use of menu entry Document -> define encoding -> none .

ProblemType: Crash
Architecture: amd64
CrashCounter: 1
Date: Sun Sep 30 11:52:41 2007
DistroRelease: Ubuntu 7.10
ExecutablePath: /usr/bin/geany
NonfreeKernelModules: vmnet vmmon fglrx
Package: geany 0.11-2
PackageArchitecture: amd64
ProcCmdline: geany
ProcCwd: /FS/documents/jm
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11:/usr/games
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: geany
StacktraceTop:
 strcmp () from /lib/libc.so.6
 ?? ()
 ?? () from /usr/lib/libglib-2.0.so.0
 ?? ()
 ?? ()
Title: geany crashed with SIGSEGV in strcmp()
Uname: Linux GoNow 2.6.20-16-generic #2 SMP Sun Sep 23 18:31:23 UTC 2007 x86_64 GNU/Linux
UserGroups: adm admin audio cdrom dialout dip floppy lpadmin mythtv plugdev scanner video

Related branches

Jürgen Mertens (j-mertens) wrote :

StacktraceTop:strcmp () from /lib/libc.so.6
compare_symbol (a=0xb74580, b=0xb74560) at symbols.c:312
g_list_sort_real (list=<value optimized out>, compare_func=0x4684f0 <compare_symbol>, user_data=0x0) at /build/buildd/glib2.0-2.14.1/glib/glist.c:583
get_tag_list (idx=<value optimized out>, tag_types=1048575) at symbols.c:380
symbols_recreate_tag_list (idx=0) at symbols.c:620

Changed in geany:
importance: Undecided → Medium

Thank you for your bug report.

Could you please try to reproduce this with a more recent version of geany ? If you can reproduce, please attach an updated stacktrace and I will forward this to the upstream developer.

Thank you in advance !

Changed in geany:
status: New → Incomplete

The problem seems to be solved, with Version 0.14 the problem didn't occure.

2009/2/18 Jérôme Guelfucci <email address hidden>

> Thank you for your bug report.
>
> Could you please try to reproduce this with a more recent version of
> geany ? If you can reproduce, please attach an updated stacktrace and I
> will forward this to the upstream developer.
>
> Thank you in advance !
>
> ** Changed in: geany (Ubuntu)
> Status: New => Incomplete
>
> --
> geany crashes during character conversion to "no coding"
> https://bugs.launchpad.net/bugs/147151
> You received this bug notification because you are a direct subscriber
> of the bug.
>
>

--
Grüße

Jürgen Mertens
mailto:<email address hidden>

The upstream author just had a look at this and fixed this in upstream SVN, this will be available in the next geany release. Thank you again for having reported this bug, and sorry for the numerous mails...

Changed in geany:
status: Incomplete → Fix Committed

0.17 was uploaded to Karmic and fixes this problem.

Changed in geany (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers