geany fails to open files on xfs (inode 64)

Bug #1270127 reported by Alessandro Cantatore on 2014-01-17
This bug affects 1 person
Affects Status Importance Assigned to Milestone
geany (Ubuntu)

Bug Description

The problem affects past and current version of geany on various
*buntu flavors and versions (tested only on 32 bit distributions)

I have various text files on a large (little less than 2TB) xfs formatted volume
which geany consistently fails to open (value too large...).

The problem arises from stat() calls passing the address of a structure of unfit size.
It probably depends on inode numbers as the file sizes are just few kBs.

I found that the stat() source code example (see "man -s2 stat") produces the
same error (value too large...) when tested with those files.

The problem is easily solved by rebuilding with -D_FILE_OFFSET_BITS=64.

I've been using for a few months geany rebuilt with a #define _FILE_OFFSET_BITS 64
at the start of the main header and it looks like that solved the problem.

It would be great if you could patch the next geany.deb releases since it looks
like the problem is relatively common (google: "geany value too large").


stinke (redhat-tux) wrote :

I can confirm the problem and the fix. Considering how easy it is to fix, please integrate the patch.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers