gdpc version 2.2.5-1 failed to build on amd64 with GCC-4.6/oneiric

Bug #770768 reported by Matthias Klose on 2011-04-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gdpc (Ubuntu)
High
Unassigned
Oneiric
High
Unassigned

Bug Description

gdpc version 2.2.5-1 failed to build on amd64 with GCC-4.6/oneiric
Link to failed build: https://launchpad.net/ubuntu/+archive/test-rebuild-20110413/+buildjob/2450777

Details about the rebuild:
https://lists.ubuntu.com/archives/ubuntu-devel/2011-April/033042.html

Direct link to the build log: https://launchpad.net/ubuntu/+archive/test-rebuild-20110413/+buildjob/2450777/+files/buildlog_ubuntu-natty-amd64.gdpc_2.2.5-1_FAILEDTOBUILD.txt.gz

This log snippet might be of interest, since it triggered the matcher 'Purging chroot-autobuild'.
Excerpt 1469 lines into the build log:

 .
   [ Andreas Tille ]
   * New upstream version
   * debian/control:
     - Added myself to uploaders
     - Standards-Version: 3.8.3 (added README.source)
     - Debhelper 7
     - use quilt instead of simple-patchsys
   * debian/rules: short rules file using dh
Checksums-Sha1:
 e7d6356670391995028094871b6583d6526f1398 38886 gdpc_2.2.5-1_amd64.deb
Checksums-Sha256:
 f623f47020e1c57278270202e41bf60c1c281aecfc50c6f7a0c83ae6aded0446 38886 gdpc_2.2.5-1_amd64.deb
Files:
 369154849c8d54e90138ddc4861335e9 38886 science optional gdpc_2.2.5-1_amd64.deb

******************************************************************************
Built successfully
Purging chroot-autobuild/build/buildd/gdpc-2.2.5

Matthias Klose (doko) on 2011-04-26
Changed in gdpc (Ubuntu):
importance: Undecided → High
Nelson A. de Oliveira (naoliv) wrote :

Actually it doesn't fail to build, but gives only a warning at the end:

=====
Function `gdk_gc_new' implicitly converted to pointer at drawatoms.c:63

Our automated build log filter detected the problem(s) above that will
likely cause your package to segfault on architectures where the size of
a pointer is greater than the size of an integer, such as ia64 and amd64.

This is often due to a missing function prototype definition.

Since use of implicitly converted pointers is always fatal to the application
on ia64, they are errors. Please correct them for your next upload.

More information can be found at:
http://wiki.debian.org/ImplicitPointerConversions
=====

Changed in gdpc (Ubuntu):
milestone: none → oneiric-alpha-3
Changed in gdpc (Ubuntu Oneiric):
milestone: oneiric-alpha-3 → none
status: New → Confirmed
tags: added: universe
Colin Watson (cjwatson) wrote :

Nelson, such warnings are intentionally converted into hard failures on Ubuntu amd64.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gdpc - 2.2.5-1ubuntu1

---------------
gdpc (2.2.5-1ubuntu1) oneiric; urgency=low

  * Drop -DGDK_DISABLE_DEPRECATED until such time as gdpc is converted to
    use Cairo for drawing (LP: #770768).
 -- Colin Watson <email address hidden> Mon, 19 Sep 2011 13:01:36 +0100

Changed in gdpc (Ubuntu Oneiric):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers