[nouveau] Ubuntu 18.10 boots to a blank screen with a blinking cursor

Bug #1796614 reported by Christopher Patti on 2018-10-08
This bug affects 7 people
Affects Status Importance Assigned to Milestone
gdm3 (Ubuntu)
mutter (Ubuntu)

Bug Description



Running startx starts X just fine, but at login I just get a blank screen with a blinking cursor. If I hit Alt+F<n> I can get a console which allows me to login and run 'startx' at which point Gnome starts normally after entering my keychain unlock password.

ProblemType: Bug
DistroRelease: Ubuntu 18.10
Package: xorg 1:7.7+19ubuntu8
ProcVersionSignature: Ubuntu 4.18.0-8.9-generic 4.18.7
Uname: Linux 4.18.0-8-generic x86_64
ApportVersion: 2.20.10-0ubuntu11
Architecture: amd64
BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
CompositorRunning: None
CurrentDesktop: GNOME
Date: Sun Oct 7 22:59:13 2018
DistUpgraded: Fresh install
DistroCodename: cosmic
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes, including running git bisection searches
 Subsystem: Dell Device [1028:0877]
 NVIDIA Corporation GP104M [GeForce GTX 1070 Mobile] [10de:1be1] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: Dell GP104M [GeForce GTX 1070 Mobile] [1028:0877]
InstallationDate: Installed on 2018-10-07 (0 days ago)
InstallationMedia: Ubuntu 18.10 "Cosmic Cuttlefish" - Beta amd64 (20180927)
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 003: ID 1bcf:2b8c Sunplus Innovation Technology Inc.
 Bus 001 Device 002: ID 187c:0550 Alienware Corporation
 Bus 001 Device 004: ID 8087:0025 Intel Corp.
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Alienware Alienware 17 R5
 PATH=(custom, no user)
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.18.0-8-generic root=UUID=c3d3798c-6179-472a-ba82-55ef94f4d382 ro quiet splash vt.handoff=1
SourcePackage: xorg
Symptom: display
Title: Xorg crash
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/10/2018
dmi.bios.vendor: Alienware
dmi.bios.version: 1.5.0
dmi.board.name: Alienware 17 R5
dmi.board.vendor: Alienware
dmi.board.version: A00
dmi.chassis.type: 10
dmi.chassis.vendor: Alienware
dmi.chassis.version: Not Specified
dmi.modalias: dmi:bvnAlienware:bvr1.5.0:bd08/10/2018:svnAlienware:pnAlienware17R5:pvr1.5.0:rvnAlienware:rnAlienware17R5:rvrA00:cvnAlienware:ct10:cvrNotSpecified:
dmi.product.family: Alienware
dmi.product.name: Alienware 17 R5
dmi.product.sku: 0877
dmi.product.version: 1.5.0
dmi.sys.vendor: Alienware
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.94-1
version.libgl1-mesa-dri: libgl1-mesa-dri 18.2.1-1ubuntu1
version.libgl1-mesa-glx: libgl1-mesa-glx N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.20.1-3ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:18.1.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20171229-1build1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.15-3

Christopher Patti (feoh) wrote :
Daniel van Vugt (vanvugt) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 1795637, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

affects: xorg (Ubuntu) → xorg-server (Ubuntu)
affects: xorg-server (Ubuntu) → gdm3 (Ubuntu)
Christopher Patti (feoh) wrote :

Hi there. Thanks for the triage. As per https://bugs.launchpad.net/ubuntu/+source/gdm3/+bug/1795637/comments/25 this bug isn't a duplicate of the bug you mention. I've removed the duplicate notation.

In fact this bug is being tracked in upstream Gnome bug https://gitlab.gnome.org/GNOME/gdm/issues/428

Christopher Patti (feoh) wrote :

Not sure if there's a way to mark this bug as duplicated by the upstream Gnome one.

Daniel van Vugt (vanvugt) wrote :

I think the right answer is to reopen bug 1795637. Unless you can convince people to move the remaining discussion into this bug.

summary: - Ubuntu 18.10 - X fails to start on login
+ Ubuntu 18.10 boots to a blank screen with a blinking cursor
Changed in gdm3 (Ubuntu):
importance: Undecided → High

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gdm3 (Ubuntu):
status: New → Confirmed
Christopher Patti (feoh) wrote :

I don't know if anyone's tuned into this bug anymore, but are there any other verbose / debug logs I could attach to help move this one closer to resolution?

I'm totally up for doing the leg work, I just need to understand where to start digging :)

Daniel van Vugt (vanvugt) wrote :

It appears to be just us right now :)

I suggest the best next step is to report the bug to the gdm developers here:


as they are the ones who can really understand the logs. Once you have created a new bug there please mention here what its ID is.

Changed in gdm3 (Ubuntu):
status: Confirmed → Incomplete
description: updated
Changed in gdm3 (Ubuntu):
status: Incomplete → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gdm3 (Ubuntu):
status: New → Confirmed
Christopher Patti (feoh) wrote :

Hi guys! (Daniel? Since you seem to be the only one reading this :)

I fixed it! :) I added:

ow at les
to the [daemon] section of /etc/gdm3/custom.conf and the Gnome GUI starts right up on login!

I feel accomplished! :)

Now at least if anyone ever has time to fix the core issue, they'll know exactly where to look. I'll post the same thing in the upstream issue.

tags: added: nouveau
summary: - Ubuntu 18.10 boots to a blank screen with a blinking cursor
+ [nouveau] Ubuntu 18.10 boots to a blank screen with a blinking cursor
Changed in mutter (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Jeffery (jeffery-n-stewart) wrote :

I also have this problem.

Differences for me:

I have a RTX 2080 and installed Nvidia's 410.78 driver manually.

Whenever I boot, I too get the black screen with a blinking cursor. I also have the ctrl+alt+F3, login and run startx

This brings me to the gnome desktop instead of the traditional Ubuntu desktop.

I am not really sure how to fix this issue.

Jeffery (jeffery-n-stewart) wrote :


Thanks Christopher...

I duplicated your solution by editing the /etc/gdm3/custom.conf

Everything seems to be working again.


Daniel van Vugt (vanvugt) wrote :

The same workaround seems to be working for bug 1798790. Although that is about the proprietary Nvidia driver and this one is about nouveau (which also means Jeffery seems to be commenting on the wrong bug). Not sure if we can or should merge the two bugs.

tags: added: nvidia
tags: removed: nvidia
ncs (ncs-one) wrote :

I had the same problem, and also solved it with uncommenting WaylandEnable=false in /etc/gdm3/custom.conf.

I don't even have nVidia..! I'm using my CPU's graphics controller and intel graphics:

~ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller (rev 09)

~ modinfo i915
filename: /lib/modules/4.18.0-15-generic/kernel/drivers/gpu/drm/i915/i915.ko
license: GPL and additional rights
description: Intel Graphics
author: Intel Corporation

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers