[cosmic] [regression] DisplayPort Monitor works only once and not anymore after switching VTs in gdm 3.30.0

Bug #1791019 reported by shemgp on 2018-09-06
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gdm3 (Ubuntu)
High
Unassigned
mutter (Ubuntu)
High
Unassigned

Bug Description

https://gitlab.gnome.org/GNOME/gdm/issues/420

---

On Cosmic dev, I can't use my displayport monitor after logging in to gdm3. It works for login (displays the login page) after the VT switch to the session it becomes black. Using CTRL+f1, etc doesn't also show the console even in my VGA monitor.

Devices:
* Thinkpad x230t with Intel 3rd gen core processor and graphics unit.
* Laptop LCD.
* 4k monitor plugged in to display port.
* 1080p monitor plugged in to vga port.

The graphic's memory is not enough so I have to turn off the Laptop LCD to power 4k and 1080p monitors. When it boots, I can see the login screen in the 4k monitor.

To be able to login, what I do is unplug 4k monitor when booting and logging in. Once session is active, I plugin the 4k monitor.

Thank you for your work/help.

ProblemType: Bug
DistroRelease: Ubuntu 18.10
Package: gdm3 3.30.0-0ubuntu1
ProcVersionSignature: Ubuntu 4.17.0-9.10-generic 4.17.17
Uname: Linux 4.17.0-9-generic x86_64
ApportVersion: 2.20.10-0ubuntu9
Architecture: amd64
CurrentDesktop: GNOME
Date: Thu Sep 6 15:13:59 2018
EcryptfsInUse: Yes
InstallationDate: Installed on 2015-09-28 (1073 days ago)
InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422)
SourcePackage: gdm3
UpgradeStatus: Upgraded to cosmic on 2018-09-05 (0 days ago)
mtime.conffile..etc.gdm3.custom.conf: 2016-08-23T19:40:34.168140

shemgp (shemgp) wrote :
Daniel van Vugt (vanvugt) wrote :

This would be related to both:

  * The new feature of gdm3 exiting/restarting when you switch VTs; and
  * Other recent changes to VT handling in Ubuntu 18.10 (gdm3, mutter).

I had hoped these issues would be fixed with bug 1786872 and bug 1786872 :(

tags: added: vt
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gdm3 (Ubuntu):
status: New → Confirmed
Daniel van Vugt (vanvugt) wrote :

* I had hoped these issues would be fixed with bug 1786872 and bug 1786883.

tags: added: regression
Changed in gdm3 (Ubuntu):
importance: Undecided → High
summary: - DisplayPort Monitor works only once and not anymore after switching VTs
+ [cosmic] [regression] DisplayPort Monitor works only once and not
+ anymore after switching VTs in gdm 3.30.0
Daniel van Vugt (vanvugt) wrote :

Please report the issue to the Gnome developers here:

  https://gitlab.gnome.org/GNOME/gdm/issues/new

and then tell us the new bug ID.

Daniel van Vugt (vanvugt) wrote :

This might be my old friend; bug 1775764 again.

Changed in mutter (Ubuntu):
status: New → Confirmed
importance: Undecided → High
shemgp (shemgp) wrote :

More testing when using a DisplayPort connected to a 2k monitor:
I am able to do user switching flawlessly, but when I do a VT switch to the console and switch between the ttys for a while and login to one of them and then logout; if I go back to CTRL+f1 and I see the a cursor blinking and a black screen, that's my signal that my user sessions might already have died. After a while the gdm screen will show up and I am able to login to an account, but it will be a fresh one and the apps that were loaded before are gone. It's like the user session's where killed. Maybe when gdm restarted. Sometimes it works though, and I am able to relogin to my GUI session, especially if I don't see that cursor blinking with a black background.

Btw, I am not able to find the GUI logged in sessions in CTRL+f1..nor f2.. f3.. etc. I can only go to ctrl+f1 though and see GDM.

shemgp (shemgp) wrote :

Here's the bug report in GNOME Gitlab: https://gitlab.gnome.org/GNOME/gdm/issues/420

description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers