Logging out does not decrease the number of logged in users

Bug #1776487 reported by Marco Trevisan (Treviño) on 2018-06-12
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gdm3 (Ubuntu)
Medium
Marco Trevisan (Treviño)
Bionic
Undecided
Marco Trevisan (Treviño)

Bug Description

Running GDM/GNOME 3.28 on Ubuntu 18.04.

1) Boot the system, login.

uptime shows 1 logged user.

2) Logout from GNOME and login again:

uptime shows 2 logged users, instead of 1.

3) Logout from GNOME and login again:

uptime shows 3 logged users, instead of 1.

And repeating the process shows the same results, incrementing the number by 1 each time.

=======================

[ Impact ]

The number of logged users according to `uptime` grows and never goes down

[ Test case ]

1. Login with your user and launch `uptime` from a shell
   -> It should show "1 user"
2. Logout, and login again, then launch `uptime` again
   -> It should show "1 user" again
3. Repeating the process, uptime users number should match the actual
   number of logged in users

[ Regression potential ]

Nothing known so far, the fix is already in upstream branches (both stable and unstable)

Iain Lane (laney) on 2018-06-13
Changed in gdm3 (Ubuntu):
status: In Progress → Fix Committed
Changed in gdm3 (Ubuntu Bionic):
status: New → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gdm3 - 3.28.2-3ubuntu1

---------------
gdm3 (3.28.2-3ubuntu1) cosmic; urgency=medium

  * Merge with Debian. Remaining changes:
    + README.Debian: update for correct paths in Ubuntu
    + control.in:
      - Don't recommend desktop-base
      - Depend on bash for ubuntu_config_error_dialog.patch
      - Update Vcs field
    + rules:
      - Don't override default user/group
      - --enable-gdm-xsession to install upstream Xsession script
      - override dh_installinit with --no-start to avoid session being killed
    + rules, README.Debian, gdm3.8.pod:
      Use upstream custom.conf instead of daemon.conf
    + gdm3.{postinst,postrm}: rename user and group back to gdm
    + gdm3.postinst: don't kill gdm on upgrade
    + gdm3.*.pam: Make pam_env read ~/.pam_environment
    + gdm3.install:
      - Stop installing default.desktop. It adds unnecessary clutter
        ("System Default") to the session chooser.
      - Don't install debian/Xsession
    + Add ubuntu_run_xsession.d.patch
    + Add ubuntu_xresources_is_a_dir.patch
      - Fix loading from /etc/X11/Xresources/*
    + Add ubuntu_nvidia_prime.patch:
      - Add hook to run prime-offload (as root) and prime-switch if
        nvidia-prime is installed
    + Add revert_override_LANG_with_accountservices.patch:
      - On Ubuntu accountservices only stores the language and not the
        full locale as needed by LANG.
    + Add ubuntu_dont_set_language_env.patch:
      - Don't run the set_up_session_language() function, since it
        overrides variable values set by ~/.pam_environment
    + Add ubuntu_config_error_dialog.patch:
      - Show warning dialog in case of error in ~/.profile etc. and
        don't let a syntax error make the login fail
    + Add debian/default.pa
      - Disable Bluetooth audio devices in PulseAudio from gdm3.
    + debian/gdm3.install
      - Added details of the default.pa file
    + debian/gdm3.postinst
      - Added installation of default.pa and creation of dir if it doesn't
        exist.

gdm3 (3.28.2-3) unstable; urgency=medium

  * debian/patches/daemon-gdm-session-record.c-open-close-the-utmp-database.patch:
    - Keep the number of logged-in consistent with reality (LP: #1776487)

 -- Marco Trevisan (Treviño) <email address hidden> Wed, 13 Jun 2018 12:56:13 +0100

Changed in gdm3 (Ubuntu):
status: Fix Committed → Fix Released

Hello Marco, or anyone else affected,

Accepted gdm3 into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gdm3/3.28.2-0ubuntu1.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gdm3 (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic
Sebastien Bacher (seb128) wrote :

Using 3.28.2-0ubuntu1.3 "uptime" indeed lists the correct number of users

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gdm3 - 3.28.2-0ubuntu1.3

---------------
gdm3 (3.28.2-0ubuntu1.3) bionic; urgency=medium

  * debian/patches/daemon-gdm-session-record.c-open-close-the-utmp-database.patch:
    - Keep the number of logged-in consistent with reality (LP: #1776487)

 -- Marco Trevisan (Treviño) <email address hidden> Wed, 13 Jun 2018 13:04:30 +0100

Changed in gdm3 (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gdm3 has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers