[SRU] 3.28.2

Bug #1773968 reported by Iain Lane on 2018-05-29
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gdm3 (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Iain Lane

Bug Description

[ Description ]

The second stable release in the 3.28 series.

[ QA ]

Log in, log out, log in again. Get your password wrong. Try different sessions. Lock the screen, try to swtich to a different user.

We have a GNOME SRU exception allowing us to assume that upstream's fixes are good, and they don't require explicit QA. Please test gdm as per the above smoke testing. (https://wiki.ubuntu.com/StableReleaseUpdates/GNOME)

(In this case there's bug #1766137 which will get explicitly tested.)

[ Regression potential ]

A bad GDM update will, at worst, mean that people can't log in graphically.

Iain Lane (laney) on 2018-05-29
Changed in gdm3 (Ubuntu):
status: New → Fix Released
Changed in gdm3 (Ubuntu Bionic):
status: New → In Progress
assignee: nobody → Iain Lane (laney)

Hello Iain, or anyone else affected,

Accepted gdm3 into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gdm3/3.28.2-0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gdm3 (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic
Hennie Louw (hennie-g-louw) wrote :

Tested on Pop!_OS and it's working for me.
Version tested 3.28.2-0ubuntu1.1

Details of my steps were recorded here:
https://github.com/pop-os/pop/issues/238#issuecomment-393045933

Hennie Louw (hennie-g-louw) wrote :

Forget to mention, it's on Pop!_OS 18.04 :)

Łukasz Zemczak (sil2100) wrote :

Hello Iain, or anyone else affected,

Accepted gdm3 into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gdm3/3.28.2-0ubuntu1.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Hennie Louw (hennie-g-louw) wrote :

Verified that it is working for me.
Note, since the verification, I've since received a downstream patch on GDM3 from Pop!_Os repo's which also works.

tags: added: verification-done-bionic
removed: verification-needed-bionic

The verification of the Stable Release Update for gdm3 has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gdm3 - 3.28.2-0ubuntu1.2

---------------
gdm3 (3.28.2-0ubuntu1.2) bionic; urgency=medium

  * debian/patches/libgdm-drop-support-for-serializing-multiple-opens.patch,
    debian/patches/libgdm-fix-pointer-boolean-task-confusion.patch,
    debian/patches/libgdm-don-t-keep-manager-proxy-around-longer-than-we-nee.patch,
    debian/patches/libgdm-use-g_object_unref-instead-of-g_clear_object-for-w.patch,
    debian/patches/libgdm-get-connection-explicitly.patch,
    debian/patches/libgdm-Drop-weak-refs-on-the-GDBusConnection.patch,
    debian/patches/libgdm-Unref-the-manager-propagated-from-task.patch,
    debian/patches/libgdm-Don-t-double-ref-the-connection-got-from-task.patch,
    debian/patches/libgdm-Don-t-leak-connection-on-sync-re-authentication.patch,
    debian/patches/libgdm-Use-auto-pointers-and-cleanup-code.patch,
    debian/patches/libgdb-Try-to-reuse-connections-from-the-available-proxie.patch,
    debian/patches/libgdm-Don-t-save-manager-address.patch,
    debian/patches/libgdm-Return-NULL-on-invalid-client-instances.patch:
    - Cherry picks commits from upstream 3.28 branch to propely fix ref-counting
      issues on GdmClient (LP: #1766137)

gdm3 (3.28.2-0ubuntu1.1) bionic; urgency=medium

  * debian/gbp.conf: Add with 'bionic' configuration.
  * debian/control{,.in}: Update Vcs-* for git.
  * New upstream release (LP: #1773968):
    - Reference counting fixes for GdmClient (LP: #1766137)
    - ensure plymouth is quit properly even when local greeter is disabled
    - make sure GDM doesn't hang when called with unknown command line arguments
  * debian/patches/0001-libgdm-Don-t-unref-a-connection-that-s-in-use.patch,
    debian/patches/0002-libgdm-add-weak-pointer-for-connection-object.patch:
    Drop, included in this release.

gdm3 (3.28.0-0ubuntu1.1) bionic; urgency=medium

  * debian/patches/0001-libgdm-Don-t-unref-a-connection-that-s-in-use.patch,
    debian/patches/0002-libgdm-add-weak-pointer-for-connection-object.patch:
    Cherry-pick two patches from the 3.28 branch. These fix a refcounting bug
    in the GDM Client object, which had meant that the DBus connection was
    being disposed too early in some cases, particularly when logging in after
    a failed attempt. The symptom of that was that the system hung on a
    "blank" screen. (LP: #1766137)
  * debian/control{,.in}: Update for bionic

 -- Marco Trevisan (Treviño) <email address hidden> Tue, 05 Jun 2018 11:58:41 +0100

Changed in gdm3 (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.