no gdm3 greeter with nvidia quadro and modeset=1, discrete nvidia (not optimus)

Bug #1714881 reported by Tim Richardson on 2017-09-04
40
This bug affects 8 people
Affects Status Importance Assigned to Milestone
gdm
Expired
Medium
gdm3 (Ubuntu)
High
Unassigned

Bug Description

This is to track
https://bugzilla.gnome.org/show_bug.cgi?id=787207 " gdm & nvidia with modeset=1 causes loop, does not launch greeter "

I don't know if this is an nvidia bug or a gdm3 bug but it requires both to reproduce.

[reply] [−] Description <email address hidden> [reporter] 2017-09-03 10:46:21 UTC
Created attachment 359016 [details]
syslog

reproduced on two Thinkpad laptops with bios set to Discrete graphics. In this mode, the integrated Intel graphics is bypassed by a hardware mux and the machines appears to have only Nvidia graphics.

Environment is Ubuntu 17.10 development version, pre-release packages
One laptop has Quadro 1000M, the other Quadro M1000M. Both cards are supported by the latest Nvidia drivers.

Nvidia driver 375 or 384 (as packaged by Ubuntu)
/etc/modprobe.d/zz-nvidia.conf has
options nvidia_384_drm modeset=1

and after that setting
sudo update-initramfs -u

This problem does not occur when
lightdm is used in instead of gdm3
or
modeset=1
is not deployed.

The session attempted to launch is either gnome or the new "ubuntu" desktop session, which is gnome

The boot process fails.Sometimes there is just black screen (and high CPU activity driving the fans) and sometimes there is a message about NVIDIA persistence daemon starting and stopping, as well as gdm messages.

I mounted the filesystem after a crash, and I attach syslog.

In the attached syslog, search for persistenced to see messages like this

Sep 2 12:42:15 tim-ThinkPad-W520 org.gnome.Shell.desktop[1206]: Window manager warning: Failed to create renderer: Failed
 to initialize renderer: Missing extension for GBM renderer: EGL_KHR_platform_gbm, Failed to find matching EGLDeviceEXT
 Sep 2 12:42:15 tim-ThinkPad-W520 gnome-shell[1206]: Failed to create backend: Failed to create MetaRenderer
 Sep 2 12:42:15 tim-ThinkPad-W520 systemd[1]: Starting NVIDIA Persistence Daemon...
 Sep 2 12:42:15 tim-ThinkPad-W520 nvidia-persistenced: Verbose syslog connection opened
 Sep 2 12:42:15 tim-ThinkPad-W520 nvidia-persistenced: Now running with user ID 123 and group ID 131
 Sep 2 12:42:15 tim-ThinkPad-W520 systemd[1]: Started NVIDIA Persistence Daemon.
 Sep 2 12:42:15 tim-ThinkPad-W520 nvidia-persistenced: Started (1237)
 Sep 2 12:42:15 tim-ThinkPad-W520 gnome-session[1196]: gnome-session-binary[1196]: WARNING: App 'org.gnome.Shell.desktop'
 exited with code 1
 Sep 2 12:42:15 tim-ThinkPad-W520 gnome-session-binary[1196]: WARNING: App 'org.gnome.Shell.desktop' exited with code 1
 Sep 2 12:42:15 tim-ThinkPad-W520 gnome-session-binary[1196]: Unrecoverable failure in required component org.gnome.Shell.
 desktop
 Sep 2 12:42:15 tim-ThinkPad-W520 systemd-networkd-wait-online[536]: ignoring: lo
 Sep 2 12:42:15 tim-ThinkPad-W520 systemd[1]: Stopping NVIDIA Persistence Daemon...
 Sep 2 12:42:15 tim-ThinkPad-W520 nvidia-persistenced: Received signal 15
 Sep 2 12:42:15 tim-ThinkPad-W520 nvidia-persistenced: PID file unlocked.
 Sep 2 12:42:15 tim-ThinkPad-W520 nvidia-persistenced: PID file closed.
 Sep 2 12:42:15 tim-ThinkPad-W520 nvidia-persistenced: The daemon no longer has permission to remove its runtime data
 directory /var/run/nvidia-persistenced
 Sep 2 12:42:15 tim-ThinkPad-W520 nvidia-persistenced: Shutdown (1237)

Tim Richardson (tim-richardson) wrote :
summary: - no gdm3 greeter with nvidia quadro and modeset=1
+ no gdm3 greeter with nvidia quadro and modeset=1, discrete nvidia (not
+ optimus)
affects: gnome-shell (Ubuntu) → gdm3 (Ubuntu)
Changed in gdm3 (Ubuntu):
importance: Undecided → High
status: New → Triaged
Changed in gdm:
importance: Unknown → Medium
status: Unknown → Confirmed
summary: - no gdm3 greeter with nvidia quadro and modeset=1, discrete nvidia (not
+ no gdm3 greeter with nvidia quadro and modeset=1, discrete nvidia (not
optimus)
tags: added: nvidia

Why does the gdm option to disable wayland not make gdm and lightdm
behaviour identical in whatever they do to the nvidia driver when
modeset=1?

On 14 September 2017 at 11:36, Daniel van Vugt <
<email address hidden>> wrote:

> ** Summary changed:
>
> - no gdm3 greeter with nvidia quadro and modeset=1, discrete nvidia (not
> optimus)
> + no gdm3 greeter with nvidia quadro and modeset=1, discrete nvidia (not
> optimus)
>
> ** Tags added: nvidia
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1714881
>
> Title:
> no gdm3 greeter with nvidia quadro and modeset=1, discrete nvidia (not
> optimus)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gdm/+bug/1714881/+subscriptions
>

--
Tim Richardson

"reproduced on two Thinkpad laptops with bios set to Discrete graphics"

Weird, I only get this problem if the bios is set to: "Hybrid Graphics", and everything works on Discrete Graphics.

Details of how I've set those: https://askubuntu.com/questions/973605/ubuntu-17-10-boot-stuck-at-message-started-nvidia-persistence-daemon-after-ins/976578#976578

Lenovo P51, UEFI BIOS Version N1UE40W, NVIDIA Quadro M1200 Mobile, nvidia-384 installed from software-properties-gtk.

Tim Richardson (tim-richardson) wrote :

Are you using modeset=1 ?

On 15 November 2017 at 18:11, Ciro Santilli 六四事件 法轮功 <
<email address hidden>> wrote:

> "reproduced on two Thinkpad laptops with bios set to Discrete graphics"
>
> Weird, I only get this problem if the bios is set to: "Hybrid Graphics",
> and everything works on Discrete Graphics.
>
> Details of how I've set those:
> https://askubuntu.com/questions/973605/ubuntu-17-10-boot-stuck-at-
> message-started-nvidia-persistence-daemon-after-ins/976578#976578
>
> Lenovo P51, UEFI BIOS Version N1UE40W, NVIDIA Quadro M1200 Mobile,
> nvidia-384 installed from software-properties-gtk.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1714881
>
> Title:
> no gdm3 greeter with nvidia quadro and modeset=1, discrete nvidia (not
> optimus)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gdm/+bug/1714881/+subscriptions
>

--
Tim Richardson

Tim Richardson (tim-richardson) wrote :

Ciro, you have reported "works for me" but you have not confirmed that you are actually trying to reproduce the bug. The problem occurs when using modeset=1. You do not mentioned that here or in your related answer on askubuntu

If you are not using modeset=1, which is essential for people using Optimus who want to avoid tear-free graphics, then please clarify. This bug still exists for me, on both of my ThinkPads, and also with Fedora 27.

Tim Richardson (tim-richardson) wrote :

Another user has report this on the nvidia linux board. This user reproducts the problem exactly, and reports a workaround which narrows down the problem. I haven't yet verified this workaround.
While this user has both intel and nvidia, he/she does not appear to be using a laptop.

Hey guys, I too have noticed something strange with GDM when trying to enable PRIME synchronization with modeset=1 for the nvidia_drm on Ubuntu 17.10.

I have a desktop with an Intel i7 Coffee Lake 8700K and Titan Xp and one monitor is plugged into the iGPU while the other is to the dGPU. When turning on KMS for the nvidia_drm during modprobe phase, GDM only starts on the iGPU monitor and no monitor on the dGPU is detected and a blank screen occurs.

This is fixed by kill GDM and initiating a sudo startx command from SSH which initiates a gnome-session with both monitors now detected and PRIME sync working on the iGPU monitor.

Whats' interesting is that immediately after killing the startx command, and restarting GDM, both monitors are now detected and logging in results in the iGPU monitor now showing PRIME sync in xrandr

Tim Richardson (tim-richardson) wrote :

The user I referred to in the last comment has proposed changes to
/lib/systemd/system/gdm3.service

to fix the problem.

I have added his proposed changes to this report:

https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1716857

Changed in gdm:
status: Confirmed → Expired
Tim Richardson (tim-richardson) wrote :

In 18.10 (pre-release) this bug is no longer present.

Daniel van Vugt (vanvugt) wrote :

Thanks. If a fix exists in any release (even pre-release) then we mark it as Fix Released.

Changed in gdm3 (Ubuntu):
status: Triaged → Fix Released

Experiencing this trying to roll a fresh Arch Linux installation with 1060 GPU

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.