A live session can't be shut down due to "[ *** ] (2 of 2) A start job is running for ... (22s / no limit)"

Bug #1706939 reported by Doug McMahon on 2017-07-27
54
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
casper (Ubuntu)
Undecided
Dimitri John Ledkov
Bionic
Undecided
Dimitri John Ledkov
gdm3 (Ubuntu)
Medium
Unassigned
Bionic
Medium
Unassigned
systemd (Ubuntu)
Medium
Unassigned

Bug Description

Test case:
Boot to live session using current or recent image
Attempt to restart, shutdown or even log out.
Hangs basically forever with:

[ *** ] (2 of 2) A start job is running for Hold until boot process finishes up (21s / no limit)

or

[ *** ] (2 of 2) A start job is running for Wait for Network to be Configured (21s / no limit)

---
ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: gdm3 3.24.2-1ubuntu9
ProcVersionSignature: Ubuntu 4.11.0-10.15-generic 4.11.8
Uname: Linux 4.11.0-10-generic x86_64
ApportVersion: 2.20.6-0ubuntu4
Architecture: amd64
CasperVersion: 1.384
CurrentDesktop: GNOME
Date: Thu Jul 27 10:15:57 2017
LiveMediaBuild: Ubuntu 17.10 "Artful Aardvark" - Alpha amd64 (20170723)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gdm3
UpgradeStatus: No upgrade log present (probably fresh install)
mtime.conffile..etc.gdm3.custom.conf: 2017-07-27T10:13:04.127685

Doug McMahon (mc3man) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gdm3 (Ubuntu):
status: New → Confirmed
Changed in gdm3 (Ubuntu):
importance: Undecided → High
tags: added: regression
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1706939

tags: added: iso-testing
Daniel van Vugt (vanvugt) wrote :

I thought this can't be a GDM bug, but actually web searches suggest the "solution" is to switch to lightdm(?). Maybe this is caused by gdm.

Doug McMahon (mc3man) wrote :

There are some things pointing to gdm though far, far from conclusive
1. The current ubuntu-gnome daily image suffers the same
2. I have a usb from June 26 that works fine, it uses lightdm
3. This bug was filed on July 27 but was not immediate to the issue so it's emergence & the move to gdm3 *could* be the same.

If a image could be produced whose only diff is the dm that may be interesting.

Doug McMahon (mc3man) wrote :

This appears to have been fixed, either specifically or by happenstance.
Tested on image of Sept 4, live session terminated properly

It's still happening (slightly different message?) with last night's Sep 6 image.

summary: - A live session can't be terminated properly due to "[*** ]A start job
- is running for Hold for boot processes to finish up(XX/no limit)
+ A live session can't be terminated properly due to "[ *** ] (2 of 2) A
+ start job is running for Wait for Network to be Configured (21s / no
+ limit)"
description: updated
Daniel van Vugt (vanvugt) wrote :

Just reinstalled again and got the old message again:

[ *** ] (2 of 2) A start job is running for Hold until boot process finishes up (21s / no limit)

description: updated
summary: A live session can't be terminated properly due to "[ *** ] (2 of 2) A
- start job is running for Wait for Network to be Configured (21s / no
- limit)"
+ start job is running for ... (21s / no limit)"
summary: - A live session can't be terminated properly due to "[ *** ] (2 of 2) A
- start job is running for ... (21s / no limit)"
+ A live session can't be shut down due to "[ *** ] (2 of 2) A start job
+ is running for ... (21s / no limit)"

Yep, this is really messy..
Did 7 boot ups > restarts & got 4 different results

Twice got normal restarts that also included the pop up about 'remove media, press enter'
Twice got no pop up but the shutdown was text based & 'hung' on no particular errors, ctrl+c set it going again to a completed shutdown
Twice got the 'A start job is running for Hold' hang
Once got the 'Wait for Network` hang (- only session where I enabled wifi..

The systemd timeout ones are the most egregious as they're no limit.
Worst case scenario, is there any way to set all live session start/stop job's to a limited timeout? (30 sec or so max

Doug McMahon (mc3man) wrote :

This is a screenshot of the recoverable hang mentioned above, just sits there forever. crtl+c bumps it going, then 3 lines & a proper shutdown/resart

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in systemd (Ubuntu):
status: New → Confirmed
Doug McMahon (mc3man) wrote :

Just to see tried current 17.10 to an image with lightdm rather than gdm3. It was able to exit the live session cleanly every time over multiple attempts

tags: added: release-blocker
Will Cooke (willcooke) on 2017-09-27
tags: added: rls-as-incoming
Doug McMahon (mc3man) wrote :

Just to note: I do get proper shutdowns from tty1 (has to be done before attempting gui shutdown

tags: added: rls-aa-incoming
removed: rls-as-incoming
Will Cooke (willcooke) wrote :

We're not going to get this fixed this cycle. It will be looked at in the BB cycle.

tags: added: rls-aa-notfixing rls-bb-incoming
removed: rls-aa-incoming
Doug McMahon (mc3man) wrote :

It should then be added to the release notes.

Jeremy Bicha (jbicha) wrote :

Doug, this bug is mentioned in the release notes:

https://wiki.ubuntu.com/ArtfulAardvark/ReleaseNotes/#Desktop

JimmyL (jrlangston11) wrote :

I have this bug too. If it helps I have test a clean Beta 2 install twice and it doesnt hang on shutdown until the nvidia driver is installed then the bug occurs on every instance of a shutdown. It occurs on ubuntu desktop and kubuntu and in both instances only on nvidia install. Interestingly it did not happen at all on earlier beta/alpha releases.

JimmyL (jrlangston11) wrote :

My bug is only on shutdown "a stop job.... and relates to 1 of 2 ..network-manager and 2 of 2 ...WPA

On 09/30/2017 04:40 AM, JimmyL wrote:
> I have this bug too. If it helps I have test a clean Beta 2 install
> twice and it doesnt hang on shutdown until the nvidia driver is
> installed then the bug occurs on every instance of a shutdown. It
> occurs on ubuntu desktop and kubuntu and in both instances only on
> nvidia install. Interestingly it did not happen at all on earlier
> beta/alpha releases.
>
Jimmy, this bug is only about a live session, the issue after install
concerning nvidia drivers is something else.
For those with hybrid (optimus) devices this check this bug
https://bugs.launchpad.net/ubuntu/+source/gdm3/+bug/1715746

tags: added: regression-release
tags: removed: regression
tags: removed: release-blocker
Changed in ubuntu-release-notes:
status: New → Fix Released

this is an annoying issue, i had the same on a fresh installation of arfull on my dell inspiron 5570.

i think we have two separate issues:

A) [ *** ] (2 of 2) A start job is running for Wait for Network to be Configured (21s / no limit)

systemd-networkd-wait-online.service fails to start and it adds +2min delay at startup when your wired Ethernet is not connected.

looking at that https://github.com/systemd/systemd/issues/2154

I start the service by adding --ignore=enp2s0 in /lib/systemd/system/systemd-networkd-wait-online.service

[Service]
Type=oneshot
ExecStart=/lib/systemd/systemd-networkd-wait-online --ignore=enp2s0
RemainAfterExit=yes

Now i have:

time sudo /lib/systemd/systemd-networkd-wait-online --ignore=enp2s0
ignoring: enp2s0
ignoring: lo

real 0m0.023s
user 0m0.006s
sys 0m0.013s

B) a stop job ... or kworker blocked... msg at Shutdown, reboot ..
looking at https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1724317

I've fixed upgrading the kernel to 4.13.10.

Problem disappeared installing Ubuntu 18.04 LTS "Bionic Beaver" - Alpha amd64 (20171108)
also disappeared similar bug: https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1719191

Per-Inge (per-inge-hallin) wrote :

Installed "Bionic Beaver" from 2017-11-09.
Used "Install Ubuntu", which worked OK
Used "Try Ubuntu", made the installation, got the error message and not the expected "Remove the installation Media and press Return". Used Ctrl+C to stop the script and the system restarted. The Installation worked OK.

Jason (blackbluecaribou) on 2018-01-15
Changed in gdm3 (Ubuntu):
status: Confirmed → Fix Released
Changed in gdm3 (Ubuntu):
status: Fix Released → Confirmed
Will Cooke (willcooke) on 2018-03-06
tags: removed: rls-bb-incoming
Dimitri John Ledkov (xnox) wrote :

Ubiquity should not be booting anymore awaiting network configuration (i.e. systemd-networkd-wait-online is not enabled). Is there anything else to do for this bug report?

Changed in systemd (Ubuntu Bionic):
status: Confirmed → Incomplete
Daniel van Vugt (vanvugt) wrote :

It's certainly still a bug in 18.04 daily images. I don't know what the next step would be though.

Changed in systemd (Ubuntu Bionic):
status: Incomplete → Confirmed
Doug McMahon (mc3man) wrote :

Here the message continues to appear and the shut down or reboot is interrupted. The notable difference now is that it does time out after 15 seconds or so and the intended action proceeds.

tags: added: id-5ab94cfdb4921ee330c36ffd
Iain Lane (laney) wrote :

This isn't a gdm3 bug, right?

If it's a systemd or systemd unit problem and it's still happening, we probably need to provide some more information so that xnox or someone can help and take a look. I tried and just booting a live session in a VM and shutting it down works for me.

Can someone give clear reproduction steps, preferably for making this happen in a VM?

If it only happens for some people for some reason, maybe an affected person can get a journal log for this bug report: https://freedesktop.org/wiki/Software/systemd/Debugging/#index2h1 - although it'll be a bit harder to get it out of the live session it should be possible e.g. to mount a hard drive or a USB key or a 9p shared volume using virt-manager (hopefully that last one works at late shutdown).

Changed in gdm3 (Ubuntu Bionic):
status: Confirmed → Incomplete
Daniel van Vugt (vanvugt) wrote :

I don't know about VMs, but it seems to happen on just about every laptop I put bionic on.

On 04/03/2018 09:41 PM, Daniel van Vugt wrote:
> I don't know about VMs, but it seems to happen on just about every
> laptop I put bionic on.
>
Can echo the same here, has consistently occurred on various laptops
here for quite some time. The only change has been of recent (couple of
months) it did actually time out & proceed to shutdown or restart.
An exception to that is today's image (04/02 iso), it doesn't show
message but once returning to the splash screen it just hangs there forever.
(returning to tty2 from splash show no add. info or progress or error..

Not for me, sorry about that. So please if you could, try to collect some debugging information.

Dimitri John Ledkov (xnox) wrote :

@vanvugt
@mc3man

This bug was specifically about the Ubuntu Desktop Installer, and the experience one has with it.

Are you experiencing something similar, on the installed system, after the installation is done and you use Ubuntu normally? In that case that's a separate issue. Please open a new bug.

If people experience shutdown issues of the live image, please clearly state which image serial is used and what the symptoms are and how to reproduce it.

Daniel van Vugt (vanvugt) wrote :

My comment in #27 was current for daily images up to a few days ago.

Today I am using image 20180404 and can't reproduce the issue. So Incomplete.

Like Doug I do find many systems still hang instead of shutting down with 20180404, but there are different reasons for those and the error message this bug is about does not appear. So they should be different bugs.

Changed in systemd (Ubuntu Bionic):
status: Confirmed → Incomplete

On 04/04/2018 11:11 PM, Daniel van Vugt wrote:
> My comment in #27 was current for daily images up to a few days ago.
>
> Today I am using image 20180404 and can't reproduce the issue. So
> Incomplete.
>
> Like Doug I do find many systems still hang instead of shutting down
> with 20180404, but there are different reasons for those and the error
> message this bug is about does not appear. So they should be different
> bugs.
>
>
> ** Changed in: systemd (Ubuntu Bionic)
> Status: Confirmed => Incomplete
>
Haven't tried todays image but noticed with 20180404 that when it hangs
at 'splash' screen that going to tty1 & using ctrl+c allows the
shutdown/restart to proceed to completion.

Daniel van Vugt (vanvugt) wrote :

Ah. I can reproduce this using image 20180408 on a Lenovo X250 (after completing a full install). But most machines are not showing the message. Certainly there are lots of shutdown hangs in live sessions, but they're mostly not showing this error message any more.

summary: A live session can't be shut down due to "[ *** ] (2 of 2) A start job
- is running for ... (21s / no limit)"
+ is running for ... (22s / no limit)"
Changed in gdm3 (Ubuntu Bionic):
importance: High → Medium
status: Incomplete → Confirmed
Changed in systemd (Ubuntu Bionic):
status: Incomplete → Confirmed
importance: Undecided → Medium
Dimitri John Ledkov (xnox) wrote :

@Daniel van Vugt (vanvugt)

Does pressing Enter causes the system to reboot, after it hangs?

Do you see a plymouth purple screen instructing you to remove installation media and hit enter?

Do you see a console text message instructing you to "Remove installation media and reboot" (meaning hard-reset)?

no longer affects: systemd (Ubuntu Bionic)
Daniel van Vugt (vanvugt) wrote :

Using cosmic image 20180530, I can still see the error briefly. But in less than a second it's now replaced with a black terminal screen saying just:

  "Please remove the installation medium, then reboot."

So no, pressing Enter does not cause the system to reboot. I have to use the power button.

No, I do not see any purple screen.

Doug McMahon (mc3man) wrote :

 See the same as Daniel on both 18.04 & 18.10 live sessions,
"Please remove the installation medium, then reboot."

After removing media nothing happens, pressing enter nothing happens.
Here I use ctrl+c, then the reboot initializes

Iain Lane (laney) wrote :

hi xnox, is this the same as casper 1.394 - i.e. a failure to properly cache everything that casper needs?

If so, I don't think this is a gdm3 bug itself. I just assigned this to nudge you on it; feel free to move on as you see fit.

(Making Invalid for gdm3 to get this off our rls-bb-tracking list.)

Changed in casper (Ubuntu):
assignee: nobody → Dimitri John Ledkov (xnox)
Changed in casper (Ubuntu Bionic):
assignee: nobody → Dimitri John Ledkov (xnox)
Changed in gdm3 (Ubuntu):
status: Confirmed → Invalid
Changed in gdm3 (Ubuntu Bionic):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.