use ubuntu-x11 as default session

Bug #1703601 reported by Jean-Baptiste Lallement on 2017-07-11
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gdm3 (Ubuntu)
Undecided
Unassigned

Bug Description

On artful, on a fresh installation, gdm sets the default session to ubuntu-wayland. It should be set to ubuntu-x11 until it's decided that wayland is the default display server.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: gnome-session 3.24.1-0ubuntu11
ProcVersionSignature: Ubuntu 4.10.0-26.30-generic 4.10.17
Uname: Linux 4.10.0-26-generic x86_64
ApportVersion: 2.20.5-0ubuntu5
Architecture: amd64
CurrentDesktop: GNOME
Date: Tue Jul 11 14:22:37 2017
InstallationDate: Installed on 2013-09-03 (1406 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Alpha amd64 (20130902)
ProcEnviron:
 TERM=screen-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-session
UpgradeStatus: No upgrade log present (probably fresh install)

Jean-Baptiste Lallement (jibel) wrote :
Changed in gnome-session (Ubuntu):
assignee: nobody → Didier Roche (didrocks)
affects: gnome-session (Ubuntu) → gdm3 (Ubuntu)
Changed in gdm3 (Ubuntu):
assignee: Didier Roche (didrocks) → nobody
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gdm3 - 3.24.2-1ubuntu6

---------------
gdm3 (3.24.2-1ubuntu6) artful; urgency=medium

  * debian/patches/ubuntu_prefer_x11_session.patch:
    Prefer X11 session over wayland. As we are not ready yet for
    switching to wayland yet, let's prefer X11 session when no specific
    choice was made. (LP: #1703601)
    This will be reverted once we switch to wayland by default.

 -- Didier Roche <email address hidden> Wed, 12 Jul 2017 10:34:46 +0200

Changed in gdm3 (Ubuntu):
status: New → Fix Released
Didier Roche (didrocks) on 2017-07-12
tags: added: desktop-trello-import
Daniel van Vugt (vanvugt) wrote :

I'm not sure if it was this bug or just a discussion I saw on IRC, but until this morning at least both "Ubuntu" and "Ubuntu on Wayland" sessions resulted in a Wayland session (on a fresh install from a couple of days ago). "Ubuntu" was not creating a Xorg session.

I was about to log a new bug today until I noticed updates seem to have fixed it...(?)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers