Computer never gets to the GDM3 login screen when nvidia- is installed

Bug #1632322 reported by Roger on 2016-10-11
190
This bug affects 40 people
Affects Status Importance Assigned to Milestone
gdm3 (Ubuntu)
Critical
Unassigned

Bug Description

I've experience this on two separate computers with two different nvidia cards. No optimus or Intel cards in the equation. I'm running Yakkety 16.10 with a (pure) and up-to-date Ubuntu Gnome from the gnome3-staging PPA.

Activating the proprietary NVIDIA drivers is probably the first thing anyone does, if he's got an NVIDIA card. After all, that's the point of getting one in the first place. But GMD3, the _only_ display manager installed with Ubuntu Gnome, doesn't work with _any_ of the Nvidia drivers required by the yakkety 4.8 kernel. (Nvidia must be 367 or higher, 364 doesn't cut it anymore.) The result is that anyone (i.e. everyone) who tries to activate the proprietary drivers won't be able to boot past a black screen devoid of useful information.

I've managed to temporarily bypass this inconvenience by switching to lightdm, but people installing Ubuntu Gnome can't be counted on to try this or even know about this. This really should work out of the box (and after activating the drivers).

ProblemType: Bug
DistroRelease: Ubuntu 16.10
Package: gdm3 3.20.1-1ubuntu2
ProcVersionSignature: Ubuntu 4.8.0-21.23-generic 4.8.0
Uname: Linux 4.8.0-21-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
ApportVersion: 2.20.3-0ubuntu8
Architecture: amd64
CurrentDesktop: GNOME
Date: Tue Oct 11 14:37:28 2016
InstallationDate: Installed on 2016-10-07 (4 days ago)
InstallationMedia: Ubuntu-GNOME 16.10 "Yakkety Yak" - Alpha amd64 (20161006)
SourcePackage: gdm3
UpgradeStatus: No upgrade log present (probably fresh install)

Roger (r-wiberg) wrote :
Jeremy Bicha (jbicha) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 1559576, so it is being marked as such.
That bug is also mentioned in the release notes:

https://wiki.ubuntu.com/XenialXerus/ReleaseNotes/UbuntuGNOME#Known_Issues
https://wiki.ubuntu.com/YakketyYak/ReleaseNotes/UbuntuGNOME#Known_Bugs

Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

Roger (r-wiberg) wrote :

Actually, this is not a duplicate of bug #1559576. GDM3 as such doesn't play nice with NVIDIA. This has nothing to with Optimus. And it doesn't concern "hybrid (prime) systems", which is the bug referenced in the release notes on https://wiki.ubuntu.com/YakketyYak/ReleaseNotes/UbuntuGNOME#Known_Bugs

This is about systems with _only_ an NVIDIA card refusing to boot, because of GDM3, as soon as the proprietary drivers are installed.

Jeremy Bicha (jbicha) wrote :

Ok, I un-duplicated the bug. I apologize for not reading the description closely enough.

Changed in gdm3 (Ubuntu):
importance: Undecided → High
importance: High → Critical
Jeremy Bicha (jbicha) wrote :

I updated the Yakkety release notes to mention Nvidia proprietary without mentioning hybrid.

Does this bug affect 16.04 LTS too?

dino99 (9d9) wrote :

A solution proposed here: Bug #1631089

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gdm3 (Ubuntu):
status: New → Confirmed
dino99 (9d9) on 2016-10-13
summary: - Computer never gets to the GMD3 login screen when nvidia- is installed
+ Computer never gets to the GDM3 login screen when nvidia- is installed
Roger (r-wiberg) wrote :

Re #5 and #6: According to bug #1631089 it seems to affect 16.04 as well, though I cannot remember ever running into this problem when I ran 16.04. Possibly because I already had ubuntu-gnome-default-settings (16.04.4) installed. I can't be sure, because all sorts of things have changed between installations (including what PPAs I use).

Anyway, it seems, now that I'm on 16.10, that I do have ubuntu-gnome-default-settings (16.10.5) installed but I ran into this anyway.

Laszlo Stenstråle (bekkra) wrote :

Apparently, gdm3 has a setting to use something else than Wayland. Using this setting on an Xorg machine changes nothing.
At boot, the display manager tries to start six times before giving up.
There is no apparent logging.
We should conclude that in its current packaging, GDM3 is incompatible with proprietary display drivers...

Laszlo Stenstråle (bekkra) wrote :

The proposed solution #1631089 - from one user's machine makes no difference on mine.

We need somebody with actual knowledge, rather than keep guesing....

Nick B. (futurepilot) wrote :

Decided to try Ubuntu-gnome on my desktop and then after I installed the Nvidia driver using the driver manager and rebooted, GDM would not start and I was left at a blank screen. Is anyone even looking in to this?

Joachim Schwender (jschwender) wrote :

I am working around this issue using lightdm for a while now, and this did not change with 16.10 and gnome 3.20
my hardware is: NVIDIA Corporation GK208 [GeForce GT 720] (rev a1), vanilla kernel 4.8.6

Symin (symin) wrote :

Encountered this problem after upgrading distribution from 16.04 to 16.10.

Found errors like:
gnome-shell[2130]: segfault at 14 ip 00007f629a464725 sp 00007ffc1de04f30 error 4 in libmutter.so.0.0.0[7f629a428000+ff000]

Not 100% sure how to debug program that fails at boot. So I have tried simple things first.

Not ideal solution, but fixed the problem by uninstalling all nvidia and nouveau drivers and installing 367.57 from nvidia's website. There was a new version (375.20) released 2 days ago. Haven't updated yet.

Sergio Mattei (ftxrc) wrote :

The hell is with this bug? It's been reported for ages but nothing gets done. Any progress on this? Maintainers - at least write a blog post acknowledging it and proposing solutions. It's very confusing for an end user to go through this.

Jugoslav Gacas (jgacas) wrote :

Unfortunately I am one of the users that is also affected by this issue. The bug description is accurate, it is exactly what happens to me.

I tried to install both 367 and 375 driver versions (actual card is GTX 560) but had no luck, in the end I had to revert to 16.04.

It would be very helpful if someone has at least an idea how to debug this issue so we can try to do that on different systems.

jose (jose-cybergalvez) wrote :

can't upgrade from 16.04 until this is fixed

Sascha (slappyhours) wrote :

Ubuntu 16.10, NVIDIA GTX 960, clean install (no upgrade)

Same here. After resolving the secure boot mess, I still cannot reach the login screen when using the nvidia drivers. No problems with Nouveau drivers (except for them being too slow).

Rigo (rgr) wrote :
Download full text (4.3 KiB)

It's a really stupid bug, with the proprietary nvidia driver Libmutter crashes. But I can still log into gnome-shell by pressing Ctrl+Alt+F2 logging in via tty2 and then issuing startx. Weirdly everything works from there.

Excerpt of syslog around the error:

----------------------------------------------------------------------------------------------

Dec 16 21:24:03 jupiter /usr/lib/gdm3/gdm-x-session[1444]: /sbin/prime-offload: 30: /sbin/prime-offload: cannot create /var/log/prime-offload.log: Permission denied
Dec 16 21:24:03 jupiter systemd[1439]: Started D-Bus User Message Bus.
Dec 16 21:24:03 jupiter dbus-daemon[1462]: Successfully activated service 'org.freedesktop.systemd1'
Dec 16 21:24:03 jupiter dbus-daemon[1462]: Activating via systemd: service name='org.a11y.Bus' unit='at-spi-dbus-bus.service'
Dec 16 21:24:03 jupiter systemd[1439]: Starting Accessibility services bus...
Dec 16 21:24:03 jupiter dbus-daemon[1462]: Successfully activated service 'org.a11y.Bus'
Dec 16 21:24:03 jupiter systemd[1439]: Started Accessibility services bus.
Dec 16 21:24:03 jupiter at-spi-bus-launcher[1464]: Activating service name='org.a11y.atspi.Registry'
Dec 16 21:24:03 jupiter at-spi-bus-launcher[1464]: Successfully activated service 'org.a11y.atspi.Registry'
Dec 16 21:24:03 jupiter org.a11y.atspi.Registry[1469]: SpiRegistry daemon is running with well-known name - org.a11y.atspi.Registry
Dec 16 21:24:03 jupiter at-spi-bus-laun[1464]: Failed to register client: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files
Dec 16 21:24:03 jupiter kernel: [ 23.913800] gnome-shell[1480]: segfault at 14 ip 00007fb0f4ebb725 sp 00007ffefa786310 error 4 in libmutter.so.0.0.0[7fb0f4e7f000+ff000]
Dec 16 21:24:03 jupiter gnome-session[1458]: gnome-session-binary[1458]: WARNING: Application 'org.gnome.Shell.desktop' killed by signal 11
Dec 16 21:24:03 jupiter gnome-session-binary[1458]: WARNING: Application 'org.gnome.Shell.desktop' killed by signal 11
Dec 16 21:24:04 jupiter kernel: [ 24.162037] gnome-shell[1490]: segfault at 14 ip 00007fe700928725 sp 00007fff61a27210 error 4 in libmutter.so.0.0.0[7fe7008ec000+ff000]
Dec 16 21:24:04 jupiter gnome-session-binary[1458]: WARNING: Application 'org.gnome.Shell.desktop' killed by signal 11
Dec 16 21:24:04 jupiter gnome-session[1458]: gnome-session-binary[1458]: WARNING: Application 'org.gnome.Shell.desktop' killed by signal 11
Dec 16 21:24:04 jupiter gnome-session[1458]: gnome-session-binary[1458]: WARNING: App 'org.gnome.Shell.desktop' respawning too quickly
Dec 16 21:24:04 jupiter gnome-session[1458]: gnome-session-binary[1458]: CRITICAL: We failed, but the fail whale is dead. Sorry....
Dec 16 21:24:04 jupiter gnome-session-binary[1458]: Unrecoverable failure in required component org.gnome.Shell.desktop
Dec 16 21:24:04 jupiter gnome-session-binary[1458]: WARNING: App 'org.gnome.Shell.desktop' respawning too quickly
Dec 16 21:24:04 jupiter gnome-session-binary[1458]: CRITICAL: We failed, but the fail whale is dead. Sorry....
Dec 16 21:24:04 jupiter org.a11y.atspi.Registry[1469]: XIO: fatal IO error 11 (Resource temporarily unavailable) on X se...

Read more...

information type: Public → Public Security
information type: Public Security → Public
Rigo (rgr) wrote :

I managed to find a workaround by enabling autologin with nouveau installed, then installing the nvidia driver and restarting.

Logging in and out works, the greeter shows, screen locking works etc.

The issue is clearly related to how the system boots and showing the gdm greeter.

Žygimantas Beručka (zygis) wrote :

I have *no* nVidia card present on my laptop running with Intel HD4000 *only*, yet I have the same issue. Fresh install of Ubuntu 16.10. I am unable to start GDM as a service (systemctl), but I am able to start it directly ('gdm3') just fine as root from a TTY.

RobertFM (robert123m+ubuntu) wrote :

Temporary workaround is installing lightdm to get a logon screen and switch back to gdm3 when this bug is fixed.

I am also waiting on this bug to be fixed. I had this problem also a couple of years back.

sudo apt install lightdm

sudo dpkg-reconfigure lightdm

Then choose lightdm. Now you can use a login screen, instead of using auto-logon.

Mark (malvarose) wrote :

This bug was introduced in October, it is now mid February. How is this not fixed? Is there an update? What's going on.

Igor (invy) wrote :

This is configuration/initialization bug.

What happens is:
 - during startup gnome-shell is getting started and tries to initialize wayland session, which it cannot, because of lacking support in libraries
 - gdm and gnome-session-manager don't see gnome-shell running and also fail to start.

Normally gdm and gnome-shell must fallback to X.Org mode, which they apparently don't do on Ubuntu and simply try several more times and fail completely.

Fedora 25 works perfectly fine in such conditions:

gnome shell fails (please note, it doesn't crash but gives proper error messages):
Feb 23 02:00:46 afed gnome-shell[1233]: Can't initialize KMS backend: could not find drm kms device
Feb 23 02:00:46 afed gnome-session[1225]: gnome-session-binary[1225]: WARNING: App 'org.gnome.Shell.desktop' exited with code
Feb 23 02:00:46 afed gnome-session-binary[1225]: WARNING: App 'org.gnome.Shell.desktop' exited with code 1
Feb 23 02:00:46 afed gnome-session-binary[1225]: Unrecoverable failure in required component org.gnome.Shell.desktop
Feb 23 02:00:46 afed gdm-launch-environment][1127]: pam_unix(gdm-launch-environment:session): session closed for user gdm

gdm falls back to X.Org session:
Feb 23 02:00:47 afed gdm-launch-environment][1320]: pam_unix(gdm-launch-environment:session): session opened for user gdm by
Feb 23 02:00:47 afed audit[1320]: USER_START pid=1320 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:xdm_t:s0-s0
Feb 23 02:00:47 afed /usr/libexec/gdm-x-session[1404]: (--) Log file renamed from "/var/log/Xorg.pid-1409.log" to "/var/log/X
Feb 23 02:00:47 afed /usr/libexec/gdm-x-session[1404]: X.Org X Server 1.19.1

Jeremy Bicha (jbicha) wrote :

Try installing xserver-xorg-legacy

Jeremy Bicha (jbicha) wrote :

I am going to go ahead and mark this as a duplicate of LP: #1559576 where the identified solution is to install xserver-xorg-legacy. Eventually, there will be an SRU to make sure that that package is installed for people that need it.

This is not a duplicate. I just installed xserver-xorg-legacy. It did absolutely nothing. Still black screen. To clarify, this is a "monitor on, just displaying black" not a "monitor off/unable to start the xserver" issue. Xorg logs don't show anything weird. I've tried every permission setting from the xorg-legacy configure screen. No difference -- actually, if you set it to "Root Only", gdm never comes up and endlessly tries to restart, giving you a strobelight terminal, but that's irrelevant to this bug (probably?).

-----

Honestly, the only reason I care is because I'm trying to test out Gnome-wayland on the Nvidia proprietary drivers, because I heard it works now. It seems I have to go through gdm to get the Gnome-Wayland session to work. If anyone has an alternate way of getting that to work, please pm me with the details because going this route seems to be a dead end. Thanks.

Luis Alvarado (luisalvarado) wrote :

Just tested and on 16.04 and 17.04 installing xserver-xorg-legacy did nothing. I still get a black screen. What I did was install gnome desktop (gdm3 package), selected the gdm package instead of lightdm in the reconfiguration screen and after rebooting the problem started. The logs say everything is awesome but it's simply not working. If it helps I have the 378.13 Nvidia drivers, an Nvidia GTX 1080, 64GB Ram, Intel 6700k and Ubuntu 16.04 64 on the first test and then 17.04 on the second test. Both with the same issue.

Dylan Borg (borgdylan) wrote :

I am using a GTX 1080 with a Core i7 6900K and the 381 series proprietary driver. I am seriously worried about the move to GNOME from Unity and as such I;d like to test how GNOME performs before 18.04 arrives. Has anyone managed to at least start GNOME on X11?

gazhay (gazhay) wrote :

Can confirm this bug.

lightdm works and I can get into a GNOME environment, gdm just hangs after plymouthd screen.

17.04 latest NVIDIA drivers.

petersaints (petersaints) wrote :

I also don't think it's a duplicate. It also happens to me on Ubuntu GNOME 17.04 with GTX 1060 powered laptop.

for me the fix on #1631098 seems to work on my desktop i only have an nvidia card no laptop dual GFX hybrid

Ioan Loosley (1oangogo) wrote :

Also confirming that i am affected by this bug, this needs to be fixed soon as ubuntu is moving to gnome, this is going to impact your reputation if it isn't fixed

Graphics card: GTX 760

Tried drivers: 375 and 381 from the graphics drivers ppa

Ioan Loosley (1oangogo) wrote :

The other bug has been marked as fix, yet this issue persists

Jeremy Bicha (jbicha) wrote :

Ioan, this bug is fixed. Please file a new bug.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers