No auto login in Ubuntu GNOME Xenial

Bug #1547297 reported by Erick Brunzell on 2016-02-19
62
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Ubuntu GNOME
Medium
Unassigned
accountsservice (Ubuntu)
Undecided
Unassigned
gdm3 (Ubuntu)
High
Unassigned
sddm (Ubuntu)
High
Unassigned

Bug Description

Just installed Ubuntu GNOME Xenial 20160218 amd64 and selected to auto login during installation, but once the installation was complete and I booted into Ubuntu GNOME I was asked for my password. I looked in the user UI and auto login was set to off, so I unlocked it, selected auto login = on, clicked on lock again, and rebooted but was once again asked for my password and the user UI once again showed auto login = off.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: gdm3 3.18.2-1ubuntu1
ProcVersionSignature: Ubuntu 4.4.0-6.21-generic 4.4.1
Uname: Linux 4.4.0-6-generic x86_64
ApportVersion: 2.20-0ubuntu3
Architecture: amd64
CurrentDesktop: GNOME
Date: Thu Feb 18 20:26:14 2016
InstallationDate: Installed on 2016-02-19 (0 days ago)
InstallationMedia: Ubuntu-GNOME 16.04 LTS "Xenial Xerus" - Alpha amd64 (20160218)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gdm3
UpgradeStatus: No upgrade log present (probably fresh install)

Erick Brunzell (lbsolost) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gdm3 (Ubuntu):
status: New → Confirmed
Sam (litle-sam) wrote :

Same here on Ubuntu-GNOME 16.04 LTS "Xenial Xerus" - Alpha amd64
Auto login is set back to off after a reboot.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1547297

tags: added: iso-testing
Tim (darkxst) on 2016-02-19
Changed in ubuntu-gnome:
milestone: none → xenial
status: New → Confirmed
importance: Undecided → Medium
Changed in gdm3 (Ubuntu):
importance: Undecided → High
Tim (darkxst) wrote :

autologin works if you set it in '/etc/gdm3/custom.conf'

Seems there is some confusion about what "Automatic Login" in the user panel really does, see linked upstream bug.

Changed in gdm:
importance: Unknown → Medium
status: Unknown → Confirmed
amjjawad  (amjjawad) wrote :

Testing Ubuntu GNOME 16.04 Beta 1 amd64 (build: 20160225.1) and I confirm this bug!

I confirm this bug on a fresh install of the Beta iso.

Also, setting autologin in /etc/gdm3/custom.conf as suggested above got my machine to get stuck on boot, and had to restore the original settings with a live cd.

Erick Brunzell (lbsolost) wrote :

Was bug #1487819 ever fixed in Wily? I just wondered if the two could be related.

Keith Z-G (keithzg) wrote :

Also observed this testing the Beta iso today for Kubuntu i386, so it's not gdm specific per se.

Keith Z-G (keithzg) on 2016-03-24
tags: added: i386 plasma5
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in sddm (Ubuntu):
status: New → Confirmed
Changed in sddm (Ubuntu):
importance: Undecided → High
Tim (darkxst) wrote :

Accounts Service is supposed to update custom.conf, but the path is wrong now

Tim (darkxst) wrote :

Note the above comment is specific to gdm.

I do notice however that the Accounts Service "AutomaticLogin" property is not persistent across reboots, that would be why the settings toggle is broken.

Tim (darkxst) wrote :
Gunnar Hjalmarsson (gunnarhj) wrote :

Sponsored to the xenial queue.

Changed in accountsservice (Ubuntu):
status: New → Fix Committed
tags: added: patch
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package accountsservice - 0.6.40-2ubuntu9

---------------
accountsservice (0.6.40-2ubuntu9) xenial; urgency=medium

  * debian/patches/0005-gdm_config_file_path_ubuntu.patch:
    Copy patch from Debian packaging to correct the path to the
    GDM config file. (LP: #1547297)
  * debian/patches/0007-add-lightdm-support.patch:
    Update paths to gdm config directory

 -- Tim Lunn <email address hidden> Wed, 06 Apr 2016 10:59:09 +1000

Changed in accountsservice (Ubuntu):
status: Fix Committed → Fix Released
Tim (darkxst) on 2016-04-06
no longer affects: gdm
Gene Soo (genesoo77072) wrote :

I downloaded 4/7/16 15:37 Gnome AMD64 iso and this problem still exists. I see that the issue was marked as Fixed. Is this drop supposed to contain the fix or is there a delay in seeing this in the drop?

Gene Soo (genesoo77072) wrote :

Downloaded Daily Build for AMD64 4/8/16 15:59 at 4/8/16 15:49. Can't explain why time stamp was 10 minutes ahead of current time. This fix does not seem to be incorporated with this build. Even though the fix package accountsservice - 0.6.40-2ubuntu9 is available, it does no good unless it is incorporated into the build.

Erick Brunzell (lbsolost) wrote :

We're 99% of the way there. Setting auto-login during install still doesn't work though so I filed bug 1571415.

Tim (darkxst) on 2016-05-09
Changed in ubuntu-gnome:
status: Confirmed → Fix Released
Changed in gdm3 (Ubuntu):
status: Confirmed → Invalid
cmcanulty (cmcanulty) wrote :

confirmed no fix yet for xubuntu 16.04 this is a non starter for the library as users must be auto logged in or the librarians have to run around and login every machine

cmcanulty (cmcanulty) wrote :

I have a worse situation, the autologin goes to the admin user not the nonadmin as it is set. This is a library so it effects all of our security

fermulator (fermulator) wrote :

What was the installer editing instead? (is there some dangling file edits hanging around somewhere now?) -- I see from above that it was editing "/etc/gdm/...", on my system fully updated though, there is no dangling files in /etc/gdm/, so that's good.

This is what is actually needed (as we know):
{{{
$ cat /etc/gdm3/custom.conf | grep Auto
AutomaticLoginEnable = true
AutomaticLogin = <USER>
}}}

Even if we fixed the installer, what to do about all the existing versions with the bug?

Will we have it auto-correct once the user runs patch updates? - or are they just stuck with googling to find this bug report and then have to fix it manually? :(

Tuomas Lähteenmäki (lahtis) wrote :

I have a problem. Im using auto-login in my laptop. When im editing Users and Groups and selecting auto-login off in my user account. It not working. When reboot the computer. My account auto-login to desktop. Using Ubuntu MATE 16.04 32-bit. I have full upgraded system.

Tuomas Lähteenmäki (lahtis) wrote :

In my main computer 64-bit Ubuntu 16.04 LTS, it is working.

Leo (leillo1975) wrote :

I have the same problem in Ubuntu 17.10. I configure in settings my user to autologon in system but it don't works. If I type in a console:

cat /etc/gdm3/custom.conf | grep Auto

I have this:

AutomaticLoginEnable=True
AutomaticLogin=leo

I think that it's correct, but It don't login into my gnome xorg session

Changed in gdm3 (Ubuntu):
status: Invalid → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.