Cannot start icewm from the login page

Bug #757610 reported by Barry Fishman on 2011-04-11
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
gdm (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gdm

When I select icewm or IceWM from the login screen and enter my password the screen goes black, and the
login screen restarts. I get the following in my .xsession-errors:

/etc/gdm/Xsession: Beginning session setup...
Setting IM through im-switch for locale=en_US.
Start IM through /etc/X11/xinit/xinput.d/all_ALL linked to /etc/X11/xinit/xinput.d/default.
icewm-session: using /home2/barry/.icewm for private configuration files
icewmbg: using /home2/barry/.icewm for private configuration files
icewmtray: using /home2/barry/.icewm for private configuration files
IceWM: using /home2/barry/.icewm for private configuration files
XIO: fatal IO error 11 (Resource temporarily unavailable) on X server ":0"
      after 136 requests (131 known processed) with 0 events remaining.
XIO: fatal IO error 104 (Connection reset by peer) on X server ":0"
      after 129 requests (129 known processed) with 0 events remaining.
XIO: fatal IO error 104 (Connection reset by peer) on X server ":0"
      after 122 requests (122 known processed) with 0 events remaining.
icewmbg: Can't open display: :0. X must be running and $DISPLAY set.

However if I select blackbox from the gdm login screen it will start, and then I can rightclik and from the
logout menu select to start icewm. Icewm will then come up correctly.

My system was updated today 11-Apr-2011 and:
% uname -a
Linux ecube 2.6.38-8-generic #42-Ubuntu SMP Mon Apr 11 03:31:24 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux
% apt-cache policy icewm
icewm:
  Installed: 1.3.7~pre2-1
  Candidate: 1.3.7~pre2-1
  Version table:
 *** 1.3.7~pre2-1 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/universe amd64 Packages
        100 /var/lib/dpkg/status

This has been a problem for a while.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: gdm 2.32.1-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
Architecture: amd64
Date: Mon Apr 11 10:30:39 2011
ProcEnviron:
 LANGUAGE=en_US:en
 LC_COLLATE=C
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gdm
UpgradeStatus: No upgrade log present (probably fresh install)

Barry Fishman (barry-fishman) wrote :
Barry Fishman (barry-fishman) wrote :

I have a ATI Radeon HD 4670 Graphics Card, and was running the free radeon driver.

I just updated to the proprietary fglrx driver, and thinks work correctly now.

Barry Fishman (barry-fishman) wrote :

I spoke too soon in the last message. I tried this morning to login with IceWM and failed
in all attempts. I added a 5 second sleep to /etc/gdm/Xsession, thinking it might be that
the server did not have enough time to initialize, but had the same result.

I put a 'set +x' at the start of /etc/gdm/Xsession and have attached the resulting
.xsession-errors file, for a new user with no .profile or .X* files.

Barry Fishman (barry-fishman) wrote :

I built the upstream icewm 1.3 branch (under fedora 15) and it also failed. I traced the problem
to icewmbg crashing the X server.

Since the problem exists on multiple distributions (and cvs head) and both free and proprietary
ATI drivers, I submitted a upstream bug report:
https://sourceforge.net/tracker/?func=detail&aid=3289566&group_id=31&atid=10003

Bob Barry (bobb40) wrote :

The fault is in icewmbg, but to work around it:

  - delete or rename /usr/bin/icewmbg
  - create /usr/local/bin/icewmbg, containing:
      #!/bin/sh
      xsetroot -solid steelblue
      # colors are defined in /usr/share/X11/rgb.txt
  - sudo chmod +x /usr/local/bin/icewmbg

Many other utilities (xview, etc) may be used similarly.

francesco bat (nerobat2004) wrote :

I solved in this way !
Thank you very much ;-)
Bye
Francesco bat

i (iiiiii-deactivatedaccount) wrote :

By the way, both icewm or IceWM run icewm-session. There's a bug for that in Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=605926

i (iiiiii-deactivatedaccount) wrote :

I use Debian sid (not Ubuntu) and this issue is currently happening with icewmbg and with 'pcmanfm --desktop' (git version). It happens with other display managers as well like wdm and slim and with gdm only if gnome-settings-daemon is installed.
Starting the session with startx prevents this bug.
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=626331

This also affects Ubuntu Natty in my case - IceWm alone runs fine but IceWm-session crashes...UNLESS it is the first WM run in a boot, then it runs fine. Yes, it's weird. The problem seems to be with Icewmbg.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gdm (Ubuntu):
status: New → Confirmed
Barry Fishman (barry-fishman) wrote :

I've moved to Ubuntu 11.10 (oneiric) which does not have the problem.

Changed in gdm (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.