system user appears in login list of users

Bug #696038 reported by Curtis Hovey on 2010-12-31
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
gdm (Ubuntu)
Low
Robert Ancell
Natty
Low
Robert Ancell

Bug Description

Binary package hint: gdm

After upgrading to natty, the rabbitmq user was added to the list of user who can login.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: gdm 2.32.0-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.37-11.25-generic 2.6.37-rc7
Uname: Linux 2.6.37-11-generic i686
NonfreeKernelModules: nvidia wl
Architecture: i386
Date: Fri Dec 31 11:21:35 2010
ProcEnviron:
 LANGUAGE=en_US.UTF-8:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 LC_MESSAGES=en_AG.utf8
 SHELL=/bin/bash
SourcePackage: gdm

Curtis Hovey (sinzui) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, could you run ck-history --frequent and add that to the bug?

Changed in gdm (Ubuntu):
importance: Undecided → Low
Sebastien Bacher (seb128) wrote :

One issue could be that the ck-history users are not filtered on their uid

Dave Walker (davewalker) wrote :

The users i see at GDM greeter are, 'dave' and 'mysql' :

$ ck-history --frequent
dave 2895
gdm 249
root 15
puppet 13
mysql 2

summary: - rabbitmq user appears in login list of users
+ system user appears in login list of users
Soren Hansen (soren) wrote :

[2011-03-15 11:41:46] soren@lenny:~$ sudo ck-history --frequent
[sudo] password for soren:

** (ck-history:22914): WARNING **: Unable to parse session removed event: seat-id='Seat1' session-id='Session171' session-type='' session-x11-display='' session-x11-display-device='' session-display-device='/dev/???' session-remote-host-nam1297175131.310 type=SEAT_ADDED : seat-id='Seat1' seat-kind=0

** (ck-history:22914): WARNING **: Unable to parse session removed event: seat-id='Seat1' session-id='Session2405' session-type='LoginWindow' session-x11-display=':0' sess1292664169.926 type=SEAT_ADDED : seat-id='Seat1' seat-kind=0

nova 56767
soren 7945
root 495
gdm 126
rabbitmq 116
[2011-03-15 11:41:59] soren@lenny:~$

Soren Hansen (soren) wrote :

I only see nova on the list, though.

Changed in gdm (Ubuntu Natty):
status: New → Confirmed
milestone: none → ubuntu-11.04-beta-1
Dave Walker (davewalker) wrote :

/etc/passwd entries:
puppet:x:116:127:Puppet configuration management daemon,,,:/var/lib/puppet:/bin/false
mysql:x:117:128:MySQL Server,,,:/nonexistent:/bin/false

(note, puppet doesn't show but mysql does)

Sebastien Bacher (seb128) wrote :

bug #708911 has some fixes on the uid filtering but it seems that's not enough

Curtis Hovey (sinzui) wrote :

$ ck-history --frequent
curtis 1801
rabbitmq 307
gdm 255
nobody 47
root 4

Brian Murray (brian-murray) wrote :

I see couchdb in my login list.

Changed in gdm (Ubuntu Natty):
assignee: nobody → Robert Ancell (robert-ancell)
Marc Deslauriers (mdeslaur) wrote :

I am seeing this with the "postfix" user on a freshly installed natty.

Jamie Strandboge (jdstrand) wrote :

I started seeing this after installing rdnssd (uid 121).

Jamie Strandboge (jdstrand) wrote :

$ sudo ck-history --frequent
root 5732
jamie 5336
gdm 465
revssh 30
rdnssd 21
(null) 9

(revssh is uid 998).

Sebastien Bacher (seb128) wrote :

not sure if those should get ck sessions but they should not be listed in the gdm screen

Changed in gdm (Ubuntu Natty):
milestone: ubuntu-11.04-beta-1 → ubuntu-11.04-beta-2
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gdm - 2.32.0-0ubuntu14

---------------
gdm (2.32.0-0ubuntu14) natty; urgency=low

  * debian/patches/24_respect_system_minuid.patch:
    - Ignore entries from ck-history that are using system UIDs (LP: #696038)
  * debian/patches/42_no_ecryptfs_autologin.patch:
    - Don't autologin ecryptfs users (LP: #284443)
 -- Robert Ancell <email address hidden> Fri, 01 Apr 2011 15:49:50 +1100

Changed in gdm (Ubuntu Natty):
status: Confirmed → Fix Released
sergey892 (sergey-tsivin) wrote :

I see the same issue on Ubuntu 10.04 LTS.

sergey@tough:~$ uname -a
Linux tough 2.6.32-33-generic #72-Ubuntu SMP Fri Jul 29 21:08:37 UTC 2011 i686 GNU/Linux
sergey@tough:~$ cat /etc/issue
Ubuntu 10.04.3 LTS \n \l
sergey@tough:~$ ck-history --frequent
sergey 1354
gdm 371
rabbitmq 127
root 3
www-data 1

The problem has started when I installed rabbitmq-server package. The main nuisance is that when I click "shutdown" in gnome, it now prompts me to enter password because it *thinks* that another user is logged in to the computer.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers