gdm/kdm starting too early for DRM modules to load, no video

Bug #615549 reported by Hankyone on 2010-08-09
210
This bug affects 75 people
Affects Status Importance Assigned to Milestone
gdm (Ubuntu)
High
Canonical Desktop Team
Lucid
High
Martin Pitt
Maverick
High
Canonical Desktop Team
kdebase-workspace (Ubuntu)
High
Jonathan Thomas
Lucid
High
Unassigned
Maverick
High
Jonathan Thomas

Bug Description

Using "nomodeset" at boot works as a workaround

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: linux-image-2.6.35-14-generic 2.6.35-14.20
Regression: Yes
ProcVersionSignature: Ubuntu 2.6.35-14.20-generic 2.6.35
Uname: Linux 2.6.35-14-generic i686
NonfreeKernelModules: wl
Architecture: i386
Date: Mon Aug 9 15:59:55 2010
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha i386 (20100809)
ProcEnviron:
 LANG=en_US
 SHELL=/bin/bash
SourcePackage: linux
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: NVidia [HDA NVidia], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 1529 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'NVidia'/'HDA NVidia at 0xf0880000 irq 17'
   Mixer name : 'Nvidia MCP79/7A HDMI'
   Components : 'HDA:111d7675,10280271,00100103 HDA:10de0007,10280271,00100100'
   Controls : 20
   Simple ctrls : 11
DistroRelease: Ubuntu 10.10
HibernationDevice: RESUME=UUID=724430c8-4097-40d3-835b-e1538cba4bf7
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha i386 (20100809)
Lsusb:
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 002: ID 05ca:18a0 Ricoh Co., Ltd
 Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Dell Inc. Studio XPS 1340
NonfreeKernelModules: wl
Package: linux (not installed)
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-14-generic root=UUID=7e251ff1-0717-43ca-b496-8a11f8bc48ca ro rootdelay=60 nomodeset initcall_debug
ProcEnviron:
 LANG=en_US
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.35-14.20-generic 2.6.35
Regression: No
RelatedPackageVersions: linux-firmware 1.37
Reproducible: Yes
RfKill:
 0: dell-wifi: Wireless LAN
  Soft blocked: no
  Hard blocked: no
Tags: maverick graphics needs-upstream-testing
Uname: Linux 2.6.35-14-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 09/08/2009
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A11
dmi.board.name: 0K183D
dmi.board.vendor: Dell Inc.
dmi.board.version: A11
dmi.chassis.asset.tag: 1234567890
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A11
dmi.modalias: dmi:bvnDellInc.:bvrA11:bd09/08/2009:svnDellInc.:pnStudioXPS1340:pvrA11:rvnDellInc.:rn0K183D:rvrA11:cvnDellInc.:ct8:cvrA11:
dmi.product.name: Studio XPS 1340
dmi.product.version: A11
dmi.sys.vendor: Dell Inc.

---
Architecture: i386
DRM.card0.VGA.1:
 status: connected
 enabled: disabled
 dpms: On
 modes: 1024x768 800x600 800x600 848x480 640x480
 edid-base64:
DRM.card1.DisplayPort.3:
 status: disconnected
 enabled: disabled
 dpms: On
 modes:
 edid-base64:
DRM.card1.LVDS.2:
 status: connected
 enabled: disabled
 dpms: On
 modes: 1280x800 1024x768 800x600 640x480 720x400 640x400 640x350
 edid-base64: AP///////wBMo0NUAAAAAAASAQOQGhF4Cof1lFdPjCcnUFQAAAABAQEBAQEBAQEBAQEBAQEB7hoAgFAgEDAwIDYAK8MQAAAa7hoAgFAgEDAwIDYAK8MQAAAaAAAA/gBHTjI2NIAxMzNBVAogAAAAAAAAAAAAAAAAAAEBCiAgAOw=
DRM.card1.VGA.2:
 status: disconnected
 enabled: disabled
 dpms: On
 modes:
 edid-base64:
DistroRelease: Ubuntu 10.10
DkmsStatus: bcmwl, 5.60.48.36+bdcom, 2.6.35-14-generic, i686: installed
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha i386 (20100811)
Lsusb:
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 002: ID 05ca:18a0 Ricoh Co., Ltd
 Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Dell Inc. Studio XPS 1340
NonfreeKernelModules: wl
Package: xserver-xorg-video-nouveau 1:0.0.16+git20100805+b96170a-0ubuntu1
PackageArchitecture: i386
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-14-generic root=UUID=e578e61f-1e41-4242-8e12-c84f7c72da48 ro rootdelay=60 drm.debug=0x04 initcall_debug
ProcEnviron:
 LANG=en_US
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.35-14.20-generic 2.6.35
Tags: maverick maverick
Uname: Linux 2.6.35-14-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 09/08/2009
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A11
dmi.board.name: 0K183D
dmi.board.vendor: Dell Inc.
dmi.board.version: A11
dmi.chassis.asset.tag: 1234567890
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A11
dmi.modalias: dmi:bvnDellInc.:bvrA11:bd09/08/2009:svnDellInc.:pnStudioXPS1340:pvrA11:rvnDellInc.:rn0K183D:rvrA11:cvnDellInc.:ct8:cvrA11:
dmi.product.name: Studio XPS 1340
dmi.product.version: A11
dmi.sys.vendor: Dell Inc.
glxinfo: Error: [Errno 2] No such file or directory
system:
 distro: Ubuntu
 codename: maverick
 architecture: i686
 kernel: 2.6.35-14-generic

Hankyone (hankyone) wrote :
tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Anouar,

I think I am experiencing this same problem on my xps 13. Can you tell me if this fixes it for you?

sudo /etc/init.d/gdm stop
sudo /etc/init.d/gdm start

i am having this same problem when i reboot my laptop, but the above commands fix it.

I will confirm it and mark it as affecting me too if this is the same issue.

Darran

Hankyone (hankyone) wrote :

No luck, does not appear to be the same issue.

Ameet Paranjape (ameetp) on 2010-08-10
affects: linux (Ubuntu) → xserver-xorg-video-nouveau (Ubuntu)
Changed in xserver-xorg-video-nouveau (Ubuntu):
importance: Undecided → High
status: New → Triaged
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, assigning the issue to our xorg maintainer for review

Changed in xserver-xorg-video-nouveau (Ubuntu):
assignee: Canonical Desktop Team (canonical-desktop-team) → Chris Halse Rogers (raof)
Changed in xserver-xorg-video-nouveau (Ubuntu):
status: Triaged → Incomplete
Chris Halse Rogers (raof) wrote :

Unfortunately, the attached logs are from a boot with the nomodeset parameter set, which means that the nouveau drivers aren't actually in use.

When you say “no video”, at what point do you lose video - Do you see the bios startup screen? Do you see the grub screen (if it is displaying for you)? Do you see a modeswitch flicker after grub? Do you see the Ubuntu purple splash screen? Can you describe what happens during boot?

Could you please run “apport-collect 615549” during a boot *without* nomodeset parameter and with “drm.debug=0x04” set? If the video goes blank when starting X you should be able to boot into recovery mode and run this command. If you get no video at all, you should be able to run this command after ssh-ing in from a second machine. If you can't ssh in or don't have a second computer available, as a last resort you should be able to boot without nomodeset, wait for the boot to finish, restart, and then collect & attach /var/log/Xorg.0.log.old and /var/log/kern.log.

Hankyone (hankyone) wrote :

I lose the video when Nouveau is loaded (screen flickers, then nothing, no purple splash screen)
I see BIOS and GRUB just fine

description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

papukaija (papukaija) on 2010-08-15
summary: - [Maverick] Dell Studio XPS 13 no video
+ Dell Studio XPS 13 no video
Ameet Paranjape (ameetp) on 2010-08-16
Changed in xserver-xorg-video-nouveau (Ubuntu Maverick):
status: Incomplete → Triaged
Changed in xserver-xorg-video-nouveau (Ubuntu Maverick):
status: Triaged → In Progress
affects: xserver-xorg-video-nouveau (Ubuntu Maverick) → gdm (Ubuntu Maverick)
Changed in gdm (Ubuntu Maverick):
assignee: Chris Halse Rogers (raof) → nobody
status: In Progress → Triaged
Ameet Paranjape (ameetp) on 2010-08-17
Changed in gdm (Ubuntu Maverick):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Martin Pitt (pitti) on 2010-09-13
Changed in gdm (Ubuntu Maverick):
status: Triaged → Fix Released
21 comments hidden view all 101 comments

We should also backport this to lucid.

Changed in gdm (Ubuntu Lucid):
status: New → Triaged
Steve Langasek (vorlon) on 2010-09-16
Changed in gdm (Ubuntu Lucid):
milestone: none → ubuntu-10.04.2
Steve Langasek (vorlon) on 2010-09-17
Changed in gdm (Ubuntu Lucid):
importance: Undecided → High
Martin Pitt (pitti) on 2010-09-17
Changed in gdm (Ubuntu Lucid):
assignee: nobody → Martin Pitt (pitti)
status: Triaged → In Progress
Martin Pitt (pitti) on 2010-09-17
summary: - Dell Studio XPS 13 no video
+ gdm starting too early for DRM modules to load, no video

Lucid SRU uploaded. This needs review/ack from another SRU team member now.

Martin Pitt (pitti) wrote :

SRU patch: http://bazaar.launchpad.net/~ubuntu-desktop/gdm/lucid/revision/251

(Cherrypicked from packaging trunk)

Jamie Krug (jamie-thekrugs) wrote :

The patch from comment #64 does not entirely fix this issue for me on Lucid, although it has certainly improved things. I looked at the patch and changed my /etc/init/gdm.conf file accordingly (hopefully that's all I was supposed to do?). My gdm.conf is included with the archive attached to this comment. I went nearly two full days with this patch and no GDM crash, including a few reboots, suspends and hibernates... until tonight :( The lovely GDM crash appeared again, shortly after resuming from a suspend.

I've also included relevant log files around the time of this GDM crash.

After the crash, I shut down, then booted again, and promptly had another GDM crash almost immediately. I've logged in again and have been safe for 10-15 minutes here on tty8 now. I'll add a separate attachment for logs for this second crash.

Jamie Krug (jamie-thekrugs) wrote :

As I mentioned in my previous comment, I had another GDM crash right after a reboot. The logs for this one are attached here. Please let me know if there's anything else I can provide. Thanks.

Martin Pitt (pitti) wrote :

Yes, changing gdm.conf is all that the proposed SRU will do as well.

Can you please change this to

start on (filesystem
          and started dbus
          and stopped udevtrigger)

and run with that for a few days? Perhaps also do 20 reboots in a row if you can? Does that make a difference?

On 09/22/2010 08:45 AM, Martin Pitt wrote:
> Yes, changing gdm.conf is all that the proposed SRU will do as well.
>
> Can you please change this to
>
> start on (filesystem
> and started dbus
> and stopped udevtrigger)
>
> and run with that for a few days? Perhaps also do 20 reboots in a row if
> you can? Does that make a difference?
>
>
On Lucid or on Maverick?

Martin Pitt (pitti) wrote :

Seth [2010-09-22 8:00 -0000]:
> On Lucid or on Maverick?

Doesn't matter really.

Martin,

As you suggested, I've changed to this in my gdm.conf:

start on (filesystem
          and started dbus
          and stopped udevtrigger)

I will run with this for normal use and report back in a few days, or whenever a crash might occur (hopefully none!). I can also do 20 reboots in a row, but I'm not sure this will show me much. The crashes don't always occur right after reboot. Is there something more to this? Thanks.

Jamie Krug [2010-09-22 13:31 -0000]:
> The crashes don't always occur right after reboot.

Any effect which is related to the gdm.conf start condition _is_
related to boot. I. e. if gdm starts too early, then you will not get
a graphical environment at all, or a very poor one (no acceleration,
etc.). Crashes which happen during the running GNOME/KDE session are
unrelated to this.

Martin:
> Crashes which happen during the running GNOME/KDE session are
> unrelated to this.

Interesting. After sharing extensive results in bug #625239, it seemed quite clear that my issue related to the correct bug and that #625239 was a duplicate of this one (and has been marked as such). Am I really dealing with a completely different bug still? If so, any tips would be incredibly appreciated. This has been a long frustrating road (i.e., nice new loaded System76 Serval laptop w/Ubuntu 10.04, which is barely usable). Thanks in advance!

Jamie,

well, it could be that you actually only get a crash later on, when
gdm starts X.org on the framebuffer driver, and nvidia (or fglrx,
etc.) only gets loaded later on. So it would crash when you try to
start a 3D application, etc.

However, by looking at "glxinfo" or just the X server look it should
be possible to detect this situation right after boot.

Martin

--
Martin Pitt | http://www.piware.de
Ubuntu Developer (www.ubuntu.com) | Debian Developer (www.debian.org)

Seth (bugs-sehe) wrote :

On 09/22/2010 04:10 PM, Jamie Krug wrote:
> Martin:
>
>> Crashes which happen during the running GNOME/KDE session are
>> unrelated to this.
>>
> Interesting. After sharing extensive results in bug #625239, it seemed
> quite clear that my issue related to the correct bug and that #625239
> was a duplicate of this one (and has been marked as such). Am I really
> dealing with a completely different bug still? If so, any tips would be
> incredibly appreciated. This has been a long frustrating road (i.e.,
> nice new loaded System76 Serval laptop w/Ubuntu 10.04, which is barely
> usable). Thanks in advance!
>
>
The way I see it it was well established that you had the same bug that
was fixed here _BUT_ you then went on to receive other crashes that I'm
not sure are related at all. I haven't checked but can you still
identify the same symptoms:

   X starts on shared tty with getty
   X tty has isig flag set (stty(1))
   X crashes on hitting Enter or 2 keys (and perhaps a few other) with a
SIGINT (Enter) or a rather obscure handler traceback?

All this should be established when the greeter screen is shown (change
to vt1)

Include

ps -ef | grep X
gdmtty="$(ps --no-heading -o tty -p $(pgrep X))"
stty -F "/dev/$gdmtty"
ps -f -t "$gdmtty"

To me the CRUCIAL determinant to this particular bug is that 'vt7' does
_not_ appear on the command line for X. If it does, you have a different
bug or it is fixed :)

@Jamie

I think the fact that you haven't been getting VT1 starts confirms that the /etc/init/gdm.conf fix is effective.

Those logs look like the ones you posted in comment #69 and comment #98 of bug #625239. You are running on a good virtual terminal rather than VT1 or VT2 and you get just the header line of the backtrace--so they don't look like the bug we were tracking here or there.

When I looked a couple of weeks ago I couldn't find any bug reports like the ones you just posted, but I only looked for 15 minutes or so. You may want to check yourself.

Do you remember if you are typing anything when they happen? Anything else you can remember about the circumstances? You mentioned above a resume, is that always or usually involved?

If you think you were only having the VT1 (VT2) problem before you first reported the problem perhaps it would be worthwhile to check the changes you were trying out around comment #69 to see if they were all reversed. You were making changes to the grub configuration, if I recall.

Since we now know that your problem was related to the start of the proprietary NVIDIA driver and since the new problem looks like a crash in the same driver, you might be able to get relief from both by trying to switch to a different driver. I'm no longer using an nvidia card with my lucid system, but if I remember correctly I think you might check either the System->Admin->Hardware Drivers to change drivers, or perhaps you can switch drivers just by turning off all special effects in the Appearance preference. The new driver name then would be reflected in your xorg.0.log files.

If you decide to report this problem I'd suggest you use the "ubuntu-bug xorg" command right after experiencing it to collect the logs the xorg bug team like to see.

I'm sorry you are continuing to have problems.

Jamie Krug (jamie-thekrugs) wrote :

Martin:
> by looking at "glxinfo" or just the X server look it should
> be possible to detect this situation right after boot.

Sorry, I'm not entirely sure what to look for, but I've attached the output from a glxinfo command just after boot/login.

Jamie Krug (jamie-thekrugs) wrote :

Seth:
> Include
>
> ps -ef | grep X
> gdmtty="$(ps --no-heading -o tty -p $(pgrep X))"
> stty -F "/dev/$gdmtty"
> ps -f -t "$gdmtty"

I rebooted, switched to tty1 and I'm attaching the output from the above. Thanks.

Jamie Krug (jamie-thekrugs) wrote :

@John

> Do you remember if you are typing anything when they happen? Anything
> else you can remember about the circumstances? You mentioned above a
> resume, is that always or usually involved?

I'm fairly certain I was *not* typing anything, but usually had just clicked something (e.g., a link). I doubt the resume was involved, because last night I rebooted right after a crash and saw another crash shortly thereafter--unless it's possible that some sort of residual issue was related.

> If you think you were only having the VT1 (VT2) problem before you
> first reported the problem perhaps it would be worthwhile to check the
> changes you were trying out around comment #69 to see if they were all
> reversed. You were making changes to the grub configuration, if I
> recall.

Yes, I'm positive that I've reversed any and all changes. I've triple-checked. I may attempt a clean install soon anyway, just to be absolutely certain.

> Since we now know that your problem was related to the start of the
> proprietary NVIDIA driver and since the new problem looks like a crash
> in the same driver, you might be able to get relief from both by
> trying to switch to a different driver. I'm no longer using an nvidia
> card with my lucid system, but if I remember correctly I think you
> might check either the System->Admin->Hardware Drivers to change
> drivers, or perhaps you can switch drivers just by turning off all
> special effects in the Appearance preference. The new driver name then
> would be reflected in your xorg.0.log files.

I'm not sure I follow you here. I have tried the alternate nVidia driver ("version 173") and the "recommended" one, but had issues with both. When I disable nVidia drivers I have no problem, but then I get a very boring desktop experience ;-) Thanks again.

Jamie Krug (jamie-thekrugs) wrote :

I have some new clues on my crashes! First, Martin's changes to my gdm.conf as mentioned in comment #67 did not fix all for me, as I just had a few more crashes. What I noticed (and had a hunch this morning too), is that I believe I've primarily (if not always) had crashes occur while on battery power. This would explain the fact that I'm sometimes perfectly stable all day at the office (with AC power plugged in to my laptop) while other times it's just crash after crash.

I've also noticed that the crashes seem to occur very soon after login. The last 4-5 crashes have also all occurred just as I was opening Chrome browser.

I've also found a hint of this being battery/power related, as I found mentions of "gnome-power-manager" in a GDM log just after crash. I've attached various output and X/GDM logs. Here are a few lines from my :0-greeter.log.1 log, which has the gnome-power-manager warnings:

(gnome-power-manager:1852): GLib-GObject-WARNING **: /build/buildd/glib2.0-2.24.1/gobject/gsignal.c:2273: signal `proxy-status' is invalid for instance `0x773250'

** (gnome-power-manager:1852): WARNING **: Either HAL or DBUS are not working!

** (gnome-power-manager:1852): WARNING **: proxy failed

** (gnome-power-manager:1852): WARNING **: failed to get Computer root object

** (gnome-power-manager:1852): WARNING **: proxy NULL!!

Martin, you'd mentioned that the crash could be delayed from boot if something using 3D opens--could this be what's happening with Chrome? Then again, if my bug is related to power management, is this a separate bug or related? Thanks again to all for any help!

Jamie Krug (jamie-thekrugs) wrote :

Martin,

Based on my previous comment (#79), I'm curious whether you think this bug is still relevant or whether I should be opening a new bug (I'm guessing the latter). I've further confirmed the battery power relationship by working for a few hours with AC power plugged in and now crash, then later booting up on battery power and seeing crashes come fairly quickly and repeatedly. I've been searching around for other bugs that match, but no luck. Thanks again.

Accepted gdm into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in gdm (Ubuntu Lucid):
status: In Progress → Fix Committed
tags: added: verification-needed

Shouldn't SRUs have a well-defined test case?

Martin Pitt (pitti) wrote :

Unfortunately it is not that well-defined. This is mainly a race condition between loading DRM modules (such as nvidia) and gdm starting up. So this should mainly be tested by people who are affected by this bug, i. e. they do not get X start up, or with only the framebuffer driver (meaning no 3D acceleration, poor video playback, and presumably also problems on user switching).

Martin Pitt (pitti) wrote :

Adding kdebase-workspace task for kdm.

summary: - gdm starting too early for DRM modules to load, no video
+ gdm/kdm starting too early for DRM modules to load, no video
Changed in kdebase-workspace (Ubuntu Maverick):
importance: Undecided → High
status: New → Triaged
Changed in kdebase-workspace (Ubuntu Maverick):
assignee: nobody → Jonathan Thomas (echidnaman)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kdebase-workspace - 4:4.5.1-0ubuntu5

---------------
kdebase-workspace (4:4.5.1-0ubuntu5) maverick; urgency=low

  * debian/kdm.upstart: Do not already fire on a framebuffer device. When a
    real DRM driver gets loaded later on, X will be started too early to catch
    it. (LP: #615549)
 -- Jonathan Thomas <email address hidden> Tue, 28 Sep 2010 17:25:49 -0400

Changed in kdebase-workspace (Ubuntu Maverick):
status: Triaged → Fix Released
Ameet Paranjape (ameetp) on 2010-09-30
Changed in kdebase-workspace (Ubuntu Lucid):
status: New → Triaged
importance: Undecided → High
status: Triaged → Incomplete
Changed in kdebase-workspace (Ubuntu Lucid):
status: Incomplete → Triaged

I reinstalled lucid on the same system Anouar was using and I can't reproduce this bug, even with lucid fully up-to-date. Following upgrading to gdm from -proposed the issue still doesn't appear, so the best I can say is that the new package doesn't cause regressions on this particular hardware.

Jamie Krug [2010-09-23 18:47 -0000]:
> Based on my previous comment (#79), I'm curious whether you think this
> bug is still relevant or whether I should be opening a new bug (I'm
> guessing the latter).

Yes, it indeed sounds as if you have an unrelated problem then.
Thanks!

Seth (bugs-sehe) wrote :

On 10/01/2010 06:38 PM, Martin Pitt wrote:
> Jamie Krug [2010-09-23 18:47 -0000]:
>
>> Based on my previous comment (#79), I'm curious whether you think this
>> bug is still relevant or whether I should be opening a new bug (I'm
>> guessing the latter).
>>
> Yes, it indeed sounds as if you have an unrelated problem then.
> Thanks!
>
>
+1, sadly for you

Jamie Krug (jamie-thekrugs) wrote :

Martin, Seth: Thanks for the confirmation. FWIW, I've narrowed my newfound nasty crashes down to the Chrome browser, with nVidia drivers installed, but only when on battery power! If I disable nVidia drivers, or simply keep AC power connected to my laptop, everything is fine; but with battery power and nVidia, Chrome crashes hard almost instantly, every time--including a fresh install of Lucid/10.04 64-bit. Nothing else seems to cause a crash. As long as I stick with Firefox when on battery power, I've never seen a crash while working (with plenty of other apps, for extended periods). Ah well, haven't found a report yet, but will open a bug soon if I have to.

Ameet Paranjape (ameetp) wrote :

Based on comment #86, the package does not cause any regressions in Lucid. Marking as "verification-done" for Lucid.

tags: added: verification-done
removed: verification-needed
Changed in kdebase-workspace (Ubuntu Lucid):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
assignee: Canonical Desktop Team (canonical-desktop-team) → nobody
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gdm - 2.30.2.is.2.30.0-0ubuntu4

---------------
gdm (2.30.2.is.2.30.0-0ubuntu4) lucid-proposed; urgency=low

  * debian/gdm.upstart: Do not already fire on a framebuffer device. When a
    real DRM driver gets loaded later on, X will be started too early to catch
    it. Cherrypicked from packaging trunk r275. (LP: #615549)
 -- Martin Pitt <email address hidden> Mon, 20 Sep 2010 11:03:09 +0200

Changed in gdm (Ubuntu Lucid):
status: Fix Committed → Fix Released
Cesare Mastroianni (cece) wrote :

sorry for my (maybe stupid) question ... now the bug has been fixed: should I remove the PPA reference from my software source "http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu" ???

thanks

cm

rgrig (radugrigore) wrote :

After some upgrade/update my laptop (Sony VGN-SZ750N) stopped starting the graphical interface. For a couple of days I simply logged in, said "startx", and started working. After about five minutes, the graphical login would show up, interrupting what I was doing.

So I decided to investigate, and I discovered that reverting the patch discussed here fixes my problem.

Karri Kaksonen (karri) wrote :

I have had the same problem since 10.04. On MSI EX600 running GeForce 8400M G driver version 260.19.21. The kernel is 2.6.35-24. Before upgrading to 10.04 gdm worked perfectly but since then I get to the shell 50% of the time. So Ubuntu 10.10 has not fixed this problem as of today. Running on batteries or not makes no difference.

My gdm package is 2.30.5-0ubuntu4 (standard maverick package). Any ideas?

Karri Kaksonen (karri) wrote :

I also tried editing /etc/init.d/gdm.conf as stated at top of this thread with no effect. Also "sudo service gdm start" does not work. A strange thing is that shutting down the laptop causes the NVidia logo to appear immediately after pressing the power button to shut down the machine. It appears that the driver is waiting for some user input or signal at boot time. And it gets it when shutdown is started.

Yotam Benshalom (benshalom) wrote :

This keeps happening to me with recent natty kernels on 9500m nvidia card on dell xps1340 machine: either stuck on plymouth or thrown to tty login. Please, is there any way to work around this?

Yotam Benshalom (benshalom) wrote :

Well, I found a simple workaround: install lightDM and choose it as the default greeter in the dialog that ensues. Now I do not have to use failsafeX any more.

dtaylor84 (davidt-launchpad) wrote :

My natty system has recently started doing this too... X is ending up on VT 1 somehow, and then 'enter' is randomly triggering SIGQUIT...

Marius Kruger (amanica) wrote :

@Yotam Benshalom Installing lightDM did *not* fix this issue for me.
Trying https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers/+bug/625239/comments/143 next...

I have this bug on Natty with an intel mobile graphics card, I have i915 driver if that's important at all.

Steve Langasek (vorlon) wrote :

Andrew, you probably have a different bug. Please file a separate bug report with a description of what you're experiencing.

Adolfo Jayme (fitojb) on 2013-10-28
Changed in kdebase-workspace (Ubuntu Lucid):
status: Triaged → Won't Fix
Displaying first 40 and last 40 comments. View all 101 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers