With timed login enabled, logging in as another user fails.

Bug #585574 reported by Daniel Ellis on 2010-05-25
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gdm
Fix Released
Medium
gdm (Ubuntu)
Low
Unassigned
Lucid
Low
Unassigned

Bug Description

Binary package hint: gdm

Enable the timed login feature for user 'Guest'. Then reboot.
When the GDM presents the user list and displays the automatic login countdown, use the arrow keys to select another user and press enter. GDM does not display the password input box, and attempting to login will fail. After that, the greeter is reloaded and you are able to login normally.

You can avoid this issue by pressing Escape before selecting another user from the list.

This was tested on Ubuntu 10.04 Netbook Remix.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: gdm 2.30.0-0ubuntu5
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic i686
NonfreeKernelModules: wl
Architecture: i386
Date: Tue May 25 21:49:59 2010
InstallationMedia: Ubuntu-Netbook 10.04 "Lucid Lynx" - Release i386 (20100429.4)
ProcEnviron:
 LANG=en_GB.utf8
 SHELL=/bin/bash
SourcePackage: gdm

Related branches

Daniel Ellis (danellisuk) wrote :
Leo Arias (elopio) wrote :

I cuold reproduce it on my machine. Marking as confirmed...

elopio@tangamandapio-mini:~$ apt-cache show gdm
Package: gdm
Priority: optional
Section: gnome
Installed-Size: 7664
Maintainer: Sebastien Bacher <email address hidden>
Architecture: i386
Version: 2.30.0-0ubuntu5

Changed in gdm (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

the issue is fixed in the maverick version

Changed in gdm (Ubuntu):
importance: Undecided → Low
status: Confirmed → Fix Released
Changed in gdm (Ubuntu Lucid):
importance: Undecided → Low
status: New → Fix Committed
Changed in gdm (Ubuntu Lucid):
assignee: nobody → Sebastien Bacher (seb128)
Sebastien Bacher (seb128) wrote :

New stable update based on the current lucid version since the new version uploaded before introduces new issues

Sebastien Bacher (seb128) wrote :

simplified debdiff with the patches applied to the source, easier to read that diff of diff in the debian directory...

Changed in gdm:
status: Unknown → Fix Released

Accepted gdm into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Daniel Ellis (danellisuk) wrote :

Updated to gdm-2.30.2 from -proposed and can confirm that it resolves this bug. The new GDM version is much neater. The automatic login is presented without showing the other users. Selecting cancel or pressing ESC disables the auto login and the standard user list is presented. You also have the ability to skip the timed delay, by clicking login or pressing enter. In all, this is much better.

Daniel Ellis [2010-06-09 21:46 -0000]:
> Updated to gdm-2.30.2 from -proposed and can confirm that it resolves
> this bug. The new GDM version is much neater.

Thanks for testing! Can you please specify the precise version that
you tested, as there were two -proposed uploads for gdm?

Daniel Ellis (danellisuk) wrote :

Version: 2.30.2.is.2.30.0-0ubuntu1

Martin Pitt (pitti) on 2010-06-13
tags: added: verification-done
removed: verification-needed
Changed in gdm:
importance: Unknown → Medium
Changed in gdm (Ubuntu Lucid):
assignee: Sebastien Bacher (seb128) → nobody
Rolf Leggewie (r0lf) wrote :

lucid has seen the end of its life and is no longer receiving any updates. Marking the lucid task for this ticket as "Won't Fix".

Changed in gdm (Ubuntu Lucid):
status: Fix Committed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.