Home directory won't be decrypted if user password isn't asked

Bug #581303 reported by Muflone on 2010-05-16
36
This bug affects 7 people
Affects Status Importance Assigned to Milestone
eCryptfs
Undecided
Unassigned
ecryptfs-utils (Ubuntu)
Undecided
Unassigned
gdm (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gdm

This is not a duplicate of Bug #353446 even if it's similar.

Description of defect:
If the user enables password-less login through users-admin with encrypted home directory, the next reboot won't decrypt the home directory.

Step to reproduce:
- open users-admin
- click the change button next to password
- tick Don't ask for password on login
- reboot

What's expected to happen:
- the login will suceed and the home directory will be decrypted

What happened:
- the home directory won't be decrypted
- the user will be logged in but with a lot of errors caused from missing files/directories

System:
Ubuntu 10.04 LTS i386 with all updates applied

The similar bug #353446 solved this issue hiding the users with encrypted home from automatic login.

Jeff Fortin Tam (kiddo) wrote :

Seeing this in Maverick too. The attached screenshot shows that you simply need
1- to have an encrypted home directory (done at install time)
2- to check the "Don't ask for password on login" option in the user settings

Symptoms are as described above; ICE Authority errors, Nautilus not having permissions to launch, etc.

Strangely enough, if you switch to a virtual terminal (ctrl+alt+F1) and do a "sudo service gdm restart" and then click your username, it logins properly and decrypts the home directory, allowing GNOME to read your prefs etc. So it seems this happens only on the first login attempt, subsequent logins work.

Jesse Katzman (j-kat) wrote :

Hello,

I just ran into this problem. Here's what I've found: you cannot automatically login or do a passwordless login if your home directory is encrypted. When you switch to the terminal and log in, you're decrypting your home directory. Thus, once you've logged in through the terminal, you can log in to your desktop by going back to the login screen through "ctrl+alt+F8" or a "sudo service gdm restart".

I almost couldn't log into my Xubuntu because of this.

I went to "Users and Groups" and selected "Don't ask for password on login". When "Login Screen Settings" wouldn't let me log in automatically (my username was not selectable), I assumed it was a bug, not a warning, so I manually edited the /etc/gdm/custom.conf file to let me log in automatically. Because I still wanted my computer to be (mostly) secure, I enabled the lock screen after login. But when gdm tried to automatically log in, the screen would go blank and then I would be kicked back to the login screen because my home directory was encrypted.

The reason I went down this rabbit hole was to have wireless automatically enabled when (X)ubuntu starts.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ecryptfs-utils (Ubuntu):
status: New → Confirmed
Changed in gdm (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers