Setting disable_user_list to true causes gdm to crash on clicking "Log In"

Bug #579044 reported by Jeremy Zimmer on 2010-05-11
This bug affects 6 people
Affects Status Importance Assigned to Milestone
gdm (Ubuntu)
Nominated for Lucid by Joel Ebel

Bug Description

Binary package hint: gdm

This is happening with the new gdm version currently in proposed (2.30.2--0ubuntu1). I'm using Lucid amd64, installed using the alternate installer. Reverting to the version of gdm in main (2.30.0-0ubuntu5) fixes the problem.

Steps to reproduce:

sudo gconftool-2 --direct --config-source=xml:readwrite:/etc/gconf/gconf.xml.system --set /apps/gdm/simple-greeter/disable_user_list --type boolean true

(also tried using the gdm user's gconf tree, same result)

sudo service gdm restart

Click the "Log In" button. GDM will crash and restart, leaving you unable to login.

Joel Ebel (jbebel) on 2010-05-11
tags: added: regression-proposed
Joel Ebel (jbebel) wrote :

referenced in SRU bug 518810 and 398300

Joel Ebel (jbebel) wrote :

just to make it a link: bug 398300

papukaija (papukaija) wrote :

This bug is affecting 3 people. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in gdm (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please try to obtain a backtrace following the instructions at and upload the backtrace (as an attachment) to the bug report. This will greatly help us in tracking down your problem.

Changed in gdm (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Joel Ebel (jbebel) wrote :

After some more investigation, it turns out this is a problem only with oem installs. After an oem install, you are left with /etc/gdm/custom.conf with the following contents:


If I remove this file, gdm 2.30.2--0ubuntu1 works fine, and has a number of improvements over the previous version.

I'm not certain what is responsible for creating, or supposedly removing this file, but it looks like it shouldn't be there, and if it is, gdm 2.30.2--0ubuntu1 breaks if you disable the user list.

Changed in gdm (Ubuntu):
status: Incomplete → Confirmed
Sebastien Bacher (seb128) wrote :

do you have an "oem" user on your box? could you figure what setting create the issue exactly? is that an issue with the current update candidate version?

Joel Ebel (jbebel) wrote :

The "oem" user gets removed at the end of the oem-config process. I'll have to do some checking to see if a specific option breaks it, but I notice that a standard (non-oem) install doesn't have the file at all, so it seems like the oem-config process should remove that file upon completion. Though it also seems like gdm itself might be better equipped to deal with the problem.

This is not a problem with the current version in proposed, but 2.30.2 does have some fixes we are looking forward to getting, which the version in proposed doesn't offer.

Joel Ebel (jbebel) wrote :

It appears that the problem is in the TimedLogin feature. If you set TimedLoginEnable=true, you must also set a valid user in TimedLogin and a valid delay in TimedLoginDelay. If either of those is not set, or if the TimedLogin user is invalid, as was the case once "oem" was removed, then the behavior described above occurs. Keep in mind that this all depends on the user list being disabled.

Sebastien Bacher (seb128) wrote :

thank you for the extra informations, it should be enough to work on the issue

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers