Duplicate system keyboard layout

Bug #548778 reported by Ivanka Majic on 2010-03-26
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gdm (Ubuntu)
Low
Martin Pitt

Bug Description

- Ran install for first time
- selected 'use entire disk'
- on first run the gnome keyboard applet shows in the panel.

Please remove the Gnome Keyboard applet from the panel.

Ivanka Majic (ivanka) wrote :

Installing: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100326)

Changed in ubuntu:
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
tags: added: gloam
Martin Pitt (pitti) wrote :

Hello Ivanka,

which keyboard layout did you choose during installation?

Can you please attach /etc/default/console-setup and copy&paste the output of

  gconftool -g /desktop/gnome/peripherals/keyboard/kbd/layouts

(from a Terminal)? Thank you!

affects: ubuntu → gnome-settings-daemon (Ubuntu)
Changed in gnome-settings-daemon (Ubuntu):
status: New → Incomplete
importance: Undecided → Low
assignee: Canonical Desktop Team (canonical-desktop-team) → Martin Pitt (pitti)
Ivanka Majic (ivanka) wrote :
Ivanka Majic (ivanka) wrote :

I didn't make an explicit selection as UK keyboard was preselected.

Ivanka Majic (ivanka) wrote :

Running the gconftool line returned an empty list. Evan is here and he checked I had followed all instructions correctly.

Martin Pitt (pitti) wrote :

Hm, I can't reproduce this here. Let's check some further things: Can you please copy&paste the output of

  xprop -root|grep XKB
  udevadm info --export-db|grep LAYOUT|sort -u

?

Martin Pitt (pitti) wrote :

Ah, fun. I first tried with only "US", but I can actually reproduce that with "GB" on the netbook.

xprop -root has "gb,gb" in XKB_RULES_NAMES, seems this gets duplicated somehow.

Ivanka, can you confirm that if you right click on the selector -> Groups you see "UK" twice?

affects: gnome-settings-daemon (Ubuntu) → gdm (Ubuntu)
Changed in gdm (Ubuntu):
status: Incomplete → Triaged
summary: - Fresh install of Lucid shows Gnome keyboard applet in panel
+ Duplicate system keyboard layout
Ivanka Majic (ivanka) wrote :

Confirmed.

Martin Pitt (pitti) wrote :
Changed in gdm (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gdm - 2.29.92-0ubuntu9

---------------
gdm (2.29.92-0ubuntu9) lucid; urgency=low

  * 33-multi-keyboard-layouts.patch: Fix duplication of layouts by treating ""
    and NULL variants equally. (LP: #548778)
 -- Martin Pitt <email address hidden> Mon, 29 Mar 2010 10:07:58 +0200

Changed in gdm (Ubuntu):
status: Fix Committed → Fix Released
Magnes (magnesus2) wrote :

I still have it with gdm 2.30. I have one [pl, pl] keyboard layout but the indicator shows two groups (Poland and Poland).

Martin Pitt (pitti) wrote :

Magnes,

please submit the output of

  xprop -root|grep XKB
  grep ^X /etc/default/console-setup
  gconftool -g /desktop/gnome/peripherals/keyboard/kbd/layouts

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.