new theme not applied

Bug #532659 reported by Pavel Rojtberg on 2010-03-05
108
This bug affects 24 people
Affects Status Importance Assigned to Milestone
Baltix
Undecided
Unassigned
gdm (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gdm

the gdm theme did not change after the updates which were supposed to push the lucid arwork. the background is still brown and the theme defaults to Raleigh (as I removed Human I guess).
sudo -u gdm gconftool-2 -R /desktop/gnome/interface
still shows
 gtk-theme = HumanLogin

ProblemType: Bug
Architecture: i386
Date: Fri Mar 5 14:58:00 2010
DistroRelease: Ubuntu 10.04
Package: gdm 2.29.6-0ubuntu7
ProcEnviron:
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-15.22-generic
SourcePackage: gdm
Uname: Linux 2.6.32-15-generic i686

Pavel Rojtberg (rojtberg) wrote :
Chris Johnston (cjohnston) wrote :

Mine were both changed without any interaction by me after a few updates.. Can you check for new updates again and see if there is anything new?

Changed in gdm (Ubuntu):
status: New → Incomplete
Pavel Rojtberg (rojtberg) wrote :

updates make no difference. on my desktop PC the transition worked also flawlessly and that should have the same level of updates. I guess there is something funny going on with my laptop configuration...

Pavel Rojtberg (rojtberg) wrote :

rm -rf /var/lib/gdm helped. Not sure whether this is a correct fix...

Sebastien Bacher (seb128) wrote :

did you ever manually changed the theme before?

Changed in gdm (Ubuntu):
importance: Undecided → Low
Pavel Rojtberg (rojtberg) wrote :

I think I manually set the theme to human before it was officially applied in the karmic cycle..

Pavel Rojtberg: I'm having the exact same problem and I think I manually set the Karmic theme in the Beta before it was added officially.

Sebastien Bacher (seb128) wrote :

not a bug then the user changes are not overwritten on upgrade only the default change

Changed in gdm (Ubuntu):
status: Incomplete → Invalid
Stephan Peijnik (speijnik) wrote :

I am having the same problem. The new theme was not applied, and I believe I also changed the theme manually. As gdm-setup does not allow changing the theme anymore, what is the "correct" way of solving this issue, apart from deleting /var/lib/gdm?

Stephan Peijnik (speijnik) wrote :

After a short test deleting /var/lib/gdm does nothing but cause problems. However, getting rid of /var/lib/gdm/.gconf seems to solve the problem for me.

Eduard Grebe (eduardgrebe) wrote :

I have the same problem (still the brown Karmic GDM theme). No customisations were made. I am therefore changing status of this bug.

Changed in gdm (Ubuntu):
status: Invalid → New
Sebastien Bacher (seb128) wrote :

letting this bug as it is, the gdm package doesn't install a .gconf config and it's not a gdm package issue but playing changing the bug status back is of not use there

Jamie Strandboge (jdstrand) wrote :

I too can confirm this, but I did not change the gdm theme in karmic. I did make gconf adjustments however (to disable sound).

Steve Beattie (sbeattie) wrote :

I also did not change the gdm theme in karmic. After my initial upgrade from karmic -> lucid on 2010-03-05, gdm had switched over to the new theme. At some point shortly thereafter, a dist-upgrade reverted that change and I was left with the karmic gdm theme.

Claudio Viano (claudio-viano) wrote :

I haven't toched gdm ever in my life and after dist-upgrade I still had the karmic gdm theme. After some more days of updates I was left with the karmic wallpaper and the greater with no theme, just basic gtk. I removed /var/lib/gdm then marked gdm for reinstall in synaptic and the problem is solved.

Colin (dentarthurdent) wrote :

thanks Claudio, that worked for me!

if others have this issue, i ran the command

sudo rm -rf /var/lib/gdm

then reinstalled gdm via synaptic

Nick Moffitt (nick-moffitt) wrote :

Removing /var/lib/gdm/.gconf worked great for me

Nick Moffitt (nick-moffitt) wrote :

I and a few of my co-workers encountered this despite never having touched the gdm configuration before.

Jonathan Davies (jpds) on 2010-05-18
Changed in gdm (Ubuntu):
status: New → Confirmed
k3nt-1 (dugauthier) wrote :

Hello,

Indeed, the advice of Claudio did work for me too:
sudo rm -rf /var/lib/gdm && sudo aptitude reinstall gdm

Just reinstalling (without suppression of /var/lib/gdm) did not work.
/var/lib/gdm was empty on my computer before I deleted it and it still empty after reinstallation.

I did not change the default gdm config in Karmic and this did not prevented me from getting this bug.
I run on AMD 64 bits and did not get this problem on my other laptop (intel 32 bits).

If more info is required, just let me know.

Reed Lipman (rmlipman) wrote :

I didn't even realize my login screen was wrong until today. k3nt's advice (sudo rm -rf /var/lib/gdm && sudo aptitude reinstall gdm) worked for me.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers