Must log in twice to gdm in Lucid

Bug #528830 reported by Rocko on 2010-02-27
86
This bug affects 19 people
Affects Status Importance Assigned to Milestone
gdm (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gdm

On a new install of Lucid alpha 3, every time I reboot I have to log in twice. The first login accepts my user and password, but then freezes the screen for a second or so (I can't move the mouse), then I get some screen corruption, after which the gdm greeter appears again. The second login attempt is always successful.

Other info:

* I'm using the 2.6.33 kernel but exactly the same thing happens with the stock 2.6.32 Lucid kernel.
* I've got the nvidia-current drivers installed.
* I've mounted my home folder from my Karmic installation.

Info in /var/log/Xorg.0.log.old that might be relevant:

Backtrace:
0: /usr/bin/X (xorg_backtrace+0x28) [0x4a2528]
1: /usr/bin/X (0x400000+0x6522d) [0x46522d]
2: /lib/libpthread.so.0 (0x7f575f913000+0xf780) [0x7f575f922780]
3: /lib/libc.so.6 (__select+0x13) [0x7f575e6cdbe3]
4: /usr/bin/X (WaitForSomething+0x1ba) [0x45f5fa]
5: /usr/bin/X (0x400000+0x308d2) [0x4308d2]
6: /usr/bin/X (0x400000+0x2614a) [0x42614a]
7: /lib/libc.so.6 (__libc_start_main+0xfd) [0x7f575e60fc4d]
8: /usr/bin/X (0x400000+0x25cf9) [0x425cf9]

Caught signal 3 (Quit). Server aborting

ProblemType: Bug
Architecture: amd64
CheckboxSubmission: 1bd8e90541d49b96c13cbfcc9baf103b
CheckboxSystem: d00f84de8a555815fa1c4660280da308
Date: Sat Feb 27 11:12:25 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20100224.1)
NonfreeKernelModules: nvidia
Package: gdm 2.29.6-0ubuntu3
ProcEnviron:
 PATH=(custom, user)
 LANG=en_AU.utf8
 SHELL=/bin/bash
SourcePackage: gdm
Uname: Linux 2.6.33-generic x86_64

Rocko (rockorequin) wrote :
Rocko (rockorequin) wrote :
Rocko (rockorequin) wrote :
Rocko (rockorequin) wrote :
Manav Gautama (manav) wrote :

This same entering the password twice bug also shows up in ubuntu software center when authenticating software installations.

VladimirCZ (vlabla) wrote :

The same double login procedure at my PC with 64-bit, alpha 3 of 10.04 Ubuntu.

Rocko (rockorequin) wrote :

Technically, it's not a problem with having to login twice: I just found that if you enter an incorrect password on the first attempt, gdm still crashes and restarts. The second time though it starts up OK.

@Manav: I don't have to enter my password twice when authenticating software installation, only when I'm first starting up gdm. Perhaps that is a different bug.

Rocko (rockorequin) wrote :

I just did a test by removing /etc/X11/xorg.conf so that the system boots up using the nouveau driver: gdm still crashes after the first login attempt.

However, lsmod shows that the nvidia module has been loaded, which was not the case in earlier versions of Ubuntu when xorg didn't specify the nvidia module. So perhaps this bug is linked to a faulty nvidia-current install.

David Coles (dcoles) on 2010-03-01
Changed in gdm (Ubuntu):
status: New → Confirmed
electhor (electhor) wrote :

I too have to login twice to lucid alpha 3 before it goes to desktop. As far as I can remember, it only happened after installing the nvidia 190 drivers.

gibbylinks (gibbylinks) wrote :

I have same double login, but I'm running lucid alpha 3 on Dell Inspiron 1501 laptop with ATI graphics card. Also on 2.33 kernel.

gibbylinks (gibbylinks) wrote :

Sorry should read 2.6.33

Peter M. Clausen (pclausen) wrote :

I have the same problem on a dell laptop Latitude D505 and Ubuntu Lucid 10.04 32-bit
$ uname -a
 Linux clausen-laptop 2.6.32-16-generic #25-Ubuntu SMP Tue Mar 9 16:33:52 UTC 2010 i686 GNU/Linux

I am not certain, but I think that kernel 2.6.32-15 did NOT have this problem.

For me it only happens on login. By software installation and so on I only enter passphrase once.

Bernhard (b.a.koenig) wrote :

Peter, did you try to upgrade plymouth and restart? Some recent upgrades have fixed this for me.

chavash (anatoly-mironov) wrote :

I must login twice after locking screen (due inactivity). I upgraded from Hardy to Lucid 32 bit. This behavior appeared not directly after upgrading. At startup and software installation I only have to enter passphrase once.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers