New gdm does not have the FailsafeXServer config option

Bug #474806 reported by Bryce Harrington on 2009-11-04
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gdm (Ubuntu)
High
Steve Langasek
Karmic
High
Steve Langasek
Lucid
High
Steve Langasek
xorg (Ubuntu)
High
Steve Langasek
Karmic
High
Steve Langasek
Lucid
High
Steve Langasek

Bug Description

Binary package hint: gdm

gdm 2.20 had options in /etc/gdm/gdm.conf (in particular FailsafeXServer) for specifying an action to take when X is failing to start up. We attached a failsafe session (aka bulletproof-x) to be invoked by gdm in these situations, which users could use to diagnose and work around issues.

These options were implemented in the 'deal_with_x_crashes()' function in gdm.c. Near as I can tell, this gdm feature was not included in the new gdm rewrite, so we are seeing a regression here. The problem is that whereas in the past the user would be dumped into a debugging session, now gdm is simply trying multiple times, failing each time, and then exiting (which then leads to the quite severe bug 441638).

Anyway, the end result is that we no longer have a debugging failsafe mode available for users, they're just left with a non-functioning system. Please either restore the missing functionality, or provide an analogous mechanism to which we can attach a debugging session mode.

Steve Langasek (vorlon) wrote :

As discussed, this can be handled via an upstart job configured to start whenever gdm dies. That upstart job should live in x11-common with the rest of the bulletproof-X handling; so we don't have to patch the gdm source to bring this back together, we just need to fix bug #441638.

Changed in gdm (Ubuntu Karmic):
status: New → Won't Fix
Changed in gdm (Ubuntu Lucid):
status: New → Won't Fix
Changed in xorg (Ubuntu Karmic):
status: New → In Progress
assignee: nobody → Steve Langasek (vorlon)
importance: Undecided → High
Changed in xorg (Ubuntu Lucid):
importance: Undecided → High
status: New → In Progress
Changed in xorg (Ubuntu Karmic):
milestone: none → karmic-updates
Changed in xorg (Ubuntu Lucid):
assignee: nobody → Steve Langasek (vorlon)
milestone: none → lucid-alpha-1
Steve Langasek (vorlon) wrote :

Hmm - no, correction, it appears there's a change that needs to be made to the gdm upstart job to support this (to support passing in the XORGCONFIG env variable), in addition to the xorg changes.

Changed in gdm (Ubuntu Karmic):
assignee: nobody → Steve Langasek (vorlon)
importance: Undecided → High
milestone: none → karmic-updates
status: Won't Fix → In Progress
Changed in gdm (Ubuntu Lucid):
status: Won't Fix → In Progress
assignee: nobody → Steve Langasek (vorlon)
milestone: none → lucid-alpha-1
importance: Undecided → High
Bryce Harrington (bryce) wrote :

Thanks, committed to git; will upload to Lucid with the next xorg upload there.

Changed in xorg (Ubuntu Lucid):
status: In Progress → Fix Committed
Steve Langasek (vorlon) wrote :

Unless you're expecting an xorg upload soon, we'll probably be able to copy these packages from karmic-proposed to lucid once built.

That should be fine, I don't anticipate an xorg upload to lucid for a bit.

On Thu, Nov 05, 2009 at 03:26:39AM -0000, Steve Langasek wrote:
> Unless you're expecting an xorg upload soon, we'll probably be able to
> copy these packages from karmic-proposed to lucid once built.
>
> --
> New gdm does not have the FailsafeXServer config option
> https://bugs.launchpad.net/bugs/474806
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in ???gdm??? package in Ubuntu: New
> Status in ???xorg??? package in Ubuntu: Fix Committed
> Status in gdm in Ubuntu Lucid: In Progress
> Status in xorg in Ubuntu Lucid: Fix Committed
> Status in gdm in Ubuntu Karmic: In Progress
> Status in xorg in Ubuntu Karmic: In Progress
>
> Bug description:
> Binary package hint: gdm
>
> gdm 2.20 had options in /etc/gdm/gdm.conf (in particular FailsafeXServer) for specifying an action to take when X is failing to start up. We attached a failsafe session (aka bulletproof-x) to be invoked by gdm in these situations, which users could use to diagnose and work around issues.
>
> These options were implemented in the 'deal_with_x_crashes()' function in gdm.c. Near as I can tell, this gdm feature was not included in the new gdm rewrite, so we are seeing a regression here. The problem is that whereas in the past the user would be dumped into a debugging session, now gdm is simply trying multiple times, failing each time, and then exiting (which then leads to the quite severe bug 441638).
>
> Anyway, the end result is that we no longer have a debugging failsafe mode available for users, they're just left with a non-functioning system. Please either restore the missing functionality, or provide an analogous mechanism to which we can attach a debugging session mode.

Colin Watson (cjwatson) wrote :

Accepted xorg into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in xorg (Ubuntu Karmic):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in gdm (Ubuntu Karmic):
status: In Progress → Fix Committed
Colin Watson (cjwatson) wrote :

Accepted gdm into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Martin Pitt (pitti) wrote :

copied xorg karmic-proposed to lucid.

Changed in xorg (Ubuntu Lucid):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gdm - 2.28.1-0ubuntu2

---------------
gdm (2.28.1-0ubuntu2) karmic-proposed; urgency=low

  * Don't respawn gdm on failure; this lets us capture X failures instead and
    trigger the bulletproof X handler here. LP: #441638.
  * re-export any XORGCONFIG value passed to the upstart job, needed to
    complete integration with bulletproof X. LP: #474806.

 -- Steve Langasek <email address hidden> Wed, 04 Nov 2009 18:15:37 -0800

Changed in gdm (Ubuntu Karmic):
status: Fix Committed → Fix Released
Steve Langasek (vorlon) wrote :

copied gdm to lucid also.

Changed in gdm (Ubuntu Karmic):
status: Fix Released → Fix Committed
Changed in gdm (Ubuntu Lucid):
status: In Progress → Fix Released
Sebastien Bacher (seb128) wrote :

bug #476874 has comments from an user having issues with the update

Martin Pitt (pitti) wrote :

This update works fine for me. I think we can at least push gdm to -updates. Not sure about the xorg portion, because of bug 476874.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gdm - 2.28.1-0ubuntu2

---------------
gdm (2.28.1-0ubuntu2) karmic-proposed; urgency=low

  * Don't respawn gdm on failure; this lets us capture X failures instead and
    trigger the bulletproof X handler here. LP: #441638.
  * re-export any XORGCONFIG value passed to the upstart job, needed to
    complete integration with bulletproof X. LP: #474806.

 -- Steve Langasek <email address hidden> Wed, 04 Nov 2009 18:15:37 -0800

Changed in gdm (Ubuntu Karmic):
status: Fix Committed → Fix Released
Steve Langasek (vorlon) wrote :

This bug was fixed in the package xorg - 1:7.4+3ubuntu10

xorg (1:7.4+3ubuntu10) karmic-proposed; urgency=low

  * local/Failsafe/failsafeXServer: Since dexconf no longer produces
    an xorg.conf, it will neither generate a failsafe xorg.conf, so now
    we just generate one directly. Otherwise X won't start a failsafe
    session properly.
    (LP: #477149)
 -- Bryce Harrington <email address hidden> Mon, 09 Nov 2009 15:39:57 -0800

xorg (1:7.4+3ubuntu9) karmic-proposed; urgency=low

  * Restore 60x11-common_localhost. I dropped this before because the
    file was not in git so assumed it was stray. On further review I
    see this was intentionally added, just not to git, and was not stray.
    (LP: #340807)
  * control: Add Vcs-git tags
 -- Bryce Harrington <email address hidden> Wed, 04 Nov 2009 18:54:26 -0800

xorg (1:7.4+3ubuntu8) karmic-proposed; urgency=low

  * debian/local/Failsafe/failsafe{XServer,Xinit},
    debian/x11-common.failsafe-x.upstart: convert Bulletproof-X support over
    to upstart, for compatibility with gdm in karmic. LP: #474806.
  * debian/rules: install the new upstart job with dh_installinit.
  * debian/control: bump the debhelper versioned build-dependency for the
    same
 -- Steve Langasek <email address hidden> Wed, 04 Nov 2009 18:00:49 -0800

Changed in xorg (Ubuntu Karmic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers