GDM without user list requires that you click Log In.

Bug #463029 reported by Joel Ebel on 2009-10-29
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
gdm
Fix Released
Medium
gdm (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gdm

If the GDM user list (face browser) is disabled, then the user is only presented with a "Log In" button, rather than a username and password entry field. Disabling the user list is a requirement in an enterprise environment, and lacking the username and password entry field is a significant, and negative, change in the login experience. In face, I find the Karmic login experience document defines what the login screen should look like, and this does not match:

https://wiki.ubuntu.com/DesktopTeam/Specs/Karmic/LoginExperience#Login screen with username/password manual entry

The mockup on that page would be perfectly acceptable.

This requirement to click Log In combined with the non-disabled search box described in bug 463026 leads to a very bad user experience where the user may think they are typing in their username and password, but rather, they are searching a non-existent user list and their password gets displayed on screen in clear text.

This appears that it may be related to gnome bug https://bugzilla.gnome.org/show_bug.cgi?id=591084

Sebastien Bacher (seb128) wrote :

Thank you for your bug report. The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Changed in gdm (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Triaged
Joel Ebel (jbebel) wrote :

This bug is already filed upstream, and has already been linked to this bug. I just wanted a launchpad bug open to track the upstream bug.

Joel Ebel (jbebel) on 2010-02-26
tags: added: glucid
Changed in gdm:
status: Unknown → Confirmed
Changed in gdm:
status: Confirmed → Invalid
Sebastien Bacher (seb128) wrote :

https://bugzilla.gnome.org/show_bug.cgi?id=591082 suggests the issue has been fixed with the current lucid candidate update, could somebody confirms it's working§?

Joel Ebel (jbebel) wrote :

The other related launchpad bug I filed is gone in Lucid now, however, this bug, requiring that you click "Log In" before typing your username is still present. With the other bug being fixed, this is no longer as critical, but it's still a poor experience and in conflict with the login experience doc I linked in the original report.

Changed in gdm:
status: Invalid → Fix Released
Changed in gdm:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.