Does not switch to guest session if session already open

Bug #450965 reported by Robert Ancell on 2009-10-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gdm (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: gdm

To reproduce:
1. Start system
2. Log into GDM as an existing user
3. Start guest session
4. Switch back to original session
5. Start guest session

Expected:
A new guest session is started or switch to already open guest session

What occurs:
The screenlock comes on

Robert Ancell (robert-ancell) wrote :

Patch fixes this by having GDM call ConsoleKit to switch to the guest session if it is already open. Two oddities:
1. If I return TRUE from StartGuestSession() if without starting a new session gdm-session-worker terminates and a new session for the current user is opened. So the patch does the switch but returns FALSE so it looks like the D-Bus call failed.
2. I don't know how to get the display id for the guest session so this information is not available to be returned from StartGuestSession() (but this does not matter due to point 1).

Changed in gdm (Ubuntu):
importance: Undecided → Low
importance: Low → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gdm - 2.28.0-0ubuntu18

---------------
gdm (2.28.0-0ubuntu18) karmic; urgency=low

  * debian/patches/14_guest_session.patch:
    - Switch to existing guest session if already open (LP: #450965)
  * debian/patches/24_system_uid.patch:
  * debian/patches/16_gdmserver_user_manager.patch:
    - Fix more cases of users with UID < 1000

 -- Robert Ancell <email address hidden> Thu, 15 Oct 2009 01:07:18 +0200

Changed in gdm (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers