"Suspend", "Hibernate", "Restart" and "Shut Down" options in login screen shows untranslated, albeit they're translated

Bug #450707 reported by Ricardo Pérez López on 2009-10-13
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Undecided
Unassigned
gdm (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gdm

The GDM menu which opens clicking on the bottom-right icon in the login screen shows untranslated options in my Spanish desktop, albeit they're translated and the translations are into the gdm.mo file.

The strings which shows untranslated are "Suspend", "Hibernate", "Restart" and "Shut Down". All of these strings are translated in Karmic:

https://translations.launchpad.net/ubuntu/karmic/+source/gdm/+pots/gdm/es/133/+translate
https://translations.launchpad.net/ubuntu/karmic/+source/gdm/+pots/gdm/es/129/+translate
https://translations.launchpad.net/ubuntu/karmic/+source/gdm/+pots/gdm/es/131/+translate
https://translations.launchpad.net/ubuntu/karmic/+source/gdm/+pots/gdm/es/132/+translate

And the translations are into the /usr/share/locale-langpack/es/LC_MESSAGES/gdm.mo file:

$ strings -eS /usr/share/locale-langpack/es/LC_MESSAGES/gdm.mo | grep "Suspender\|Hibernar\|Reiniciar\|Apagar"
Hibernar
Reiniciar
Apagar
Suspender

So the problem seems to be in the gdm application itself.

They're all very visible strings which degrades the user experience when they shows untranslated.

Changed in gdm (Ubuntu):
status: New → Confirmed
importance: Undecided → Low
assignee: nobody → Robert Ancell (robert-ancell)
Robert Ancell (robert-ancell) wrote :

Already translated - no action required for translations

Changed in gdm (Ubuntu):
assignee: Robert Ancell (robert-ancell) → nobody
Changed in ubuntu-translations:
status: New → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gdm - 2.28.0-0ubuntu17

---------------
gdm (2.28.0-0ubuntu17) karmic; urgency=low

  [ Robert Ancell ]
  * debian/patches/22_shutdown_menu.patch:
    - Mark power menu options as translatable (LP: #450707)

  [ Scott James Remnant ]
  * debian/gdm.upstart:
    - Wait for tty7 to be ready, and either a framebuffer or the end
      of coldplugging.

 -- Scott James Remnant <email address hidden> Wed, 14 Oct 2009 05:08:47 +0100

Changed in gdm (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers