No GUI option to change login theme

Bug #449198 reported by Jorge on 2009-10-12
252
This bug affects 51 people
Affects Status Importance Assigned to Milestone
gdm
Won't Fix
Medium
Baltix
Undecided
Unassigned
gdm (Ubuntu)
Medium
Unassigned
Declined for Lucid by Rick Spencer

Bug Description

Ubuntu 9.10 (Karmic Koala) doesn't allow to change the login screen theme.
The System / Administration / Login Screen tool doesn't allow to change the GDM's background (wallpaper) or theme.
This can be seen as a regression from previous Ubuntu versions.
Currently users have to run the following command to change the GDM 2.28 theme:
gksudo -u gdm dbus-launch gnome-appearance-properties
More information: http://wiki.archlinux.org/index.php/Gnome_2.28_Changes#Configuring_gdm_2.28

This is not user friendly at all.
See http://ubuntuforums.org/showthread.php?t=1292533&page=2

Jorge (jorgealdunatel) wrote :
A. Walton (awalton) on 2009-10-12
affects: nautilus (Ubuntu) → gdm (Ubuntu)
Sebastien Bacher (seb128) wrote :

Thank you for your bug report

Changed in gdm (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Wishlist
status: New → Confirmed
summary: - not able to change GDM screen on Karmic
+ gdmsetup doesn't allow to change themes

I've updated the bug description to be more meaningful and better searchable.

description: updated
tags: added: karmic
removed: i386
tags: added: usability
Przemek K. (azrael) on 2009-11-02
summary: - gdmsetup doesn't allow to change themes
+ gdmsetup doesn't allow to change login screen theme in 9.10 (karmic)

I have 3 suggestions for implementing this:

1) In gnome-appearance-properties:
   [x] Aply this theme to the login screen (displayed/enabled only if the user has admin rights)

2) In gdmsetup:
   [x] Apply the following theme to the login screen: [Current | v ]
        [x] Use the following custom background: [/path/to/image [ Choose... ]]

3) In gdmsetup or as a separate entry in System > Administration:
  [Change look of login screen] --> that button would run $gksu -u gdm dbus-launch gnome-appearance-properties, and add something like a notice or window title to differentiate the dialog from System > Preferences > Appearance)

summary: - gdmsetup doesn't allow to change login screen theme in 9.10 (karmic)
+ No GUI option to change login theme
Changed in gdm (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → Robert Ancell (robert-ancell)
Przemek K. (azrael) wrote :

Shouldn't this bug be forwarded to Gnome devs?
https://wiki.ubuntu.com/Bugs/Upstream/GNOME

description: updated
Przemek K. (azrael) wrote :
tags: added: regression-release
Sebastien Bacher (seb128) wrote :

you should not that the gdmsetup is not upstream but an ubuntu change in karmic

2009/11/10 Sebastien Bacher <email address hidden>:
> you should not that the gdmsetup is not upstream but an ubuntu change in
> karmic

So currently upstream has no tool to change gdm settings at all?

--
## Przemysław Kulczycki >><< Azrael Nightwalker ##
# jabber: azrael[na]jabster.pl | tlen: azrael29a #
### www: http://reksio.ftj.agh.edu.pl/~azrael/ ###

Sebastien Bacher (seb128) wrote :

> So currently upstream has no tool to change gdm settings at all?

No it doesn't see https://bugzilla.gnome.org/show_bug.cgi?id=587750

Przemek K. (azrael) wrote :

So I guess that the bug I filed upstream would be a duplicate or dependant on the one that you have mentioned.

Icewalker (jbruce-cfi) wrote :

The lack of changing GDM is definitely a step back. I'm more than little pissed about this! I don't care for the new screen, or the usplash. I have my own and as far as I can tell, I'm locked out. This is deplorable.

Dave Stroud (bigdavesr) wrote :

I have all kinds of themes to use on gdm boot up, but can only use the one supplied by ubuntu. I have been using ubuntu since 6.06 came out. I have used everyone since. This is the first time I have been unhappy. Please give us our control back. I just want to fix ubuntu up the way I want it to be. Thats what ubuntu is supposed to be about. Thanks

what about a work around for the 24 hour clock problem ???

Dave Vree (hdave) wrote :

Upstream has been sitting on a patch for 2 months. I have at least 5 themes I use for different types of machines (development, office, personal, etc.). Its incredible to me what a step backwards this is.

FichdlMaa (fichdlmaa) wrote :

There are already a lot o suggestions how to deactive the user list in gdm2 database,
e.g. http://wiki.ubuntuusers.de/Baustelle/GDM2_-_Tweaks ,

but on our "Family PC" we need it TOGETHER with it's configuration feature:
Only "normal" users should be displayed, no support and system users!

But :-( Karmic :-( ignores the "old"

/etc/gdm/custom.conf:
...
[greeter]
GraphicalTheme=happygnome-list
GraphicalThemes=happygnome-list
GraphicalThemeRand=true
IncludeAll=false <-- !!!
Include=dad,mum,kids <-- !!!
Exclude=nobody,install,root,backup <-- !!!

[chooser]
...

I couldn't find any corresponding entry within gdm2 database (gconf-editor; gconftool-2 rev. 2.28).

:-((

Daniel LaGesse (dlagesse1992) wrote :

So is it correct that there is no workaround for this? Is there any way to use the old login theme selector?

MichaelSwengel (truesongtech) wrote :

I think to do that we would have to go back to an earlier version of GNOME, Daniel. :/

I just found out that all the 'sudo -u gdm gconf-editor && etc.' hacks were just wiped out by the latest GDM update (because the %gconf... files in /var/lib/gdm got overwritten).

We need to find a way to allow customization of GDM in a way that resists update, via a sensible '/etc/gdm/custom.conf' file and without reverting to horrible hacks like the "CTRL-ALT-F1 + sudo + ...".

While I can live with lack of wallpaper and time format customization (thought I'd rather not), I must ensure a few other parameters are enforced, like getting rid of the users list.

Could we imagine some automated script that would get executed when X/GDM launches (e.g. via '.xsession', IIRC), that would push some parameters in the GDM configuration from a /etc/gdm/custom.conf file via 'gconftool-2' ?

Richard Huddleston (rhuddusa) wrote :

blah ... just lost my settings like Cédric Dufour

Changed in gdm (Ubuntu):
status: Confirmed → Triaged
Changed in gdm (Ubuntu):
assignee: Robert Ancell (robert-ancell) → nobody
Xan (dxpublica) wrote :

Xubuntu and lubuntu have the same bug, I think.

Changed in gdm:
importance: Unknown → Medium
status: Unknown → New
Bryce Harrington (bryce) on 2011-01-12
tags: added: lucid natty
Bryce Harrington (bryce) wrote :

This is the latest version of a patch developed on the upstream bug report.
The upstream bug is closed as WONTFIX, so perhaps the patch won't get taken upstream.
We should consider it for Ubuntu though.

Bryce Harrington (bryce) wrote :

This was set to Wishlist importance, however it's also tagged as 'regression-release' which doesn't make sense... From what I can tell this *was* a provided feature which was lost in a gdm update at one point, so I don't think it's correct to be listed as wishlist.

Changed in gdm (Ubuntu):
importance: Wishlist → Medium
Bryce Harrington (bryce) wrote :

I haven't reviewed the patch in detail, but did take a cursory look over it. It applies to gdm 0.30.0, while natty is on 0.30.5 so it should be checked to make sure it still applies. It looks pretty self-contained so may still apply reasonably cleanly. I think it's appropriate for sponsors to review, so have gone ahead and subscribed them.

Bryce Harrington (bryce) wrote :

There's also a Brainstorm entry for this issue - http://brainstorm.ubuntu.com/idea/22389/

Sebastien Bacher (seb128) wrote :

unsubscribing the sponsors, the patch there is a rewrite of the gdmsetup utility, it would need cleaning to be integrated in ubuntu but is not ready to be sponsored as it

tags: added: patch
FichdlMaa (fichdlmaa) wrote :

My own solution (workaround) was to changed the UIDs for "hidden" users to < 1000.
That works fine, but:

Since that, I have problems with modification of files stored on my NAS (no matter whether via SMB/CIFS or NFS for such users :-(

Bye

FichdlMaa

hamish (hamish-b) wrote :

fyi, this works on ubuntu 12.04 to change the gdm login screen background image:

http://smashingweb.ge6.org/change-the-background-of-gnome-3-gdm-login-screen/

quoted:

"""
# su - gdm -s /bin/bash
$ dbus-launch

This command will print DBUS_SESSION_BUS_ADDRESS and DBUS_SESSION_BUS_PID. We need to export them

$ export DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-Jb433gMQHS,guid=fc14d4bf3d000e38276a5a2200000d38
$ export DBUS_SESSION_BUS_PID=4283

Check to see if dconf-service is running and if not, start it like this

$ /usr/lib/dconf/dconf-service &

Wallpaper

$ GSETTINGS_BACKEND=dconf gsettings get org.gnome.desktop.background picture-uri
$ GSETTINGS_BACKEND=dconf gsettings set org.gnome.desktop.background picture-uri "file:///usr/share/backgrounds/gnome/SundownDunes.jpg"

You will need to point to a file where the gdm user has permission to read, not in your home directory.
"""

then as root restart the gdm service.

for precise I had to "chown gdm.gdm /var/lib/gdm/.config -R" first, as root owned that not the gdm user, so the gdm user couldn't write the file.

The resulting /var/lib/gdm/.config/dconf/user file is binary so can't just edit the config file with a text editor as per 4 decades of UNIX /etc conventions. (@!#@$!^%~)

have fun,
Hamish

dino99 (9d9) on 2013-05-04
tags: added: precise
removed: karmic natty
shankao (shankao) wrote :

Shouldn't this bug be targeted to lightdm since it's the display manager used in Ubuntu now?

Changed in gdm:
status: New → Won't Fix
Changed in baltix:
status: New → Invalid
Changed in gdm (Ubuntu):
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.