gconftool calls trigger pam asked for password as it was configured with pam_mount

Bug #441167 reported by Toby Collett on 2009-10-03
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gdm (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: gdm

My system uses pam_mount to unencrypt users home drives with their login password. The last lot of updates (2009-10-02) gdm no longer updates properly unless I disable pam mount in the pam configs before I run apt-get/dpkg.

ProblemType: Package
Architecture: amd64
Date: Sat Oct 3 09:06:28 2009
DistroRelease: Ubuntu 9.10
ErrorMessage: subprocess installed post-installation script killed by signal (Interrupt)
Package: gdm 2.28.0-0ubuntu11
ProcVersionSignature: Ubuntu 2.6.31-11.36-generic
SourcePackage: gdm
Title: package gdm 2.28.0-0ubuntu11 failed to install/upgrade: subprocess installed post-installation script killed by signal (Interrupt)
Uname: Linux 2.6.31-11-generic x86_64

Related branches

Toby Collett (thjc) wrote :
summary: - package gdm 2.28.0-0ubuntu11 failed to install/upgrade: pam asked for
- password as it was configured with pam_mount
+ gconftool calls trigger pam asked for password as it was configured with
+ pam_mount
Changed in gdm (Ubuntu):
status: New → Confirmed
importance: Undecided → High
milestone: none → ubuntu-9.10
Sebastien Bacher (seb128) wrote :

the issue will be fixed with the changes on bug #438561

Changed in gdm (Ubuntu):
assignee: nobody → Chris Coulson (chrisccoulson)
assignee: Chris Coulson (chrisccoulson) → nobody
assignee: nobody → Chris Coulson (chrisccoulson)
assignee: Chris Coulson (chrisccoulson) → nobody
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gdm - 2.28.0-0ubuntu19

---------------
gdm (2.28.0-0ubuntu19) karmic; urgency=low

  * debian/%gconf-tree.xml, debian/gdm.postinst, debian/rules:
    - don't use gconftool to register the default gconf keys but rather
      install a xml files with the values, that will avoid different issues
      due to the su call or the gconf server not being running
      (lp: #441028, #441167)
    - set the gnome-power-manager icon key to never since that's not useful
      on the login screen and the design team recommended to not have it there
  * debian/gdm.postinst:
    - workaround chown breaking due to the .gvfs fuse directory (lp: #438561)
  * debian/patches/25_update_gconf_directories.patch:
    - define a new directory which is used for the default gconf values

 -- Sebastien Bacher <email address hidden> Thu, 15 Oct 2009 12:34:11 +0200

Changed in gdm (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers