gdm still appears briefly even though autologin is enabled

Bug #435801 reported by Pete Goodall on 2009-09-24
64
This bug affects 17 people
Affects Status Importance Assigned to Milestone
gdm
Fix Released
Medium
gdm (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gdm

I enabled autologin, and when I reboot I see:

 * Blinking cursor in the upper left corner
 * then Xsplash
 * very briefly see the default Ubuntu background and the "login ready" sound plays
 * then I'm returned to Xsplash

This translates to a very jittery boot experience, and means boot takes a long time (about 40 seconds).

ProblemType: Bug
Architecture: i386
Date: Thu Sep 24 11:30:36 2009
DistroRelease: Ubuntu 9.10
Package: gdm 2.28.0-0ubuntu4
ProcEnviron:
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-10.35-generic
SourcePackage: gdm
Tags: ubuntu-unr
Uname: Linux 2.6.31-10-generic i686

Pete Goodall (pgoodall) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, did the issue started recently? I'm wondering if that's a side effect of the change to not use autologon users again when they are logging out

Changed in gdm (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
Pete Goodall (pgoodall) wrote :

Yes, this came up recently. At least I think so as GDM was starting by itself for a while. ;-) Still happens as of today (with updates) and it is pretty ugly. :-/

David Barth (dbarth) wrote :

I can also confirm the issue and it started when the autologin bug fix was integrated into gdm.

Assigning to Robert at Rick's request. To be worked on as a post-beta bug though.

Changed in gdm (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → Robert Ancell (robert-ancell)
Sebastien Bacher (seb128) wrote :

Robert, the change which leads to the issue is

" * debian/patches/17_use_timed_login_after_autologin.patch:
    - revert upstream change to not use timed login after autologin session
      (lp: #396489)"

it would be nice to have autologin working as it did before but having the second login to be a timeouted one

Robert Ancell (robert-ancell) wrote :

Please ignore this main sponsors - you have been accidentally subscribed

Changed in gdm (Ubuntu):
assignee: Robert Ancell (robert-ancell) → nobody
assignee: nobody → Robert Ancell (robert-ancell)
Changed in gdm (Ubuntu):
status: New → Confirmed
importance: Low → Medium
Robert Ancell (robert-ancell) wrote :

Bug found and fixed. It appears to be fixed upstream as that code was changed for other reasons.

Changed in gdm (Ubuntu):
assignee: Robert Ancell (robert-ancell) → nobody
Robert Ancell (robert-ancell) wrote :

Note it wasn't due to 17_use_timed_login_after_autologin.patch. It was easier to see by apt-get removing xsplash.

Changed in gdm (Ubuntu):
status: Confirmed → Fix Committed
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gdm - 2.28.0-0ubuntu9

---------------
gdm (2.28.0-0ubuntu9) karmic; urgency=low

  * debian/gdm.postinst:
    - use the correct key to set the gtk theme

  [ Robert Ancell ]
  * debian/patches/22_shutdown_menu.patch:
    - Fix spacing on shutdown menu (LP: #437691)
  * debian/patches/*.patch:
    - Update patch headers
  * debian/patches/19_no_greeter_for_autologin.patch:
    - Fix bug that caused the GDM greeter to be displayed briefly when
      automatically logging in (LP: #435801)

 -- Sebastien Bacher <email address hidden> Wed, 30 Sep 2009 15:21:09 +0200

Changed in gdm (Ubuntu):
status: Fix Committed → Fix Released
tags: added: iso-testing
Changed in gdm:
importance: Unknown → Medium
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.