GDM fails to authenticate pre-existent users.

Bug #432492 reported by ENigma885 on 2009-09-18
38
This bug affects 8 people
Affects Status Importance Assigned to Milestone
gdm (Ubuntu)
Low
Ubuntu Desktop Bugs
Declined for Karmic by Sebastien Bacher

Bug Description

Binary package hint: gdm

***Problem:-
GDM fails to authenticate users from the login menu.
__________
***Details:-
1- GDM 1st completely failed to start because of the absence of "/var/log/gdm" (Bug#405227)
2- Making the needed directory, mkdir /var/log/gdm, enabled GDM to start.
3- After the 2nd Ubuntu loading screen,the new dark brown one, 2 errors popped up:
   I- [Could not update ICEauthority file /var/lib/gdm/.ICEauthority]
   II- [This is a problem with the configuration sever.
        (usr/lib/libgconf2-4/gconf-sanity-check-2 exited with status 256)]
4- User selection menu appeared. And selecting any user gave [Unable to authenticate user]
5- Automatically, the Ubuntu loading screen appeared again and the same senario was repeated.
__________
**Notes:-
-Reconfiguring Xserver, dpkg-reconfigure xserver-xorg, and reconfiguring GDM, dpkg-reconfigure gdm, didn't change any of the previously mentioned behaviour.
_________
Bug was submitted using w3m.

ProblemType: Bug
Architecture: i386
Date: Fri Sep 18 15:13:50 2009
DistroRelease: Ubuntu 9.10
Package: gdm 2.27.90-0ubuntu7
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-10.34-generic
SourcePackage: gdm
Uname: Linux 2.6.31-10-generic i686

ENigma885 (enigma-pentagram) wrote :
description: updated
tags: added: authenticate failure gdm
removed: apport-bug i386
Sebastien Bacher (seb128) wrote :

Not confirming the issue nobody else is having it, setting to low since that seems rather a local configuration issue than a bug which will impact lot of users

Changed in gdm (Ubuntu):
importance: Undecided → Low
ENigma885 (enigma-pentagram) wrote :

Is there any additional info am i supposed to provide?
or even a way to troubleshot the issue?

ENigma885 (enigma-pentagram) wrote :

Not sure if it was a bug or not. But everything is restored to normal behaviour after GDM reinstallation.

Sebastien Bacher (seb128) wrote :

closing since that works now

Changed in gdm (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
status: New → Invalid
Sebastien Bacher (seb128) wrote :

closing since that works now

WayOutThere (kevin-b-crocker) wrote :

This just happened to me during a routine update - gdm was updated and caused a complete GDM failure "Unable to authenticate" --- I had to go into a terminal screen "C-A-F1" and rollback the update using 'aptitude' - thank goodness that worked!!!

from version 2.28.1-0ubuntu1 to 2.28.1-0ubuntu2

I feel this is a CRITICAL error that would prevent many users from using (and rescuing) their desktop

WayOutThere (kevin-b-crocker) wrote :

This problem has re-surfaced with the latest upgrade of gdm from 2.28.1-0ubuntu1 to 2.28.1-0ubuntu2 causing complete gdm failure to authenticate

Changed in gdm (Ubuntu):
status: Invalid → New
Eric (ericchaves) wrote :
Download full text (3.3 KiB)

bugs.launchpad.net/ubuntu/+source/gdm/+bug/432492

I'm facing a similar problem, and have found some other users that went with this problem too, so I agree with those defending that importance level should be raised.

I'm running Xubuntu 9.10 (x86_64) on a Dell D520 latitude. It's a fresh install made yesterday and after installing I did logon, suspend and resume normally, no problems at all. However after first logout subsequent logins fails with "authentication failure". This process happens with *every* account (I created 2 more account and they all show the same behavior). The only way to logon into the system again is bypass gdm and logon in consoloe by either pressing <ctrl>+<alt>+<f1> or to reboot in rescue mode and select "resume normal boot".

Reinstalling GDM did not fix this.

I've faced the same proble twice before that, once I was running Ubuntu, and the second time I was running Ubuntu with XFCE4. Both times it was 9.10 version.

The only unusual thing in my notebook is that battery is dead, never charges beyond 4~8%. Not sure if this could be related, however gdm logs does mention some errors related to "power managment".

:0-greeter.log says:

gnome-session[1716]: devkit-power-gobject-WARNING: Couldn't enumerate devices: The name org.freedesktop.DeviceKit.Power was not provided by any .service files
gnome-session[1716]: WARNING: Could not launch application 'metacity.desktop': Unable to start application: Failed to execute child process "metacity" (No such file or directory)
** (process:1728): DEBUG: Greeter session pid=1728 display=:0.0 xauthority=/var/run/gdm/auth-for-gdm-xFpOdR/database
gnome-session[1716]: WARNING: Could not launch application 'gnome-power-manager.desktop': Unable to start application: Failed to execute child process "gnome-power-manager" (No such file or directory)
gdm-simple-greeter[1728]: devkit-power-gobject-WARNING: Couldn't enumerate devices: The name org.freedesktop.DeviceKit.Power was not provided by any .service files
gdm-simple-greeter[1728]: devkit-power-gobject-WARNING: Error invoking GetAll() to get properties: The name org.freedesktop.DeviceKit.Power was not provided by any .service files
gdm-simple-greeter[1728]: devkit-power-gobject-WARNING: Error invoking GetAll() to get properties: The name org.freedesktop.DeviceKit.Power was not provided by any .service files
gdm-simple-greeter[1728]: devkit-power-gobject-WARNING: Couldn't enumerate devices: The name org.freedesktop.DeviceKit.Power was not provided by any .service files
gdm-simple-greeter[1728]: devkit-power-gobject-WARNING: Error invoking GetAll() to get properties: The name org.freedesktop.DeviceKit.Power was not provided by any .service files
gdm-simple-greeter[1728]: devkit-power-gobject-WARNING: Couldn't enumerate devices: The name org.freedesktop.DeviceKit.Power was not provided by any .service files
gdm-simple-greeter[1728]: devkit-power-gobject-WARNING: Error invoking GetAll() to get properties: The name org.freedesktop.DeviceKit.Power was not provided by any .service files
---[END OF LOG]---

The failures are reported in auth.log like:

Nov 13 14:17:37 hobbes gdm-session-worker[1469]: pam_unix(gdm:auth): authentication failure;...

Read more...

NoOp (glgxg) wrote :

I am also getting:
   I- [Could not update ICEauthority file /var/lib/gdm/.ICEauthority]
   II- [This is a problem with the configuration sever.
        (usr/lib/libgconf2-4/gconf-sanity-check-2 exited with status 256)]
except I am able to login for each user on the system after clicking 'OK' on the warning popups.

If I open Nautilus as root (gksu nautilus) and look at the permissions properties, on the machine with errors I show permissions for /var/lib/gdm/.ICEAuthority as:

Owner: avahi-autopd - Avahi autoip daemon
Access: Read and write
Group: fuse
Access: None
Others
Access: None
SELinux context: unknown
Last changed: unknown

$ apt-cache policy gdm
gdm:
  Installed: 2.28.1-0ubuntu2
  Candidate: 2.28.1-0ubuntu2
  Version table:
 *** 2.28.1-0ubuntu2 0
        500 http://archive.ubuntu.com karmic-updates/main Packages
        100 /var/lib/dpkg/status
     2.28.1-0ubuntu1 0
        500 http://archive.ubuntu.com karmic/main Packages

$ uname -a
2.6.31-15-generic #50-Ubuntu SMP Tue Nov 10 14:54:29 UTC 2009 i686 GNU/Linux

Note: the machine has been updated from dapper thru karmic & the hard drives changed from 40Gb to 200Gb using Gparted 'copy'.

If I look at the permissions for /var/lib/gdm/.ICEAuthority on a clean karmic install (with no errors), I see that .ICEAuthority has the same Owner and Group as the /var/lib/gdm folder:

Owner: gdm - Gnome Display Manager
Access: Read and Write
Group: gdm
Access: none
Others
Access: None

The exception of course is the Access for Group is set to 'none' on the file and 'Access files' on the folder.

NoOp (glgxg) wrote :

OK. Modifying the permissions on a similar machine with the errors fixes the problem. I'll now do the same on this machine & post back with my results.

NoOp (glgxg) wrote :

Changing permissions fixed error I
 I- [Could not update ICEauthority file /var/lib/gdm/.ICEauthority]
but still getting error II
   II- [This is a problem with the configuration sever.
        (usr/lib/libgconf2-4/gconf-sanity-check-2 exited with status 256)]

NoOp (glgxg) wrote :

Taking a hint from:
<https://bugs.launchpad.net/ubuntu/+source/gconf/+bug/269215>
[There is a problem with the configuration server. (/usr/lib/libgconf2-4/gconf-sanity-check-2 exited with status 256)]

I compared the permissions of /etc/gconf/gconf.xml.system/ on the error machine against a new karmic install. This error machine had the permissions for the folder set to 775, the new karmic install have it set for 755. On the error machine I did:

$ sudo chmod 755 /etc/gconf/gconf.xml.system

and I am no longer getting the 'usr/lib/libgconf2-4/gconf-sanity-check-2 exited with status 256' error msg.

NoOp (glgxg) wrote :

Sorry, forgot to add that I also did:

$ sudo dpkg-reconfigure gdm

and now I no longer get the 256 error.

So in summary:
I- [Could not update ICEauthority file /var/lib/gdm/.ICEauthority]
Resolved by changing Owner etc permissions via 'gksu nautilus' to:
Owner: gdm - Gnome Display Manager
Access: Read and Write
Group: gdm
Access: none
Others
Access: None

II- [This is a problem with the configuration sever.
        (usr/lib/libgconf2-4/gconf-sanity-check-2 exited with status 256)]
Resolved by:
$ sudo chmod 755 /etc/gconf/gconf.xml.system
$ sudo dpkg-reconfigure gdm

Hope that helps someone else with the same issues.

Chris (cbaines) wrote :

I also feel that this should be critical, I have had this problem 3 times now. On a jaunty -> karmic upgrade, karmic fresh install and a karmic xubuntu fresh install. I thought chucking gnome would rid me of this problem? I get the same errors but looking at my system from a live cd I don't have a /var/lib/gdm/.ICEAuthority file, the /var/lib/gdm/ directory exists, with some slightly weird permissions though:
ubuntu@ubuntu:/media/disk-1/var/lib$ ls -l
total 232
...
drwxr-x--- 11 avahi messagebus 4096 2009-12-22 13:47 gdm
...
What do I do?

floid (jkanowitz) wrote :

Just lost a day to this myself (though my fault for not keeping backups).

A permissions (or configuration, I suppose) error anywhere in the gconf hierarchy can turn this up.

In my case, /etc/gconf/2/path included references to the following (installed automatically at some point):

xml:readonly:/etc/gconf/gconf.xml.system
xml:readonly:/var/lib/gconf/debian.defaults
xml:readonly:/var/lib/gconf/defaults

As it turned out, /var/lib/gconf/debian.defaults was not world-readable.

The only clue logged regarding this was:

===
The files that contain your preference settings are currently in use.

You might be logged in to a session from another computer, and the other login session is using your preference settings files.

You can continue to use the current session, but this might cause temporary problems with the preference settings in the other session.

Do you want to continue? Continue (y/n)
===

in /var/log/gdm/:0-greeter.log. Not exactly the first place I would look, or the clearest indication of where the problem is. (After numerous attempts to reinstall and reconfigure all related packages, I was hunting for lockfiles...)

IIRC it looks like fresh installs (or 100% fresh installs of gconf) may not include /etc/gconf/2/path at all (or delete it?), so the wrong permissions from whatever package installs /var/lib/gconf/debian.defaults may only turn up for upgrading users.

karlrt (karlrt) wrote :

just got the same error on karmic, allthough logging in as another user works as usual, just my account is broken. What can i do to debug?

Daniel Asarnow (dasarnow) wrote :

Had same issue (devices: The name org.freedesktop.DeviceKit.Power was not provided by any .service files).
Deleting /var/lib/gdm/.ICEauthority allowed me to log in but doesn't preserve display settings.

For me this issue began after installing the nvidia drivers for my new gfx board.

wade.cherry (wade-cherry) wrote :

I had the exact problem and following the steps by NoOp resolved the issues. Thanks!

Blue_Bullet (nrburness) wrote :

I also had the exact problem and following the steps by NoOp resolved the issues. Thanks!

Little Turtle (litturt) wrote :

This happened to me when I deleted a user and then created a new user with the same name.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gdm (Ubuntu):
status: New → Confirmed
Changed in gdm (Ubuntu):
status: Confirmed → In Progress
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers