login screen is showing user below 1000

Bug #427462 reported by James Dupin on 2009-09-10
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gdm (Ubuntu)
Low
Unassigned

Bug Description

karmic alpha 5

at login screen one user (999) is being shown in the list. thought only equal or greater than 1000 where shown in the ubuntu way.

Not dramatic of course but strange.

affects: ubuntu → gdm (Ubuntu)
Paul Broadhead (pjbroad) on 2009-10-03
Changed in gdm (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, could you give example of users listed?

Changed in gdm (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low

running karmic as a virtualbox machine I noticed that the vboxadd user
(listed as # 999 if memory serves - I am not on my machine right now, I will
correct later if needed) is showed on the karmic login screen (gnome). I
should try to add a user with id 998 to see what is happening.
The vboxadd user comes from the virtualbox guest additions. I will provide
you later on with the complete id of that user.

As said before nothing terrible, just strange.

On Mon, Oct 5, 2009 at 10:53 AM, Sebastien Bacher <email address hidden> wrote:

> Thank you for your bug report, could you give example of users listed?
>
> ** Changed in: gdm (Ubuntu)
> Importance: Undecided => Low
>
> ** Changed in: gdm (Ubuntu)
> Assignee: (unassigned) => Ubuntu Desktop Bugs (desktop-bugs)
>
> --
> login screen is showing user below 1000
> https://bugs.launchpad.net/bugs/427462
> You received this bug notification because you are a direct subscriber
> of the bug.
>

James Dupin (james.dupin) wrote :

I can reproduce this with karmic beta version and I am pretty sure that you can all reproduce that.

I created users with 500 =< UID < 1000 and they all appear at login screen.
This behaviour in itself doesn't bother me in fact as if you create a user and want to force its UID you may want him to appear in the login screen.

I am more annoyed by "service" accounts created by programs (such as the vboxadd user uid=999 gid=1(daemon) groups=1(daemon))

Changed in gdm (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → Robert Ancell (robert-ancell)
Robert Ancell (robert-ancell) wrote :

Debian policy states dynamic user accounts should have UID > 1000:
http://www.debian.org/doc/debian-policy/ch-opersys.html

Changed in gdm (Ubuntu):
assignee: Robert Ancell (robert-ancell) → nobody
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gdm - 2.28.0-0ubuntu15

---------------
gdm (2.28.0-0ubuntu15) karmic; urgency=low

  * debian/patches/23_login_window_hint.patch:
    - Don't put a type hint on the login window as this causes it not to get
      focus (LP: #447049)
  * debian/patches/16_gdmserver_user_manager.patch:
    - Don't show users with UID < 1000 (LP: #427462)

 -- Robert Ancell <email address hidden> Tue, 13 Oct 2009 15:56:41 +1100

Changed in gdm (Ubuntu):
status: Confirmed → Fix Released
Alexander Sack (asac) wrote :

unix has tradition to have UIDs > 500 to be user accounts. debian changed that for whatever reason - probably because they thoguth they run out of uids soon.

i have a uid 501 and now i dont see my main user account anymore. I have that uid for about 10 years and carry it around etc.

what user did you see exactly?

Alexander Sack (asac) wrote :

can you also paste the passwd line for that user please?

James Dupin (james.dupin) wrote :

after upgrading the problem is gone.

consider it solved. ty

djwong (djwong) wrote :

This change prevents me from using the face browser for my uid 501 user account, and since you've hardcoded DEFAULT_MIN_UID=1000 in the binary program, any customization in /etc/login.defs is ignored.

(I'll grant you that upstream shouldn't have hardcoded these values in the first place...)

Alessio Bolognino (themolok) wrote :

Same problem, my uid 501 user does not show up in face browser anymore

Aaron Peromsik (aperomsik) wrote :

I have been going around renumbering my user id's on my home machines, which all had "real" users' numbers starting from 600 due to switching from Mandriva back in the Dapper time frame. The old gdm used to respect the setting in /etc/gnome-system-tools/users/profiles . It would be nice if the new gdm could respect that too.

Aaron Peromsik (aperomsik) wrote :

Sorry, looks like that comment should have gone to bug 459199 instead... except that the comments there already cover it.

Ralf-Peter (ralfpeter-rohbeck) wrote :

I have the same problem. We have a RedHat based infrastructure and my UID/GID is 518. To easily access files via NFS I changed my UID and GID from 1000 but now the greeter doesn't show the user name any more.
Please make the limit configurable - preferably use login.defs.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers