Ubuntu

XDMCP server not working in Ubuntu 10.10 (Maverick)

Reported by Martin Pitt on 2009-08-03
This bug affects 260 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
gdm
Confirmed
Medium
Nominated for Main by thomas
gdm (Ubuntu)
High
Robert Ancell
Declined for Maverick by Sebastien Bacher
Lucid
High
ew59
Natty
High
Robert Ancell

Bug Description

The XDMCP server in GDM does not work/work reliably. When connecting to this server a black screen is shown.

To enable the XDMCP server edit /etc/gdm/custom.conf and set:
[xdmcp]
Enable=true

This bug affects Ubuntu 10.10 (Maverick). It is fixed in 11.04 (Natty) which uses GDM 2.32.0.

A patched GDM by Tom Ellis works better (read comments at the bottom of this bug report for details).
https://launchpad.net/~tellis/+archive/customer1/+packages

(note, this bug used to refer to the lack of an option in the GDM login screen (greeter) to log into remote systems using XDMCP. This is now being tracked in bug 689988).

Martin Pitt (pitti) on 2009-08-03
Changed in gdm (Ubuntu):
assignee: nobody → Robert Ancell (robert-ancell)
tags: added: regression-potential
Changed in gdm (Ubuntu):
status: New → Triaged
Changed in gdm (Ubuntu):
importance: Undecided → Low

What work, if any, is available if this is not fixed?

summary: - does not offer XDMCP any more
+ No option to log in remotely via XDMCP
description: updated

tsclient can connect to XDMCP servers. It does not appear to be working in Karmic for me.

Robert Ancell (robert-ancell) wrote :

(It connects and works for a bit then fails after a few seconds)

Sebastien Bacher (seb128) wrote :

the issue with tsclient is that you need to log in a local account to run it

Changed in gdm (Ubuntu):
importance: Low → High
milestone: none → ubuntu-9.10-beta
Changed in gdm (Ubuntu):
milestone: ubuntu-9.10-beta → none
Robert Ancell (robert-ancell) wrote :

The new GDM does not support logging into remote systems. To workaround this problem thin clients should run an older version of GDM (e.g. by running Jaunty).

Changed in gdm (Ubuntu):
assignee: Robert Ancell (robert-ancell) → nobody
Changed in gdm:
status: Unknown → New
Changed in gdm (Ubuntu):
assignee: nobody → Robert Ancell (robert-ancell)
Robert Ancell (robert-ancell) wrote :

Proposed solution: Make the old GDM available in Karmic as a 'gdm-old' package for users requiring this functionality

Robert Ancell [2009-09-10 2:59 -0000]:
> Proposed solution: Make the old GDM available in Karmic as a 'gdm-old'
> package for users requiring this functionality

It's just a temporary workaround, though, of course. As it happens,
"gdm-2.20" is in source NEW, as a proposed alternative login manager
for Xubuntu. I was hoping that we wouldn't actually need it, though.

Lars - robbiew suggested that you might be able to crack this but

Changed in gdm (Ubuntu):
assignee: Robert Ancell (robert-ancell) → Lars Wirzenius (liw)
assignee: Lars Wirzenius (liw) → nobody

sorry, wrong bug :(

gali98 (korylp) wrote :

This is not so much as a problem (since it is fixable just using terminal client) as not being able to enable the XDMCP server on the machine. This used to be in the Login Window app, but it is now gone. Is there anyway to enable it?
Kory

David Ayers (ayers) wrote :

Using the terminal client would also be sufficient though slightly inconvenient but indeed not being able to configure the XDMCP Server is a show stopper. I suppose that should be separate bug report but Google produces quite a few discussions and potential workarounds (creating gdm.conf with an [XDMCP] section with the entry Enable=true) which do not seem to work for me.

If a separate bug report exists could someone please link to it? I cannot seem to find it.

Justin Clift (justin-salasaga) wrote :

Ironically, an easy to use workaround for now is to install KDM (the KDE login manager). That gives the XDMCP option.

Lennart Hengstmengel (farenji) wrote :

I am suffering from this bug as well. I think it is braindead to start using this new gdm version. Some very useful features were removed without providing an alternative! Apart from not being able to use xdmcp anymore (which I used to do a lot, using gdmflexiserver, which is now as good as useless), it also gives me this stupid chooser without possibility to go back to a normal login screen. I do not want a chooser, i want a plain login! And I do not want to use kdm as I don't like kde and it forces me to enter my password twice each time I login (once to login, and once to unlock my keyring).

I tried going back to the gdm-2.20 legacy version from the repository, but that BREAKS my entire system. X will not start anymore, instead I see strange garbage on the screen and I cannot even access a virtual console anymore using ctrl-alt-f[1-6] (screen stays blank). Only way to get a working system back was a hard reset, getting a recovery root prompt from the grub menu and removing gdm-2.20 and reinstalling the default gdm.

Please fix this. I am considering going back to an older version of ubuntu, or maybe even plain debian for this issue alone. It's very annoying.

I won't update to 9.10 because of this bug. I don't have a real monitor attached to my linux box. I use Xming from my windows box to log into ubuntu.

ghook (gary-hook) wrote :

I was able to use Xming to establish a remote XDMCP session to a Karmic box. I just added the following lines to the \etc\gdm\custom.conf file:

[daemon]
RemoteGreeter=/usr/lib/gdm/gdmlogin

[xdmcp]
Enable=true

Rolf Leggewie (r0lf) on 2009-12-14
tags: added: karmic

One main features removed from gdm, is the possibility to log in from the
gdm login screen. This was an important feature, that should not have been
removed.

Also, GDMSetup is reduced to only configuring automatic login. All other
settings are removed, including the option to enable remote log in from
GDMSetup. This feature, togehter with te possibbilty to configure GDM's
look, themes, should not have been removed. Even with the purpose of
cretaing a simpler and cleaner GUI.

2009/12/10 ghook <email address hidden>

> I was able to use Xming to establish a remote XDMCP session to a Karmic
> box. I just added the following lines to the \etc\gdm\custom.conf file:
>
> [daemon]
> RemoteGreeter=/usr/lib/gdm/gdmlogin
>
> [xdmcp]
> Enable=true
>
> --
> No option to log in remotely via XDMCP
> https://bugs.launchpad.net/bugs/408417
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Just want to say that what ghook proposes will probably get this working for most people. I had that file from having XDMCP set up in an earlier verison and I can get in fine.

Could anyone test to see if the system prevents them from mounting drives through a remote xsession? It keeps telling me that I'm unauthorized. The exact same user account can do that when I'm logged into a local graphic console but it denies me when I'm remote. Is there a config file somewhere I need to change?

tags: added: regression-release
removed: regression-potential
komputes (komputes) wrote :

ghook mentioned it, and peppertop.com blogged it, but here is a link to the official link to gdm daemon configuration documentation:

http://library.gnome.org/admin/gdm/2.28/configuration.html.en#daemonconfig

As James requested, could people affected test this and report back if enabling XDMCP works for them.

David Ayers (ayers) wrote :

I do not use Xming but Xnest via Terminal-Server-Client since I'm connecting from a Jaunty System.

I tried with both [xdmcp] and [xdcmp] (note the typo in the title of http://library.gnome.org/admin/gdm/2.28/configuration.html.en#xdmcpsection ) without success.

Yet I noticed that netstat only shows a udp6 listener on the server:
~$ netstat -ltun|grep 177
udp6 1728 0 :::177 :::*

I installed wireshark on the client Jaunty but I'm only capturing IPv4 traffic.

So how would I configure XDMCP to bind on IPv4 interface or teach Terminal-Server-Client to use IPv6?

scotcarl (scotcarl) wrote :

Hi guys. I've just followed the instructions on http://www.peppertop.com/blog/?p=690 ( thanks mfolkerts ), and am now able to connect to my confuser that runs ubuntu 9.10 with no problems. I am using Xming from my laptop which runs Vista ( everyones favourite OS ) as the client. Thanks for everyones comments, and thanks to the dude at http://www.peppertop.com/blog/ for taking the time to spell it all out in steps that are easy enough for me to follow. I hope that the plain and simple tick box in the GUI is bought back, cos this is much simpler.

Martin Pitt (pitti) wrote :

(Not a lucid release blocker)

Changed in gdm (Ubuntu Lucid):
status: Triaged → Won't Fix

None of these workarounds have worked for us... We'll have to rollback to Jaunty because of this.. Sad an painful...

jdege (jdege) wrote :

I have to say I'm flabbergasted. I'd though remote login has always been considered one of the fundamental capabilities of X11. I'm astounded that anyone would consider it optional.

That enabling an XDCMP server requires editing a config file is a minor inconvenience. That I can't access the chooser from a GDM login screen is a definite show-stopper.

Johanna Hofinger (j-hofinger) wrote :

I agree fully with jdege

Antje H. (anthe1) wrote :

Add me to those who need it!

dunand (jeffnadeau) wrote :

We need xdmcp too. It's a show stopper for us.

rlaforge (laforge-lettis) wrote :

I had this working under karmic, then a kernel upgrade killed it. spent a day trying to get it to work, to no avail

raraki-adpt (raraki-adpt-tech) wrote :

the solution using vnc4server (see http://www.peppertop.com/blog/?p=744 under the VNC section) worked perfectly well for us: multiple users are able to remotely connect to a headless virtual server running 9.10 and have the full desktop available. Many thanks to the blog author for a comprehensive discussion of the topic.

David Ayers (ayers) wrote :

Thanks for the pointer yet it seems not to be an option if someone else is logged onto their own desktop session and is doing real work which is the scenario I need to solve. Also it's much to technical for the users that need this.

I understand the Ubuntu maintainers see their responsibility in packaging GNOME and not in fixing all bugs/adding features that have not been implemented upstream and that seems perfectly valid. I would like to know whether the Ubuntu maintainers do feel responsible to forwarding bugs reported against supported versions of Ubuntu upstream and referencing them here.

Anyway these are the reports I found that seem to address part of the issue:
https://bugzilla.gnome.org/show_bug.cgi?id=592976

I haven't found a bug report that addresses the fact that gdm cannot be configured as server anymore.

Note I'm not necessarily stuck on "XDMCP". If there is some other protocol/package with which one could start in independent remote session in Lucid, I'd be a happy camper.

solution by ghook worked for me.

He suggests:

I was able to use Xming to establish a remote XDMCP session to a Karmic box. I just added the following lines to the \etc\gdm\custom.conf file:

[daemon]
RemoteGreeter=/usr/lib/gdm/gdmlogin

[xdmcp]
Enable=true

happens to be a required feature for me.

Michał Borsuk (michal-borsuk) wrote :

I was about to upgrade one of my computers and keep the other as "lean client" with XDMCP, when Ubuntu 9.10 came out.

Juan J. Garcia (juanjo-lau) wrote :

It's frustrating when you know where is an option on the GUI, and then it's removed. Know to setup the remote login, you have to go to the command line.

kfsone (oliver-kfs) wrote :

I had this work, once, using pepper's instructions. Then I restarted my XMing session to switch from Window to Fullscreen, and never got it working again (without changing anything, going through all the restart/reboot/etc hoops).

So I did a clean install on a virtual machine, with Lucid 10.4 rc, repeated pepper's steps, got the chooser to come up, closed down the x server, restarted, and same thing. So I rolled the virtual machine back, repeated pepper's steps, and it worked. Closed the x server, restarted, same thing.

I don't know why it works that first time - but the problem appears to be that GDM is only listening on the udpv6 port:

netstat -an | grep 177

osmith@lucidrc:~$ netstat -an | grep 177
udp6 0 0 :::177 :::*

Tony McConnell (amnw14545) wrote :

@34: seems to work for me with xming 7.5.0.15, gdm 2.30.0

Just had to edit the custom.conf as detailed in comment #15, and run with the following from DOS:

"C:\Program Files\Xming\Xming.exe" -query 192.168.1.2 -ac -wgl -nodecoration -multimonitors -clipboard

Michael DePaulo (mikedep333) wrote :

ghook's method work's erratically with lucid

I followed his instructions (it sounds more like the actual feature than a workaround) by adding these lines to /etc/gdm/custom.conf
[daemon]
RemoteGreeter=/usr/lib/gdm/gdmlogin

[xdmcp]
Enable=true

Sure enough, I can connect to the server with Xming and the window with gdm pops up
Xming.exe -query 192.168.1.101

After repeated testing, I believe that both GNOME sessions and Failsafe GNOME sessions seem to worked erratically. When it doesn't work, after you enter your password and hit enter it freezes up.
Alternating between those two types of sessions seems to help.

Please note that I had a neatx NX session going, and I have LTSP installed with no LTSP clients going.

In my auth.log I have a bunch of lines like these (my username is mike and I hadn't been doing any other types of logins):
May 1 22:10:53 minilove gdm-session-worker[9697]: pam_unix(gdm:session): session opened for user mike by (uid=0)
May 1 22:10:53 minilove gdm-session-worker[9697]: pam_ck_connector(gdm:session): nox11 mode, ignoring PAM_TTY ::ffff:192.168.1.102:0
May 1 22:14:21 minilove gdm-session-worker[9697]: pam_unix(gdm:session): session closed for user mike

Bercail (comptawiph) wrote :

Arghhh ! Steping from Hardy to Lucid let me discover the problem.
I'm using xdmcp to control all the pc (15 Hardy) and 2 debian servers from my stations (one Ubuntu or one Xp from laptop) to maintain them and help the users while they are using their computer.
What other solution is there, as easy and powerfull as xdmcp was ?
BD

Németh Csaba (1soproni) on 2010-05-11
Changed in gdm (Ubuntu Lucid):
assignee: nobody → Németh Csaba (1soproni)
assignee: Németh Csaba (1soproni) → nobody

This is beyond nuts. I was weirded out on 9.10 when I lost the configuration screens. Losing remote XDMCP is catastrophic to the point it will likely have me sticking with 9.04. I can't think of any reason why this would be undesirable, in particular when you have multiple clients running multiple X-terminals. This needed to be corrected on 9.10, I was SURE it would be fixed in 10.04, now I'm screwed.

Gabriel Mazetto (brodock) wrote :

Can someone just reopen this for Maverick?

tags: added: lucid
Fastguy (erenoglu) wrote :

I'm trying to login to a remote XDMCP enabled server with my Lucid 10.04 desktop system. I can't find the Remote Login option in the GDM screen. Where is it?

Changed in gdm:
status: New → Confirmed
Changed in gdm (Ubuntu):
status: Triaged → Confirmed
Rolf Leggewie (r0lf) on 2010-06-07
Changed in gdm (Ubuntu):
status: Confirmed → Triaged
Steve Langasek (vorlon) on 2010-07-08
Changed in ubuntu-release-notes:
status: New → Fix Released
Changed in gdm:
importance: Unknown → Medium
Changed in ubuntu-release-notes:
status: Fix Released → Confirmed
Steve Langasek (vorlon) on 2010-10-08
Changed in ubuntu-release-notes:
status: Confirmed → Fix Released
36 comments hidden view all 116 comments
Jonathan Carter (jonathan) wrote :

Fabián and Steve, do you think it's likely that XDMCP will be available in GDM again? It seems somewhat deprecated in favour of many newer technologies that are more likely to be implemented in a login manager. Are you planning to just mention this release note in every Ubuntu release then indefinitely? IMHO, since it's not a regression and since it's probably likely to stay that way, it should probably not have to be mentioned in the release notes.

For Lucid it was since it might have affected 8.04 -> 10.10 upgrades, I don't believe it's relevant for 10.10 though.

papukaija (papukaija) on 2010-10-10
tags: added: maverick
Fabián Rodríguez (magicfab) wrote :

Jonathan, some users may still be updating from 8.04 LTS -> 10.04 LTS -> 10.10 so this is the only way to make sure they know about it (other than this bug).

Alvin (alvind) wrote :

So far, I have considered this bug a regression, and not a feature. As a sysadmin for a company that uses XDMCP extensively, I'd like to know what new technologies deprecated XDMCP. We're currently happy to be using Kubuntu, but what if KDM will also lose this option?

No XDMCP bugs me so long now. I don't understand why it is gone. I found nothing better in for my network enviroment. You could even use compiz over the network with it.

XDMCP is handy in my shop at work. We use SunRay thin clients. From the SunRay login prompt you can log in to an XDMCP capable machine via Remote Login/Enter Host Name. See screen shot below.

http://lh6.ggpht.com/_wqO1jszSllI/TLccHFqGJpI/AAAAAAAA5ZQ/26cUiVNXA6c/s800/IMG_20101014_110106.jpg

I installed WDM on Ubuntu 10.10. I was able to log-in via XDMCP but I couldn't open a gnome-terminal or gnome-system-monitor. WDM installation appears to have broken some things. If adding XDMCP back to GDM doesn't cause major headaches I would like to see it added back. Even if I have to edit a config file somewhere. As long as we can get it working reliably.

Patrick,

Your gnome-terminal and gnome-system-monitor problems are unrelated to wdm. In fact I'm typing this from a WDM login on a thin client to a gnome session and both gnome-terminal and gnome-system-monitor start up just fine. I suggest you bring up an Xterm (ALT-F2, xterm, enter) and run them from a cli to see what the error is or check your .xsession-errors file.

kfsone (oliver-kfs) wrote :

@Jonathon It *IS* a regression. See comments 69 and 70.

Is there *somebody* who has a working solution? Because I read all comments, and I tried some workarounds, but none of them worked for me ... :-(

kdm is working.

Am Dienstag, den 26.10.2010, 07:14 +0000 schrieb Jochen Hebbrecht:
> Is there *somebody* who has a working solution? Because I read all
> comments, and I tried some workarounds, but none of them worked for me
> ... :-(
>

Martin,

But I prefer to use GDM :-( ...
If not, then we have to switch to KDM ...

Jochen

Martin,

* $ aptitude install kdm
* enabled XDMCP in /etc/kde4/kdm/kdmrc
* enabled in /etc/kde4/kdm/Xaccess
- * #any host can get a login window
- * CHOOSER BROADCAST #any indirect host can get a chooser

... doesn't work. Xnest keeps on giving me a black window ...

Pffffff! :-)

Jochen

Jochen,

You might try wdm. The interface is ugly, but you don't have to load all the KDE stuff on the machine to run it, it's very light weight.

I've never used Xnest, but I'm thinking the problem is *NOT* related to gdm/kdm/wdm. Perhaps some insight on the application of Xnest? 'Xnest -query localhost' :).

Have you tested KDM with a "normal" xsession? ((CTL-)ALT-F2) login cli, 'X :2 -query localhost' ???

Some of the changes to the X libraries created all kinds of havoc with VNC and others.

Keith,

So, I first have to install "wdm", but what do I have to next? Do I need some kind of configuration?
I didn't try that KDM with a "normal" xsession ...

Jochen

Install wdm, dpkg-reconfigure gdm, select wdm as your default. Talk to
me offline keith at ksmith.com as this is not in scope. You are having
a problem with Xnest which may have nothing to do with the display
manager. You can determine that trivially by running another X session
against the dm. If you don't understand how this works this is a bug
trac for gdm, not a help forum, we shouldn't be discussing this here
beyond the scope of work arounds.

Hi All,

I am truly very disappointed by Ubuntu's dev team decision to ship its latest version of OS without xdmcp functionality.
we all can understand that it is GDM's responsibility to maintain its packages and include/remove functionality, yet it is ubuntu's responsibility to make sure that end user receives product that provides the desired functionality and not half-baked product.
And i am not talking only about home users or some test machines.
The company i work for use ubuntu ALOT(i am talking about tens of ubuntu servers), and by removing xdmcp from latest release, we will have no choice but to avoid upgrade, and later thinking about moving to different OS.
Its a real shame that company so loved by its users, doesn't listen to them anymore..

Sebastien Bacher (seb128) wrote :

> yet it is ubuntu's responsibility to make sure that end user receives product that provides the desired functionality and not half-baked product.

the Ubuntu team is mostly volunteers, nobody in the team seems to be using xdmcp and noticed that it was broken before upgrading, there is probably a call for better testing there to avoid such issues

> thinking about moving to different OS.

why not just contributing a fix or changing the login manager to one support xdmcp? Other linux distributions will have the same issue since the bug is a gdm one

> Its a real shame that company so loved by its users, doesn't listen to them anymore..

nobody there not listening, the number of contributors is just limited and the team can't work on all issues immediatly...

On Mon, 08 Nov 2010 10:23:25 -0000
Sebastien Bacher <email address hidden> wrote:

> why not just contributing a fix or changing the login manager to one
> support xdmcp? Other linux distributions will have the same issue since
> the bug is a gdm one
>

I think it's NOT a GDM bug since I'm happily using GDM (2.20.11) on
debian testing as XDMCP login server.

Giuseppe

I can confirm that XDMCP is working on debian squeeze.

Stranger than that is a box I have running Lucid, which does work with XDMCP although this is declared broken for Lucid.
On another box that I upgraded from Lucid to Maverick, XDMCP was working before and stopped after the upgrade.

This reminds me of the pulseaudio saga, in case you still remember.

David Ayers (ayers) wrote :

I'd like to iterate that I confirmed in comment 64 that Fedora 13 didn't have the issue either. If it helps I can also check with Fedora 14. The inability to use gdm as an XDMCP server seems Ubuntu specific to me.

Sebastien Bacher (seb128) wrote :

> The inability to use gdm as an XDMCP server seems Ubuntu specific to me.

no it's not, but it depends of the build option it seems, having ipv6 enabled or not seems to be one thing that makes a difference, would be nice if somebody could try with the debian patch and building without ipv6

what gdm version is in the fedora which is working? seems gdm xdmcp was working in lucid as well so it got broken on the way

David Ayers (ayers) wrote :

From comment #64: "Connecting to a Goddard gdm 2.30.2 allows multiple successive logins."

Now netstat reports that Lucid is listening on port 177 only under IPv6 and Goddard only on IPv4.
How would I get Lucid to listing on IPv4?

jss (jsantossilva) wrote :

On the Lucid box that is working with XDMCP, I just confirm that port 177 is only opened for IPV6:

$ sudo netstat -atnup | grep 177
udp6 0 0 :::177 :::* 754/gdm-binary
$

Anomaly256 (anomaly256) wrote :

Wow, this is retarded. Epically retarded.

Sorry guys, but all this back and forth arguing and the issue itself.. It really is retarded.

It's clear people want and *NEED* this feature. VNC is hardly in the same ballpark as true remoteX. Ever tried to use remote GL calls under vnc? Can't happen. Works sweet with full remoteX though.

This has *always* been one of the most powerful features of linux. PLEASE fix it.

Just fix it. Put it back. Downgrade, upgrade, whatever you need to do. This 'LTS' is simply broken until you do. And while you're at it, put back the ability to replace your (frankly) *ugly* ubuntu gdm theme from gdmsetup. Not everyone 'feels' purple you know.

No other distro that I've used lately is experiencing these feature cutbacks and retardation, and some of them even use newer versions of gdm than Lucid does. At a minimum.. the Ubuntu team misconfigured the build options. At worst, it's an intentional oversight. Stop passing the buck around on this, delaying and stalling, JUST FIX IT.

</appeal_to_reason_and_common_sense>

David Ayers (ayers) wrote :

I was hoping this could be resolved by a backport of the fix in 2.30.4-0ubuntu1 for bug #393835 but I cannot connect to a maverick server with the even newer 2.30.5-0ubuntu4 with Xephir. Yet I still can connect to a Fedora with gdm 2.30.2 1.fc3.

Sebastien Bacher (seb128) wrote :

Could someone try to set --enable-ipv6 to no in the rules? The fedora build doesn't enable ipv6 and some comments suggested there that ipv6 could create the bug

Martin Pitt (pitti) wrote :

Robert, do you have some time to look into this? It seems that XDMCP is working in Fedora, so it seems the feature is not missing as such, it's just broken in our package. Thanks! (Please kick back to c-desktop-team if you can't handle this).

Changed in gdm (Ubuntu Natty):
assignee: nobody → Robert Ancell (robert-ancell)
Tom Ellis (tellis) wrote :

So, I tested GDM 2.30.5-0ubuntu4 on Maverick with /etc/gdm/custom.conf set to:
[xdmcp]
Enable=true

Connecting to the system with '# X :1 -query <ip>' fails after hanging for a few minutes.

After I recompiled GDM with the compile flag --enable-ipv6 set to no in debian/rules as Sebastien suggests in #101 (available in my PPA here: https://launchpad.net/~tellis/+archive/generic/+packages).

With the recompiled GDM, I can successfully connect to GDM remotely and login via the GDM greeter, but no gnome-panel's are displayed. However, upon the 2nd attempt, I can login and get a fully working desktop.

Tom Ellis (tellis) wrote :

I also rebuilt Maverick's GDM keeping the --enable-ipv6=yes option and bringing in the 03_ipv6.patch patch from Debian as mentioned in #96 from http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=579033, grabbed from Debian package version gdm3_2.30.5-6 (build available in my PPA here: https://launchpad.net/~tellis/+archive/customer1/+packages).

This works as expected, XDMCP session is successful but gnome-session/panel's are not appearing until I log in via XDMCP for the 2nd time.

I also carried out some verification with 10.04 using GDM 2.30.2.is.2.30.0-0ubuntu4 - XDMCP is working perfectly.

To summarise:

Ubuntu 10.04 - GDM 2.30.2.is.2.30.0-0ubuntu4 - Remote XDMCP successful
Ubuntu 10.10 - GDM 2.30.5-0ubuntu4 - Remote XDMCP connections fail
Ubuntu 10.10 - GDM 2.30.5-0ubuntu5-ppa1 with --enable-ipv6=no - Remote XDMCP connections successful (but no gnome-session until second login attempt)
Ubuntu 10.10 - GDM 2.30.5-0ubuntu5-ppa2 with 03_ipv6.patch from Debian - Remote XDMCP connections successful (but no gnome-session until second login attempt)

So, for 10.10, it looks like pulling in the ipv6 patch from Debian would solve part of the problem and for 10.04 I don't see an issue.

David Ayers (ayers) wrote :

Interesting.. I suppose you are connecting from a Maverick client? Which client are you using?
I've got 2 i686 10.04 systems and I'm using:
Xephyr :1 -once -query <hostname>
and all I'm getting is a blank screen in the Xephyr window:
xserver-xephyr 2:1.7.6-2ubuntu7.4

If I try the same Xephyr command from a Maverick VM to the Lucie VM I get a segfault.

Tom Ellis (tellis) wrote :

Yes, for testing XDCMP for Lucid, I'm connecting from a Maverick desktop to a Lucid VM, not using Xephyr though, just using 'X :2 -query <ip>'. I also just installed, xserver-xephyr (2:1.9.0-0ubuntu7) on Maverick desktop and tried with the command you suggested and I do not have an issue connecting to Lucid. As mentioned before, I do not see the problem on Lucid, only Maverick.

I've also tried the latest GDM from Natty (2.32.0-0ubuntu1) which brings in the latest upstream release, this already has the IPv6 patch which has been committed upstream and works perfectly for XDMCP (although I still have the gnome-session issue), so I can confirm XDMCP will work in Natty too.

David Ayers (ayers) wrote :

Thanks a lot Tim... It seems that for my use case using X directly would actually also be more appropriate anyway.

I have my desktop session running, switch to terminal 1 via ctrl-alt-F1, login then run:
sudo X :2 -query <ip>
my screen goes blank but no greeter is displayed. I've attached the custom.conf from the server, but I don't find anything unusual.

I suppose that the main difference between our setup is that you are using two 64-bit systems while mine are i686, is that correct? These are both Dell pre-installed systems that have been upgraded to Lucid with many manual configurations and a few proprietary drivers for misguided hardware purchases :-/ oh well...

I'd install 64-bit Lucid on both via external USB drives but due to:
https://bugs.launchpad.net/ubuntu/+source/grub-installer/+bug/45989
https://bugs.launchpad.net/ubuntu/+source/grub-installer/+bug/46520
that's a bit tedious for my production systems... but I hope I'll get around to it coming week.

Again, thanks a lot for providing the PPA's for lucid and spending the time to knock this out.

Tom Ellis (tellis) wrote :

@David - Tested your custom.conf, that works perfectly for me on a Lucid VM when connecting from Maverick and yes I'm using 64-bit on everything.

I've opened another bug for the gdm-session/gnome-panel issue here, for those interested:
https://bugs.launchpad.net/ubuntu/+source/gnome-panel/+bug/689366

Changed in gdm (Ubuntu Natty):
status: Triaged → Fix Released
Robert Ancell (robert-ancell) wrote :

Closing the natty component as "Fix Released". I can confirm as Tom Ellis did that the XDMCP server is working correctly with GDM 2.32.0. Test case:

1. Set the following in /etc/gdm/custom.conf:
    [xdmcp]
    Enable=true
2. Restart GDM
3. Log in, and run Xephyr:
    $ Xephyr :1 -broadcast

Result:
Xephyr window appears with GDM greeter shown. Logging into greeter works as expected. Repeating step 3 continues to work.

Robert Ancell (robert-ancell) wrote :

This bug has morphed from it's original goal. The bug was opened about the GDM login screen (greeter) not being able to log into remote systems, as it did pre GDM 2.20.

The majority of the comments here are about the XDMCP server in GDM not working, probably due to implementation errors with IPv6 and/or 32/64 bit issues.

I've opened a bug 689988 to track the original GDM UI problems, if you were following that issue, please change to that bug.

I've updated the description of this bug to be about the XDMCP server issues.

summary: - No option to log in remotely via XDMCP
+ XDMCP server not working
description: updated
description: updated
description: updated
summary: - XDMCP server not working
+ XDMCP server not working in Ubuntu 10.10 (Maverick)
Robert Ancell (robert-ancell) wrote :

Thanks Tom for the work with the patch. I tried it in a fresh virtual (qemu) Maverick i386 install and it works perfectly (i.e. no gnome-session issues). I'm testing by the following:
1. Fresh Maverick install (tried with and without updates)
2. GDM set to autologin
3. XDMCP enabled in /etc/gdm/custom.conf
4. From terminal, run Xephyr :1 -broadcast
Could you confirm if you get the same problems following the same steps?

I've pushed these changes to lp:~ubuntu-desktop/gdm/maverick. I'll propose this as a SRU if we can confirm the gnome-session problems are not related.

Tom Ellis (tellis) wrote :

Hi Robert,

I can confirm your findings using your test case in #112, with GDM set to auto-login, I do not see the issue with the gnome-session and everything works successfully on Maverick with the patch.

Without auto-login, I hit the gnome-session issue but we can move that over to LP: #689366 to keep this bug clean if you like?

David Ayers (ayers) wrote :

OK I can confirm that from a Maverick system I can also connect to a freshly installed Lucid GDM server.
I cannot connect to my existing GDM server so it seems that my issue is local to my setup.

ew59 (w-ewert) on 2011-01-31
Changed in gdm (Ubuntu Lucid):
assignee: nobody → ew59 (w-ewert)
John (tails-naf) wrote :

I have applied the patch, but I am seeing a very strange problem.

I am using vnc sessions with gdm / xdmcp enabled to allow persistent sessions in 10.10
It seems that gdm-simple-greeter is now hanging/crashing, depending on what is done.

a)
If I have a vnc session with display resolution set to 640x480, simple-greeter works and I can login.
However, if I click on my user name to login and then click cancel, simple-greeter segfaults.
(the segfault can be seen in /var/log/gdm/xxxxx-greeter.log)

b)
If I have a vnc session with a display resolution of, say, 800x600, simple-greeter hangs, and I cannot login at all.

In fact, the change in behavior it seems to be related to the x-dimension of the vnc session requested - if I set it to be 640x800, that will work just as in case a) above
Either way, both a and b either crash or hang.

I don't know if this issue is related to the patch or not as I applied the patch before setting up the vnc system.
I applied the i386 patch listed above to a 10.10 32bit install. (i686 from uname -a)

I would be interested to see if anyone else is seeing an issue with gdm-simple-greeter, or if there is an alternative to it that I could try..

K1773R (k1773r) wrote :

WONT_FIX for a LTS is absolutely unacceptable...

Displaying first 40 and last 40 comments. View all 116 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.