GDM login theme change when using accessibility features

Bug #402017 reported by Tomas Cassidy on 2009-07-21
210
This bug affects 43 people
Affects Status Importance Assigned to Milestone
gdm
Fix Released
Medium
gdm (Ubuntu)
Low
Unassigned
Lucid
Low
Unassigned

Bug Description

Binary package hint: gdm

Karmic Alpha2 running inside VMWare Player on linux.

uname -r: 2.6.31-3-generic
gdm: 2.27.4-0ubuntu2

When login screen first appears, the window/area containing the username to click on is 338px wide (measured with "screenruler" app). After enabling and disabling the large-text accessibility feature, the area increases to 455px wide.

After enabling and disabling the large-text accessibility feature the accessibility icon/button does not change back to the original size but stays at the larger size set when the large-text feature is on. This is causing part of the icon/button to be hidden below the bottom of the screen and is forcing the date/time text to align on the bottom of the white strip instead of the horizontal-centre as it is initially.

After enabling/disabling of the "enhance contrast in colours" feature, the colours don't revert back to brown but stay as blue.

Screenshots of before/after are attached.

Sebastien Bacher (seb128) wrote :

thank you for your bug report, is gnome-settings-daemon crashing?

Changed in gdm (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Tomas Cassidy (tomas-cassidy) wrote :

I had to login via ssh to run these commands as trying to switch to VC1 with ctrl+alt+1 got picked up by the host machine and not VMWare Player.

Before enable/disable of accessibility features:
$ ps aux |grep gnome-settings-daemon
gdm 2479 0.4 1.9 35668 10000 ? Ssl 12:06 0:01 /usr/lib/gnome-settings-daemon/gnome-settings-daemon --gconf-prefix=/apps/gdm/simple-greeter/settings-manager-plugins
gdm 3324 2.2 1.9 35672 9992 ? Ssl 12:09 0:00 /usr/lib/gnome-settings-daemon/gnome-settings-daemon --gconf-prefix=/apps/gdm/simple-greeter/settings-manager-plugins

After enable/disable of accessibility features:
$ ps aux |grep gnome-settings-daemon
gdm 2479 0.4 1.9 35716 10024 ? Ssl 12:06 0:01 /usr/lib/gnome-settings-daemon/gnome-settings-daemon --gconf-prefix=/apps/gdm/simple-greeter/settings-manager-plugins
gdm 3324 1.6 2.6 38140 13364 ? Ssl 12:09 0:01 /usr/lib/gnome-settings-daemon/gnome-settings-daemon --gconf-prefix=/apps/gdm/simple-greeter/settings-manager-plugins

There was no output from "pgrep -l gnome-settings-daemon"

Sebastien Bacher (seb128) wrote :

Confirmed on current karmic now and sent to http://bugzilla.gnome.org/show_bug.cgi?id=589539

summary: - [karmic] GDM login screen is different after enable/disable of
- accessibility features
+ GDM login screen is different after enable/disable of accessibility
+ features
summary: - GDM login screen is different after enable/disable of accessibility
- features
+ GDM login theme change when using accessibility features
Changed in gdm (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
status: Incomplete → Triaged
Changed in gdm:
status: Unknown → New
Jeff Sereno (jsereno) wrote :

I can confirm this on a native machine installation as well. The Ubuntu logo in the GDM display changes to the GNOME monitor icon and never changes back after you uncheck the "enhance contrast" option too (although the colours changed back, but only after a reboot).

David Gillies (daveg) wrote :

Adding in a "me too". I'm seeing the same on a native machine like Jeff Sereno after performing the same actions.

Jan Nekvasil (jan-nekvasil) wrote :

That's all because whole directory /var/lib/gdm/.gconf/desktop/gnome/interface gets deleted by checking that accessibility checkbox, taking down the according %gconf.xml file with it. Manual recreation of this directory a it's contents fixes it until next click on the ACODBIT (Accessibility-Checkbox-Of-Death-By-Inappropriate-Theme).

John Wells (jfw) wrote :

Me too -- new login screen looked great. Only saw it properly themed once. Observed on a live image, fresh-installed machine, and a machine upgraded from Jaunty. Disappointing -- I won't be clicking on the "ACODBIT" again

Rafael (qe47ct6n318407t6n) wrote :

This worked for me:
1 - copy file /var/lib/gdm/.gconf.defaults/%gconf-tree.xml to another place (just a backup)
2 - boot from a LiveCD ou USB
3 - copy file /var/lib/gdm/.gconf.defaults/%gconf-tree.xml over the original

NoOp (glgxg) wrote :

Rafael's workaround also worked for me.

 Attached is a meld diff showing the difference between the files. The file on the left (/home/gg2xp/tempdir/G/%gconf-tree.xml) is from a standard 9.10 Ubuntu (Gnome) machine, the file on the right (/home/gg2xp/tempdir/%gconf-tree.xml) is from a 9.10 Ubuntu test machine where the "enhance contrast colors" was enabled at the GDM login screen.

$ apt-cache policy gdm
gdm:
  Installed: 2.28.1-0ubuntu2.1
  Candidate: 2.28.1-0ubuntu2.1
  Version table:
 *** 2.28.1-0ubuntu2.1 0
        500 http://archive.ubuntu.com karmic-updates/main Packages
        100 /var/lib/dpkg/status
     2.28.1-0ubuntu1 0
        500 http://archive.ubuntu.com karmic/main Packages

2.6.31-17-generic #54-Ubuntu SMP Thu Dec 10 16:20:31 UTC 2009 i686 GNU/Linux

Pablo Nogueira (pirelo) wrote :

I also lost the default theme when playing with accessibility options
I should add the default theme I saw after upgrading to Karmic does not look like the one shown in #1.

My /var/lib/gdm/.gconf.defaults/%gconf-tree.xml had no information registered on the "interface" and "metacity"-"general" entries:

  <dir name="interface">
  </dir>

  <dir name="metacity">
   <dir name="general">
   </dir>
  </dir>

I've recovered the theme by simply adding the missing data:

<dir name="interface">
    <entry name="icon_theme" mtime="1255598514" type="string">
     <stringvalue>HumanLoginIcons</stringvalue>
    </entry>
    <entry name="gtk_theme" mtime="1255598514" type="string">
     <stringvalue>HumanLogin</stringvalue>
    </entry>
   </dir>

<dir name="metacity">
   <dir name="general">
    <entry name="theme" mtime="1255598514" type="string">
     <stringvalue>HumanLogin</stringvalue>
    </entry>
   </dir>
  </dir>

I haven't changed the other fields because they're specific to my setting: keyboard layout, language, etc.
(Albeit they could could be changed using the gdm menus when loging in).

gsmx (gsmx) wrote :

Same behaviour still present in Lucid Alpha 2

I did see it few days agao (around 2 weeks IIRC), but I can confirm tonight once I'm back home.

Changed in gdm (Ubuntu Lucid):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → Canonical Desktop Team (canonical-desktop-team)
John Baptist (jepst79) wrote :

This still happens under Lucid Beta 2, as well.

I should point out that (on my machine, at least) logging in and then logging back out, or rebooting the machine, or restarting X, results in the theme and colors returning to normal. It's not necessary to edit config files. That is, the unexpected theming is only temporary. Nevertheless, this is a weird usability bug, and disconcerting to a new user.

Sebastien Bacher (seb128) wrote :

the bug should be fixed in upstream git now

Changed in gdm (Ubuntu):
status: Triaged → Fix Committed
Changed in gdm:
status: New → Fix Released
Changed in gdm (Ubuntu Lucid):
status: Triaged → Fix Committed
Sebastien Bacher (seb128) wrote :

the upstream change fixes some issues but the theme doesn't go back to the initial value

Changed in gdm (Ubuntu):
assignee: Canonical Desktop Team (canonical-desktop-team) → nobody
Changed in gdm (Ubuntu Lucid):
assignee: Canonical Desktop Team (canonical-desktop-team) → nobody
status: Fix Committed → Triaged
Changed in gdm (Ubuntu):
status: Fix Committed → Triaged

FWIW, I'm still seeing this in 10.04.1.

Here are a couple of workarounds I have tested that seem to work:

This will temporarily fix the theme, but checking the accessibility feature breaks it again:
sudo gconftool-2 --direct --config-source xml:readwrite:/var/lib/gdm/.gconf.defaults --set --type string /desktop/gnome/interface/icon_theme LoginIcons
sudo restart gdm

This will make the setting mandatory. With this setting, checking the accessibility feature breaks the theme, but on any restart of gdm (or the system), it will revert to the proper theme:
sudo gconftool-2 --direct --config-source xml:readwrite:/var/lib/gdm/.gconf.mandatory --set --type string /desktop/gnome/interface/icon_theme LoginIcons
sudo restart gdm

I hope this helps...

Changed in gdm:
importance: Unknown → Medium
Jordon Bedwell (envygeeks) wrote :

Still plaguing Maverick as well.

Jeremy Bicha (jbicha) wrote :

And still broken in 11.04

Rolf Leggewie (r0lf) wrote :

lucid has seen the end of its life and is no longer receiving any updates. Marking the lucid task for this ticket as "Won't Fix".

Changed in gdm (Ubuntu Lucid):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.