gdm 2.26 custom configuration file: wrong filename

Bug #395861 reported by Hernando Torque on 2009-07-05
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
casper (Ubuntu)
Undecided
Martin Pitt
gdm (Ubuntu)
Medium
Martin Pitt
ubiquity (Ubuntu)
Medium
Colin Watson
user-setup (Ubuntu)
Medium
Colin Watson

Bug Description

Binary package hint: gdm

GDM installs a file /etc/gdm/custom.conf which apparently does not do what its filename suggests: configure GDM.

Instead GDM seems to use the file /etc/gdm/gdm.conf-custom for configuration.

gdm 2.26.1-0ubuntu2

Hernando Torque (htorque) wrote :

After reading the documentation (http://library.gnome.org/admin/gdm/stable/configuration.html.en) it's in fact custom.conf that should be used to config GDM. I suggest renaming the bug to something like "gdm 2.26 wrong configuration file used".

Stephen Cradock (s-cradock) wrote :

I can confirm that the contents of /etc/gdm/custom.conf are IGNORED and the contents of /etc/gdm/gdm.conf-custom over-ride the settings in /etc/gdm/gdm.schemas, contrary to the documentation.

Changed in gdm (Ubuntu):
status: New → Confirmed
Wayne Cat (exchange) wrote :

I can also confirm this.

An entry:

---
[daemon]

AutomaticLoginEnable=true
AutomaticLogin=<my_user>
---

in custom.conf does nothing.

But it works in gdm.conf-custom

Sebastien Bacher (seb128) wrote :

the configuration file has always been named gdm.conf-custom in ubuntu is that an issue?

Changed in gdm (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: Confirmed → Incomplete
Hernando Torque (htorque) wrote :

Issue #1: Upgrading from 2.20 to 2.26 leaves you with two configuration files. Pretty confusing I'd say - especially because you have to manually configure GDM since there is no graphical tool (yet?) to do it.

Issue #2: Fresh installations just install 'custom.conf', which isn't used (yet?) by GDM. Again, if you want to configure GDM you'd probably put the information into that file rather than creating a new file called 'gdm.conf-custom' (which IS used by GDM).

Martin Pitt (pitti) wrote :

Indeed upstream uses /etc/gdm/custom.conf, and we have a patch which changes the name to be loaded. We should remove that patch, move an existing gdm.conf-custom to custom.conf during upgrade.

Changed in gdm (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → Martin Pitt (pitti)
status: Incomplete → In Progress
Martin Pitt (pitti) wrote :

This also needs to be adapted in casper and oem-config.

Changed in casper (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
status: New → Triaged
Changed in gdm (Ubuntu):
importance: Low → Medium
Changed in oem-config (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
importance: Undecided → Medium
status: New → Triaged
Martin Pitt (pitti) on 2009-07-06
Changed in gdm (Ubuntu):
status: In Progress → Fix Committed
Colin Watson (cjwatson) on 2009-07-06
Changed in user-setup (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
importance: Undecided → Medium
status: New → Fix Committed
Changed in oem-config (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package user-setup - 1.27ubuntu4

---------------
user-setup (1.27ubuntu4) karmic; urgency=low

  * Use /etc/gdm/custom.conf rather than /etc/gdm/gdm.conf-custom (LP:
    #395861).

 -- Colin Watson <email address hidden> Mon, 06 Jul 2009 14:25:38 +0100

Changed in user-setup (Ubuntu):
status: Fix Committed → Fix Released
Sebastien Bacher (seb128) wrote :

we used to use the gdm configure option to rename the file to gdm.conf-custom, should we keep doing that now?

Martin Pitt (pitti) wrote :

Sebastien, I think we should use custom.conf, like upstream. I fixed this in bzr.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gdm - 2.26.1-0ubuntu3

---------------
gdm (2.26.1-0ubuntu3) karmic; urgency=low

  * Add 03_hide_system_users.patch: Do not show system users in the "frequent
    users" list. (LP: #395281)
  * debian/rules: Call dh_installinit with --no-scripts, to avoid restarting
    gdm (and killing your X session) during upgrade. The prerm/postinst
    scripts already have code to reload gdm if appropriate. Unfortunately this
    doesn't help to fix the upgrade from 0ubuntu2, its prerm already kills it.
    (LP: #395302) This also fixes the "locks session and spawns a second X
    server" issue on upgrades from Jaunty. (LP: #395313)
  * Drop 16_correct_customconf_naming.patch: Upstream uses
    and installs /etc/gdm/custom.conf, so gdm also needs to read this. Add
    debian/gdm.preinst to migrate the old name to the new name on upgrades.
    (LP: #395861)
  * 02_dont_force_us_keyboard.patch: Don't return NULL in
    get_default_layout(), but return an empty string and explicitly check this
    when setting $GDM_KEYBOARD_LAYOUT. With NULL, gdm trips over an assertion
    check. (LP: #395595)

 -- Martin Pitt <email address hidden> Mon, 06 Jul 2009 16:04:25 +0200

Changed in gdm (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package casper - 1.180

---------------
casper (1.180) karmic; urgency=low

  [ Colin Watson ]
  * scripts/casper-bottom/15autologin: Minor consistency fixes.

  [ Martin Pitt ]
  * scripts/casper-bottom/15autologin: Update for new gdm custom configuration
    file (/etc/gdm/custom.conf). (LP: #395861)

 -- Martin Pitt <email address hidden> Mon, 06 Jul 2009 16:40:00 +0200

Changed in casper (Ubuntu):
status: Triaged → Fix Released
Marques Johansson (marques) wrote :

This is a little off topic and perhaps fodder for another bug, but I had serious gdm problems after this last batch of gdm and x updates because my gdm custom file had an alternate server defined (by myself long ago). I had the X path of /usr/X11R6/bin/X which no longer works (due to a recent change). /usr/X11R6/bin no longer exists.

I'm not complaining (although I was confused for a little while). Folks that have used gdm custom configs in this way are sure to run into the same problem.

Colin Watson (cjwatson) wrote :

I fixed this in oem-config, but the autologin-disabling code was lost when oem-config was merged into ubiquity recently. I've restored it and re-merged my fix.

affects: oem-config (Ubuntu) → ubiquity (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 1.99.1

---------------
ubiquity (1.99.1) karmic; urgency=low

  [ Colin Watson ]
  * Use dh_lintian.
  * Restore autologin-disabling code from oem-config, corrected to work with
    new gdm (LP: #395861).

  [ Evan Dandrea ]
  * Add support for ubiquity-slideshow.
  * Debconf GET returns the default value if no value is set on a
    question. As an undesirable default is set for netcfg/get_hostname,
    check the seen flag to see if the value returned by GET was inputted
    by the user (LP: #401919).
  * Do not try to run Migration Assistant for the KDE frontend.
  * Automatic update of included source packages: partman-base
    132ubuntu1, partman-target 62ubuntu1.

  [ Mario Limonciello ]
  * Divert the ubiquity-gtkui.desktop file when oem-config is installed as
    oem-config now depends on ubiquity.

  [ Michael Terry ]
  * GTK frontend: Remove horizontal separator at bottom, and let timezone
    map fill its allocated space
  * GTK frontend: Have all buttons set use_underline to True. LP: #399005
  * noninteractive frontend: Don't tell debconf the translated name of the
    chosen language, but rather the language code.

 -- Evan Dandrea <email address hidden> Tue, 21 Jul 2009 17:43:37 +0100

Changed in ubiquity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers