gdm 2.26 appears on wrong monitor

Bug #395314 reported by Max Bowsher on 2009-07-03
122
This bug affects 25 people
Affects Status Importance Assigned to Milestone
gdm
Expired
Medium
gdm (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gdm

I have two monitors, using nVidia TwinView.

gdm 2.20 appeared on my primary monitor

gdm 2.26 appears on my secondary monitor

ProblemType: Bug
Architecture: amd64
Date: Fri Jul 3 21:19:02 2009
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: nvidia
Package: gdm 2.26.1-0ubuntu2
ProcEnviron:
 LC_COLLATE=C
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-1.14-generic
SourcePackage: gdm
Uname: Linux 2.6.31-1-generic x86_64

Max Bowsher (maxb) wrote :
Max Bowsher (maxb) wrote :

Empirically is seems that gdm 2.26 is appearing on whichever monitor contains the mouse pointer, which in my case at bootup seems to be one pixel right of centre, putting it just onto my secondary monitor. I assume gdm 2.20 tried to pick the primary monitor.

Sebastien Bacher (seb128) wrote :

Thank you for your bug report. The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Changed in gdm (Ubuntu):
importance: Undecided → Low
Changed in gdm (Ubuntu):
status: New → Triaged
Changed in gdm:
importance: Undecided → Unknown
status: New → Unknown
Changed in gdm (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
Changed in gdm:
status: Unknown → New
Tim Lunn (darkxst) wrote :

I am also having this problem, on Karmic/gdm 2.28.0

Michal Bořek (mibo) wrote :

I am also having this problem. (Karmic/gdm 2.28.0/nvidia 185.18.36)

Michal Bořek (mibo) wrote :

Gdm appears on monitor where is mouse pointer while system starting.

Luke J Militello (kilahurtz) wrote :

Is there a way to add an option in gdm.conf to tell gdm which display is the primary (that it should appear on)?

YitzchokL (yitzchok+launchpad) wrote :

I'm adding my comment here rather than to the Gnome bug tracker because I don't have an account there, and here I can reference Ubuntu versions

According to lspci my graphics card is
VGA compatible controller: nVidia Corporation G71 [GeForce 7300 GS] (rev a1)

On Jaunty the login prompt always appeared on the primary monitor (left). On Karmic (upgraded on-line today 25/Dec/09) the login prompt seems to be dependent on the mouse position as described above. I seem to recall that the mouse always was in the middle of the two screens, just to the right.

Interestingly at the point at which you have to put your mouse on the main screen to get the login prompt to appear there, you can't actually see the mouse pointer on that screen; it seems to be hidden by the Ubuntu splash screen.

Cosworth (keld-hjortskov) wrote :

a quick workaround for this problem is to add:

Option "TwinViewOrientation" "CRT-0 RightOf TV-0"

to the device section in xorg.conf. CRT-0 is in my case the primary monitor.

Joerg Friede (jfriede) wrote :

Another quick workaround (if not already posted somewhere else) that worked for me:

- install xwit from using apt-install or synaptics
- add the following line to /etc/gdm/Init/Default or another script that gets called by gdm prior to login

xwit -root -warp 500 500 #or use any other x/y coordinates that lie within the range of the primary monitor

Hope this helps

Rocko (rockorequin) wrote :

Thanks, Joerg! It works a treat.

Changed in gdm:
importance: Unknown → Medium
repley (repley) wrote :

I also have the same problem, but not only gdm login form appear on the second monitor, but also truecrypt password form and amsn main window at first start-up.

I'm on ubuntu 10.10

repley (repley) wrote :

... and also amsn popup that appear when user logged in

Changed in gdm:
status: New → Fix Released
Changed in gdm:
status: Fix Released → New
Dàrent (animaletdesequia) wrote :

This is an old bug, but just in case somebody is still experiencing it in a newer release, I can confirm than this problem is due to the mouse appearing in the exact center of both displays (nvidia gtx 550 ti in my case, two monitors 1024x768 with twin view) and gdm thinks than it's on the one of the right, since must be one pixel to the right or left since technicaly there's no real "center" betwen both screens.

The solution from post Joerg in post #11 worked for me, thanks a lot! It forces gdm to set the mouse closer to the 0x0 coordinates, making it appear in the first monitor by default and so the gdm, login screen, language selector, etc...

Thanks again man :)

<rant>
How can a bug that was reported almost 3 years ago and affects many people reproducably still exist? Then again, GNOME developers probably consider it a feature.
Yet another case of GNOME (and Ubuntu) breaking stuff that worked fine for a decade, and then making a point of not listening to the users who complain. I have so many examples of this by now, I stopped counting. byebye GNOME, byebye UBUNTU, it was nice while it lasted (the first few years anyway, lately it just sucks).
</rant>

Tim Lunn (darkxst) wrote :

Looks like this issue has finally been resolved, by way of the new NVIDIA 302 drivers supporting XRandr!

Changed in gdm:
status: New → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.