/etc/init.d/gdm check for 'text' in /proc/cmdline should not match within words

Bug #294980 reported by Sundar Nagarajan on 2008-11-07
2
Affects Status Importance Assigned to Milestone
gdm (Ubuntu)
Low
Michael Vogt

Bug Description

Line 49 of /etc/init.d/gdm checks for 'text' in kernel command line, and if present, does not start the Display Manager. However, the script does
  grep -qs text /proc/cmdline
which will match anything on the kernel command line that includes 'text' (including a UUID, kernel image or initrd filename or any other kernel parameter including the string 'text'. This is probably not what is expected.

I suggest replacing line 49 to read as follows instead:
        if grep -qsw text /proc/cmdline; then
This will match 'text' only as a separate word, and is probably what was intended.

Related branches

Sebastien Bacher (seb128) wrote :

thank you for your bug report, michael you did the change any opinion about that one?

Changed in gdm:
assignee: nobody → mvo
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gdm - 2.20.8-0ubuntu6

---------------
gdm (2.20.8-0ubuntu6) jaunty; urgency=low

  * debian/control.in:
    - don't depends on xbase-clients the depends workarounded an old xorg issue
    - don't recommends ubuntu-sounds since it is installed by default on ubuntu
      use a suggests and let other distribution install it or not (lp: #260558)
    - recommends alsa-utils rather than depends on it, only gdmplay it using it
      which is not something required to use the login screen (lp: #293075)
  * debian/gdm.init:
    - use w argument to match only the "text" word (lp: #294980)
  * debian/gdmplay:
    - update to fix quoting issue, Antonio Salazar suggested the change
      (lp: #281518)
  * debian/patches/11_powermanagement.patch:
    - "Don't offer hibernate option if no swap partitions exist.
       LP: #320208", thanks to Michael Terry who worked on the change

 -- Sebastien Bacher <email address hidden> Wed, 28 Jan 2009 13:53:48 +0100

Changed in gdm:
status: New → Fix Released
Loïc Minier (lool) wrote :

I did this change in Debian in 2.20.7-2 which was uploaded to unstable in August; too bad we had no merge of it. :-/

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers